Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Systems and Services > OS X

Reply
 
Thread Tools Search this Thread Display Modes
Old Mar 4, 2009, 01:10 PM   #1
siavash
macrumors newbie
 
Join Date: Feb 2008
Airport Shows Connection (Full Bars) But Can't Access Internet!

This problem has been going on for a couple of months now. I use my macbook at 2 places: school and home.
At school, when I click the school network under airport, it connects and shows the full bars. But when I open safari/firefox, the page won't load and I get the error message when you're not connected. However, sometimes after like an hour of persisting and retrying, it will be able to access the internet for a little bit for like an hour or so maybe, and then it'll stop working.

At home, it's the same thing. It will connect to my home network (got wireless at home set up through my desktop PC), and show the full connection on airport, but it won't access the internet for the life of me. The difference is I can never gt it to connect unlike at school where it sometimes works, except that it worked for like one day out of the last 2 months (and I didn't change any settings then so it's not like I can attribute it to that).

Also, I am absolutely positive that the networks of my home/school computer and the router settings etc. aren't to blame. Reason is that my friends with macbooks can access the internet both using my home network and the school network (the school one is obvious).

What could possibly be going wrong? Any settings on my macbook that I can change / completely reset? Is the network card or something messed up? I'm contemplating just completely formatting my laptop to see if it fixes the issue. I have leopard installed btw.
siavash is offline   0 Reply With Quote
Old Mar 6, 2009, 02:02 AM   #2
alphaod
macrumors Core
 
alphaod's Avatar
 
Join Date: Feb 2008
Location: 上海 (Shanghai)
Are you geting an IP address? Try deleting the AirPort adapter from Network Prefs, restart, re-add and restart again.
__________________
Mac Pro | iMac | Mac mini | MacBook Pro | MacBook Air | iPad | iPhone | iPod
alphaod is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > OS X

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
thread Thread Starter Forum Replies Last Post
Internet connection working properly but can't access internet? tehuberc Mac Basics and Help 1 Nov 15, 2010 09:24 AM
Airport connected but can't get Internet? Logo2010 MacBook Pro 3 Sep 1, 2010 08:23 AM
Macbook and Netgear Problems. Able to connect, but can't access internet. MurkyDreams MacBook 0 Jan 3, 2010 07:52 PM
[Open Wi-Fi] Can connect to Hotspot but can't use internet? loisd OS X 0 Aug 17, 2009 01:50 PM
Connected to network but can't use internet. ipodtouchftw iPod touch 4 Jul 5, 2008 11:20 AM


All times are GMT -5. The time now is 06:09 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC