Go Back   MacRumors Forums > Apple Hardware > Notebooks > MacBook Pro

Reply
 
Thread Tools Search this Thread Display Modes
Old May 16, 2009, 12:57 AM   #1
macdude69
macrumors member
 
Join Date: Aug 2007
Battery stopped charging / sleep issues after 10.5.7

So I updated to 10.5.7, then that night, I noticed my computer wouldn't go to sleep right. Next day, noticed that my battery was not charging up (yet the computer was plugged in - green light was very dim).

Maybe it's a strange coincidence... with updating to 10.5.7 at the same time

Took it to apple store today and they sent it away, determined it was something internal (logic board ?). I am out of my 1 year warranty, so they estimated it at 325 bucks... fortunately I got it with my AmEx and I can make a claim though them to pay for it.

Anyone else ever have this problem? I haven't seen anyone else say something like this happened to their computer after 10.5.7.

I have had really nothing but problems with this computer.
Last summer I had the screen + battery replaced.

MBP 2.2 ghz (mid 2007) 15 inch
macdude69 is offline   0 Reply With Quote
Old May 16, 2009, 11:34 AM   #2
jav6454
macrumors G5
 
jav6454's Avatar
 
Join Date: Nov 2007
Location: 1 Geostationary Tower Plaza
Quote:
Originally Posted by macdude69 View Post
So I updated to 10.5.7, then that night, I noticed my computer wouldn't go to sleep right. Next day, noticed that my battery was not charging up (yet the computer was plugged in - green light was very dim).

Maybe it's a strange coincidence... with updating to 10.5.7 at the same time

Took it to apple store today and they sent it away, determined it was something internal (logic board ?). I am out of my 1 year warranty, so they estimated it at 325 bucks... fortunately I got it with my AmEx and I can make a claim though them to pay for it.

Anyone else ever have this problem? I haven't seen anyone else say something like this happened to their computer after 10.5.7.

I have had really nothing but problems with this computer.
Last summer I had the screen + battery replaced.

MBP 2.2 ghz (mid 2007) 15 inch
Maybe your battery went down again. Wouldn't surprise me if it's the same issue. On the not sleeping issue I guesstimate that maybe your logic board or sensor also gave and it isn't necessarily 10.5.7's fault, maybe it made those problems come to view before they got worse.
__________________
Al MacBook 2.4GHz Late '08 | 5 S⃣ | Macross Click Me
jav6454 is offline   0 Reply With Quote
Old May 16, 2009, 11:07 PM   #3
jojo712
macrumors newbie
 
Join Date: May 2009
Same Issue

I have got the same problem with just about the same Mac, except 2.16ghz. The day before 10.5.7, it was charging just fine and giving me approximately three hours of use on a three month old battery; today, the battery is completely discharged, and the computer will not work at all unless it is plugged in 100% of the time.

The fact that this would happen in two Macs at the same time is no coincidence, and leads me to believe that this is purely a software issue. If anyone else can confirm or deny this, please let us know, because it looks like there's more than one of us out there.

Jesus
jojo712 is offline   0 Reply With Quote
Old May 17, 2009, 06:48 AM   #4
philips
macrumors regular
 
Join Date: Oct 2004
Location: Baden-WŁrttemberg, Germany
My UMBP17 from signature sleeps fine after update.

P.S. And that was first time I seen such colossal update being downloaded/installed (with all reboots) in under 15 minutes. SSD is ********** amazing.
__________________
PowerBook G4 12" @ 997MHz
iPod Nano Black 8G
Ub MacBook Pro 17" Matte/SSD (early '09)
Panasonic GX7 // 20mm
philips is offline   0 Reply With Quote
Old May 17, 2009, 09:05 AM   #5
youssefm
macrumors 6502
 
Join Date: Oct 2008
Did you try resetting the smc?
http://support.apple.com/kb/HT1411
youssefm is offline   0 Reply With Quote
Old May 17, 2009, 06:22 PM   #6
macdude69
Thread Starter
macrumors member
 
Join Date: Aug 2007
i tried that SMC reset, no effect

i also tried to do the PRAM reset but couldn't get it to work right with the Open Firmware password and then the battery ran completely out

i tried everything else I could think of, nothing work

perhaps, it was something in the 10.5.7 that brought out this problem

i am very worried about this computer because i think it might just be prone to fail. screen, battery, (last year) now logic board all have to be replaced. i just know that after my amex extended warranty runs out, something new is gonna break.

----------

i just called to cancel the work on my laptop (they haven't even sent it out yet) cause I have to file a claim with American Express first (they offer an extended warranty, 1 extra year) --- anyone have any experience with this process???

----------

so at the apple store, the guy tried a new battery and it booted fine but would still not charge it (so its not just the battery)

they also tried my power adapter and it worked to charge another computer (so its not the adapter)
they also tried a new power adapter and it didn't work with my computer

Last edited by macdude69; May 17, 2009 at 06:28 PM.
macdude69 is offline   0 Reply With Quote
Old May 17, 2009, 06:25 PM   #7
macdude69
Thread Starter
macrumors member
 
Join Date: Aug 2007
Quote:
Originally Posted by jojo712 View Post
I have got the same problem with just about the same Mac, except 2.16ghz. The day before 10.5.7, it was charging just fine and giving me approximately three hours of use on a three month old battery; today, the battery is completely discharged, and the computer will not work at all unless it is plugged in 100% of the time.

The fact that this would happen in two Macs at the same time is no coincidence, and leads me to believe that this is purely a software issue. If anyone else can confirm or deny this, please let us know, because it looks like there's more than one of us out there.

Jesus
well its good to see I'm not the only one here with this problem

but for me, i can't even get it to work on direct power without a battery, you are lucky, at least you can use your computer, i can't
macdude69 is offline   0 Reply With Quote
Old Jun 2, 2009, 03:07 PM   #8
macdude69
Thread Starter
macrumors member
 
Join Date: Aug 2007
update on this

they replaced the logic board / some i/o thing / dvd drive / top case
and now it's running great again

it was 325 bucks
which AmEx should pay once they review my claim
macdude69 is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Notebooks > MacBook Pro

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
iPhone 5s stopped charging via car USB Route20bear iPhone 6 Aug 16, 2014 07:46 PM
Charging sound stopped macmesser iPad Tips, Help and Troubleshooting 7 Sep 3, 2013 06:51 PM
Help - Battery charging issues Pioneerbob MacBook Pro 1 Dec 30, 2012 12:58 PM
MacBook stopped charging last night, fixed but now what? diane143 MacBook 1 Jul 19, 2012 01:55 PM
MBP Retina Sleep/Battery Issues 3leggeddog MacBook Pro 1 Jul 18, 2012 01:46 PM

Forum Jump

All times are GMT -5. The time now is 11:27 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC