Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > iPhone, iPod and iPad > iPhone > iPhone Tips, Help and Troubleshooting

Reply
 
Thread Tools Search this Thread Display Modes
Old Jul 16, 2009, 02:55 AM   #1
andylyon
macrumors 6502a
 
andylyon's Avatar
 
Join Date: Jul 2008
Location: London
iPhone apps wont open..

I tried searching but came up with nothing specific to this problem.

I need help, whenever I try to load an apps they just flash open for a few seconds and the screen returns to the apps page the app was on. This does not happen for the apps that came with the phone. Just the 30 or so that i've got from the app store.

Any advice?

AnDy
__________________
Andy MacBook Air 11" Mountain Lion 10.9.1 | iPhone 5 iOS 7.0.5
andylyon is offline   0 Reply With Quote
Old Jul 16, 2009, 02:59 AM   #2
ajnicho
macrumors 6502a
 
Join Date: Sep 2008
Quote:
Originally Posted by andylyon View Post
I tried searching but came up with nothing specific to this problem.

I need help, whenever I try to load an apps they just flash open for a few seconds and the screen returns to the apps page the app was on. This does not happen for the apps that came with the phone. Just the 30 or so that i've got from the app store.

Any advice?

AnDy
This happened on a friend phone. I just deleted all the apps and resynced with iTunes. they seem to work now.
ajnicho is offline   0 Reply With Quote
Old Jul 16, 2009, 05:10 AM   #3
Ingster
macrumors regular
 
Join Date: Apr 2007
Location: Leeds, UK
Mine did something very similar - have you put the tether 'hack' on your iphone? i just used an old backup to restore and everything became good again!
__________________
Duct tape is like the force, it has a light side, a dark side and holds the galaxy together
Ingster is offline   0 Reply With Quote
Old Jul 16, 2009, 05:41 AM   #4
andylyon
Thread Starter
macrumors 6502a
 
andylyon's Avatar
 
Join Date: Jul 2008
Location: London
Quote:
Originally Posted by Ingster View Post
Mine did something very similar - have you put the tether 'hack' on your iphone? i just used an old backup to restore and everything became good again!
No hack what so ever!
__________________
Andy MacBook Air 11" Mountain Lion 10.9.1 | iPhone 5 iOS 7.0.5
andylyon is offline   0 Reply With Quote
Old Jul 16, 2009, 07:33 AM   #5
andylyon
Thread Starter
macrumors 6502a
 
andylyon's Avatar
 
Join Date: Jul 2008
Location: London
SoLvEd

In the meantime, I started deleting apps before re-syncing with iTunes later today and all of a sudden they all started working. Maybe one of the four I deleted was causing a conflict with another maybe? I don't know but I'm just glad my new expensive phones works as it should now!

AnDy
__________________
Andy MacBook Air 11" Mountain Lion 10.9.1 | iPhone 5 iOS 7.0.5
andylyon is offline   0 Reply With Quote
Old Jul 16, 2009, 07:42 AM   #6
isaaclimdc
macrumors 6502
 
Join Date: Jun 2009
Location: Pittsburgh, PA
Send a message via Skype™ to isaaclimdc
Are you Jailbroken?
__________________
 13" MacBook Air (Mid-2012), OS X Mountain Lion, iPhone 4 (GSM) 32GB
isaaclimdc is offline   0 Reply With Quote
Old Jul 16, 2009, 07:59 AM   #7
andylyon
Thread Starter
macrumors 6502a
 
andylyon's Avatar
 
Join Date: Jul 2008
Location: London
Quote:
Originally Posted by isaaclimdc View Post
Are you Jailbroken?
Nope, no hacks or anything.
__________________
Andy MacBook Air 11" Mountain Lion 10.9.1 | iPhone 5 iOS 7.0.5
andylyon is offline   0 Reply With Quote
Old Jul 16, 2009, 09:42 AM   #8
teeceegee
macrumors newbie
 
Join Date: Mar 2009
I used to get this a lot (as did my other half). I would find that deleting apps or adding a new one would fix it. However, since I installed an app called Free Memory I hardly ever have this problem. All I do is run Free Memory a couple of times a day to clear up the memory usage and all seems to be fine. It also gives a battery level % indicator (within the app).

I have no connection with the app developer whatsoever.

TCG
teeceegee is offline   0 Reply With Quote
Old Jul 16, 2009, 09:46 AM   #9
lavinci
Banned
 
Join Date: Jun 2009
Just resync them or do a fresh restore. Sometimes my apps would have different icons, like the AIM app would have a Pandora icon.
lavinci is offline   0 Reply With Quote
Old Jul 17, 2009, 02:17 AM   #10
Tfrost
macrumors newbie
 
Join Date: Nov 2008
Had the same problem. I downloaded a new app and the others opened again?
Tfrost is offline   0 Reply With Quote
Old Jul 17, 2009, 02:42 AM   #11
colmaclean
macrumors 68000
 
colmaclean's Avatar
 
Join Date: Jan 2004
Location: Berlin
I had this problem last night. I remedied it by removing an affected app from the iPhone and re-installing it through the phone's AppStore (not iTunes).

No idea why I got into this situation. If it was a fragmented memory issue, you'd think rebooting the phone would fix it - it didn't.
colmaclean is offline   0 Reply With Quote
Old Jul 17, 2009, 02:44 AM   #12
337894
Guest
 
Join Date: Jul 2009
Finally! At least I'm not the only one!!!! By the way, my iPhone hasn't been hacked, jailbroken, or anything. This sane thing happened to my iPhone 3gs and I was frustrated because all of a sudden my apps wouldn't launch and one of my apps (jumi mouse) showed it's name as skype spthat was something weird. I did a restore from one of my iPhone backups and it did the sane thing so I scheduled an appointment with the genius bar and they said that it was probably a corrupt driver or something that was corrupt in the OS. So they did an iPhone resotre at their store and they handed my iPhone back tellig me to download an app (which I did) using the apple store's wi-fi and I launched te free app that I downloaded and it worked!! So there was something wrong with the is or drivers for launching the apps. So after that, I was happy, got home, did a iPhone restore from the backup of one of my previous iPhone backups that iTunes had done automatically when I synced my iPhone. So zoom forward about 4 to 3 hours, and my restore is finally finished. As I would expect, my apps would launch after the restore, but they wouldn't!! I was really frustrated after that and knew that there was something wrong with one of my backups. Right now, i'm waiting until Saturday because I had schedlued another genius bar appointment on Saturday so I can get my iPhone fixed. Hopefully, they'll fix it so I can go home and finally use my apps.

also, I'm going to tell them about my apps not launching experience so hopefully they'll tell me click the set up as new iPhone instead of restoring it from a backup which will hopefully have all of my purchased apps, music, and etc. (like my contacts). In addition, I'm going to ask them why my iPhone has poor connectivity (it was good when I first got my iPhone and now it's starting to get bad!!! It's odd!) and why it shows stuff like bad 404 gateway when I search on wikipedia do suddenly, YouTube movie can't be played, my iPhone makes rattling sounds when I shake it when playing apps, and etc.)


Sorry I just wanted to tell everyone about this because I thought it was an isolated problem.
337894 is offline   0 Reply With Quote
Old Jul 24, 2009, 01:26 PM   #13
jeffkimlv
macrumors newbie
 
Join Date: Jul 2009
Apps close abruptly after upgrade or sync

OK everyone. I’ve used several of the above posts and did not get my apps to open. I think that each one worked for different reasons, but that there were other steps that took place in each that weren’t documented fully. I think I may have all the steps needed that finally worked for me using the information from each successful attempt above. Here goes:
1. In the iPhone go to Settings>Store and sign out of your account if you are already signed in.
2. Delete all the “Apple Apps” from your iPhone.
3. Open iTunes (don’t connect your phone) and in the menu bar go to Store>Deauthorize Computer and deauthorize it.
4. In iTunes navigate to “Applications” and delete all of your applications (when asked: move to recycle bin).
5. Now download just one of your applications.
6. Plug in your iPhone to connect it to iTunes.
7. Navigate to the Application page of your iPhone and check “Sync Applications” “All Applications” (you should just see one application as you have deleted all the others.
8. Now press sync.
9. At some point iTunes will tell you that it did not sync the application because your computer was not “authorized” go ahead and “authorize” it now.
10. Perform another sync. It will now sync the one application.
11. Test the application on your iPhone to make sure it works.
12. Wha-La! You can now add as many apps as you want.
jeffkimlv is offline   0 Reply With Quote
Old Jul 24, 2009, 01:30 PM   #14
andylyon
Thread Starter
macrumors 6502a
 
andylyon's Avatar
 
Join Date: Jul 2008
Location: London
Quote:
Originally Posted by jeffkimlv View Post
OK everyone. I’ve used several of the above posts and did not get my apps to open. I think that each one worked for different reasons, but that there were other steps that took place in each that weren’t documented fully. I think I may have all the steps needed that finally worked for me using the information from each successful attempt above. Here goes:
1. In the iPhone go to Settings>Store and sign out of your account if you are already signed in.
2. Delete all the “Apple Apps” from your iPhone.
3. Open iTunes (don’t connect your phone) and in the menu bar go to Store>Deauthorize Computer and deauthorize it.
4. In iTunes navigate to “Applications” and delete all of your applications (when asked: move to recycle bin).
5. Now download just one of your applications.
6. Plug in your iPhone to connect it to iTunes.
7. Navigate to the Application page of your iPhone and check “Sync Applications” “All Applications” (you should just see one application as you have deleted all the others.
8. Now press sync.
9. At some point iTunes will tell you that it did not sync the application because your computer was not “authorized” go ahead and “authorize” it now.
10. Perform another sync. It will now sync the one application.
11. Test the application on your iPhone to make sure it works.
12. Wha-La! You can now add as many apps as you want.
Kind of a long-winded solution though isnt it? If you have pages and pages of apps its a long process to restore them one by one.

AnDy
__________________
Andy MacBook Air 11" Mountain Lion 10.9.1 | iPhone 5 iOS 7.0.5
andylyon is offline   0 Reply With Quote
Old Nov 28, 2009, 03:19 AM   #15
buymeaniphone
macrumors 6502
 
Join Date: Feb 2007
Location: San Antonio, Texas
What worked for me was doing a restore through iTunes and then when it asked me if I wanted to use a previous backup, I just picked one from a few months ago. All my apps were still in my Applications section in iTunes so I just had to go through and check them off and sync after it restored from the backup. Fixed the problem and was better than completely starting from scratch.
__________________
Omar C
Head Geekster at GeeksterLabs.com - News & Video Reviews
buymeaniphone is offline   0 Reply With Quote
Old Nov 28, 2009, 01:18 PM   #16
firewood
macrumors 603
 
Join Date: Jul 2003
Location: Silicon Valley
Often, just deleting one free app and signing out from your iTune account on the iPhone, then redownloading that one free app and signing back in to your iTunes account will fix the problem for all apps that were purchased with that same account.

It's like the iPhone forgets the account info for all authorized apps and needs to be reminded.
firewood is offline   0 Reply With Quote
Old Jul 7, 2010, 10:34 AM   #17
Kayla1224
macrumors newbie
 
Join Date: Jul 2010
Iphone...agh!

I just got my Iphone working after it being stuck on the apple logo for 20 minutes or so..after my Iphone finally started up again my apps wouldnt open..so I updated an app and now they all work perfectly once again..
I hope I can help ;D
Kayla1224 is offline   0 Reply With Quote
Old Nov 7, 2011, 01:42 PM   #18
Conrod
macrumors newbie
 
Join Date: Nov 2011
Easy fix

Download a new app. I had this problem today. I read this and didn't want to do what everyone else did. I just downloaded the weather network app (at random) and now all my apps work. Boom!
Conrod is offline   0 Reply With Quote
Old Jan 22, 2012, 09:49 PM   #19
Keithc2485
macrumors newbie
 
Join Date: Jan 2012
Same thing is happening to new

Quote:
Originally Posted by andylyon View Post
I tried searching but came up with nothing specific to this problem.

I need help, whenever I try to load an apps they just flash open for a few seconds and the screen returns to the apps page the app was on. This does not happen for the apps that came with the phone. Just the 30 or so that i've got from the app store.

Any advice?

AnDy
I am soo baffeled dude they work like once a week maybe . Other then that
Same thing they blink n stay open in the open bar but realllly. Won't open again
Same thing only apps I dl. Wtf if any knows anything plz help. Only thing I can think of is a bug or virus
Keithc2485 is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iPhone > iPhone Tips, Help and Troubleshooting

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
thread Thread Starter Forum Replies Last Post
Is there a software available for making iPad or iPhone apps technoawareness iPhone/iPad Programming 29 Mar 30, 2012 04:36 AM
Begin Making iPhone Apps applereviewguy iPhone and iPod touch Apps 1 Oct 18, 2011 11:42 PM
An upcoming iPhone app from Punflay- My Word Wall Zacherena iPhone and iPod touch Apps 3 Jun 10, 2011 04:03 AM
iPhone App Testing Help? jonclarkccnp iPhone and iPod touch Apps 3 Nov 11, 2010 08:21 AM
iPhone app which reads out caller ID? emilemac iPhone and iPod touch Apps 1 Nov 7, 2010 08:08 AM


All times are GMT -5. The time now is 04:23 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC