Go Back   MacRumors Forums > Apple Systems and Services > Mac Basics and Help

Reply
 
Thread Tools Search this Thread Display Modes
Old Aug 4, 2009, 04:18 AM   #1
sk8mash
macrumors 6502a
 
sk8mash's Avatar
 
Join Date: Dec 2007
Location: England
JavaScript not working with Safari.

If I try to go on YouTube in Safari I get a message saying "Hello, you either have JavaScript turned off or an old version of Adobe's Flash Player." I downloaded the newest version as it prompted me to, but its still not working. I also checked I have JavaScript turned on, and I do. I just tried it in Firefox and it's working fine...

Anyone know where I'm going wrong? It was working perfectly earlier...

Edit: Also, I just tried the Ad Gallery on Apple's website and it says "Quicktime required for free download". What gives?
__________________
27" iMac 3.2GHz - 11" MacBook Air 1.4Ghz - iPad Air 32GB - iPhone 5S 32GB

Last edited by sk8mash; Aug 4, 2009 at 05:16 AM.
sk8mash is offline   0 Reply With Quote
Old Aug 4, 2009, 07:03 AM   #2
wrldwzrd89
macrumors G4
 
wrldwzrd89's Avatar
 
Join Date: Jun 2003
Location: Solon, OH
Several things to check:
  1. The issue's obviously not JS-related, so check your plugins.
  2. Did you run the Flash Player 10 installer (and make sure it's the Universal one, if you have an Intel Mac)
  3. You'll need to close your browsers during the installation. If you didn't, you must manually restart them before they'll see the new plugin.
__________________
iMac Intel (Rev H, 27"), 1TB HDD, 16GB RAM, 10.8.4
wrldwzrd89 is offline   0 Reply With Quote
Old Aug 4, 2009, 07:28 AM   #3
sk8mash
Thread Starter
macrumors 6502a
 
sk8mash's Avatar
 
Join Date: Dec 2007
Location: England
Quote:
Originally Posted by wrldwzrd89 View Post
Several things to check:
  1. The issue's obviously not JS-related, so check your plugins.
  2. Did you run the Flash Player 10 installer (and make sure it's the Universal one, if you have an Intel Mac)
  3. You'll need to close your browsers during the installation. If you didn't, you must manually restart them before they'll see the new plugin.
What are plugins? I have Flip4Mac installed if thats anything to do with it? But I have been using that for ever...It was working fine, then next time I tired to watch a video, it just stopped working. I just tried installing the OSX Flash again, with the browser close, then restarted, and its still not working...
__________________
27" iMac 3.2GHz - 11" MacBook Air 1.4Ghz - iPad Air 32GB - iPhone 5S 32GB
sk8mash is offline   0 Reply With Quote
Old Aug 4, 2009, 11:51 AM   #4
sk8mash
Thread Starter
macrumors 6502a
 
sk8mash's Avatar
 
Join Date: Dec 2007
Location: England
This is still not working....very frustrating. Please help.
__________________
27" iMac 3.2GHz - 11" MacBook Air 1.4Ghz - iPad Air 32GB - iPhone 5S 32GB
sk8mash is offline   0 Reply With Quote
Old Aug 4, 2009, 12:44 PM   #5
Salmar
macrumors regular
 
Join Date: Sep 2007
Location: Florida
Okay I don't use firefox but the other day when I updated firefox to the newest version and tried to view a video on youtube I got the same message that you are receiving. I checked to see if java and javascript set and it was, and it was driving me nuts why I couldn't see the video on youtube. Then I went down to the bottom right hand corner and clicked on options and that was were the problem was. You have to ALLOW youtube to play and mine was blocked. I just clicked on allow youtube and then all was well.
Type in youtube in your address bar and then look down in the bottom right for options and then click allow you tube or words to that effect and it should work for you. Hope this helps because it was driving me nuts too.
Salmar is offline   0 Reply With Quote
Old Aug 4, 2009, 12:48 PM   #6
Salmar
macrumors regular
 
Join Date: Sep 2007
Location: Florida
Oops, I just saw where you were referring to Safari and it was already working in your firefox. I don't use safari either but perhaps there is a similar setting in Safari to enable you to see the videos. Apparently it's just being blocked somewhere in the Safari settings. Sorry I misread your original post.
Salmar is offline   0 Reply With Quote
Old Aug 4, 2009, 12:49 PM   #7
geoffreak
macrumors 68020
 
geoffreak's Avatar
 
Join Date: Feb 2008
Location: Texas; Wish I was in Japan
Try running Software Update and/or another browser.
__________________
rMBP 2.6GHz 16GB 512GB | Mac Mini 2009 2.26GHz | MBP Early '08 2.4GHz | iPhone 4S 32GB | Drobo
Nimbix - Accelerated Cloud Supercomputing
geoffreak is offline   0 Reply With Quote
Old Aug 4, 2009, 03:25 PM   #8
sk8mash
Thread Starter
macrumors 6502a
 
sk8mash's Avatar
 
Join Date: Dec 2007
Location: England
Thanks for all the suggestions. Unfortunately, I have run software update, and everything is up to date. Also this seems only to be a problem in Safari, but no just with youtube, as the apple site won't stream quicktime either as I said earlier. I'm still lost on this, any more ideas? I havn't changed any settings that could have triggered this
__________________
27" iMac 3.2GHz - 11" MacBook Air 1.4Ghz - iPad Air 32GB - iPhone 5S 32GB
sk8mash is offline   0 Reply With Quote
Old Aug 4, 2009, 03:27 PM   #9
geoffreak
macrumors 68020
 
geoffreak's Avatar
 
Join Date: Feb 2008
Location: Texas; Wish I was in Japan
Have you tried restarting the computer?
__________________
rMBP 2.6GHz 16GB 512GB | Mac Mini 2009 2.26GHz | MBP Early '08 2.4GHz | iPhone 4S 32GB | Drobo
Nimbix - Accelerated Cloud Supercomputing
geoffreak is offline   0 Reply With Quote
Old Aug 4, 2009, 03:30 PM   #10
sk8mash
Thread Starter
macrumors 6502a
 
sk8mash's Avatar
 
Join Date: Dec 2007
Location: England
Quote:
Originally Posted by geoffreak View Post
Have you tried restarting the computer?
Yep, and reinstalling Flash...multiple times...
__________________
27" iMac 3.2GHz - 11" MacBook Air 1.4Ghz - iPad Air 32GB - iPhone 5S 32GB
sk8mash is offline   0 Reply With Quote
Old Aug 5, 2009, 05:47 AM   #11
sk8mash
Thread Starter
macrumors 6502a
 
sk8mash's Avatar
 
Join Date: Dec 2007
Location: England
I just re installed Safari, and it is still not working...I'm out of ideas...

Also reinstalled flip4mac...
__________________
27" iMac 3.2GHz - 11" MacBook Air 1.4Ghz - iPad Air 32GB - iPhone 5S 32GB

Last edited by sk8mash; Aug 5, 2009 at 05:53 AM.
sk8mash is offline   0 Reply With Quote
Old Aug 5, 2009, 11:28 AM   #12
MWPULSE
macrumors 6502a
 
Join Date: Dec 2008
Location: London
Have you tried finding the .plist file for safari. It will reset your
preferences to the standard settings. Related to that might be have you blocked YouTube from activating flash there's an Orion in preferences under
content I think.

PTP
__________________

15" 2.3Ghz MBPr13, 16GB RAM, 512GB SSD; 15" 2.4Ghz MBP08, 4GB RAM, 200GB; 1.66Ghz Mac Mini06 1GB RAM, 250GB+320GB; 32GB iPhone 5
MWPULSE is offline   0 Reply With Quote
Old Aug 5, 2009, 12:07 PM   #13
sk8mash
Thread Starter
macrumors 6502a
 
sk8mash's Avatar
 
Join Date: Dec 2007
Location: England
Quote:
Originally Posted by MWPULSE View Post
Have you tried finding the .plist file for safari. It will reset your
preferences to the standard settings. Related to that might be have you blocked YouTube from activating flash there's an Orion in preferences under
content I think.

PTP
If I delete the plist would it loose my auto fill and passwords etc.? Also, its not just youtube, no videos work on any site.
__________________
27" iMac 3.2GHz - 11" MacBook Air 1.4Ghz - iPad Air 32GB - iPhone 5S 32GB
sk8mash is offline   0 Reply With Quote
Old Aug 5, 2009, 12:28 PM   #14
sk8mash
Thread Starter
macrumors 6502a
 
sk8mash's Avatar
 
Join Date: Dec 2007
Location: England
Oh, simple fix. I ticked the "enable plugins" box in Safari Preferences.

Thanks to everyone who tried!
__________________
27" iMac 3.2GHz - 11" MacBook Air 1.4Ghz - iPad Air 32GB - iPhone 5S 32GB
sk8mash is offline   0 Reply With Quote
Old Sep 14, 2009, 12:45 PM   #15
interchange42
macrumors newbie
 
Join Date: Sep 2009
I am suddenly experiencing the same trouble that Sk8mash reported here - except that the 'enable plugins' box in Safari Preferences has always been checked in my case, and unchecking it, then checking it again has not solved the problem. I also went through the whole Flash reloading, restarting etc., series of tests. anyone have any other ideas?

42
interchange42 is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > Mac Basics and Help

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
I have a javascript working great on Mozilla but not on Safari or Chrome BG29 Web Design and Development 7 Jun 16, 2013 11:07 AM
Cannot turn off Javascript in Safari pribl iPhone Tips, Help and Troubleshooting 1 Jan 17, 2013 05:11 PM
Resolved: Web browsing, Safari and Javascript cyberghoser1 PowerPC Macs 24 Jan 4, 2013 12:23 PM
Safari JavaScript loading nelly22 OS X 10.8 Mountain Lion 2 Nov 27, 2012 10:06 AM
Safari 6.0.2 and javascript Franciturci OS X 10.8 Mountain Lion 2 Nov 16, 2012 09:32 AM

Forum Jump

All times are GMT -5. The time now is 03:01 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC