Go Back   MacRumors Forums > Special Interests > Digital Audio

Reply
 
Thread Tools Search this Thread Display Modes
Old Aug 8, 2009, 12:18 PM   #1
scoot713
macrumors newbie
 
Join Date: Aug 2009
Midi Help----

So recently i just bought a Yamaha UX16 5-pin to usb wire...it goes from my Casio CTK-471 keyboard to my mac...jus bought the mac about a month or two ago so its basically brand new.

Problem:
I get the wire hooked up, go to the Midi Settings, get that all hooked up the right way and hit test settings. The Midi out is working, but not the Midi In.

Im stumped. Ive looked at about half a million different solutions and none are working.
Hopefully, some of u might have an idea.

Thanks in advance.
scoot713 is offline   0 Reply With Quote
Old Aug 8, 2009, 04:28 PM   #2
ChrisA
macrumors G4
 
Join Date: Jan 2006
Location: Redondo Beach, California
Quote:
Originally Posted by scoot713 View Post
The Midi out is working, but not the Midi In.
So you can send midi data to your keyboard and hear it play on the keyboard but when you press keys on the keyboard no data goes to the computer?

I have to ask because "in" and "out" depend on if you are sitting at the keyboard or at the computer.

What did you do to test your setup? What have you already tried?
ChrisA is offline   0 Reply With Quote
Old Aug 8, 2009, 05:30 PM   #3
scoot713
Thread Starter
macrumors newbie
 
Join Date: Aug 2009
Well, when i go to the Audio Midi Setup screen, i hooked everything up and when i hit "Test Setup" and press the Midi out arrow from the Yamaha UX16 interface to the keyboard, the light on the interface showing that the signal went out to the keyboard lights up. But when i press the keys on the keyboard the "Midi In" doesnt and the comp doesnt get the signal back.
Im not really sure what else to try.
Ive dled the Midi Monitor and its showing no signal from anything.

Also, i just got the Yamaha UX16 about 4 days ago. Installed all the software, drivers, etc. Ive also updated the driver from the Yamaha site.

When i hook up the interface to the comp it says the powers on, but im starting to wonder if somethings wrong with the actual "Midi In" cable.

Hope i explained it better, just ask if i left something out...
Thanks
scoot713 is offline   0 Reply With Quote
Old Aug 10, 2009, 06:55 AM   #4
TwoSpot
macrumors newbie
 
Join Date: Aug 2009
Location: New Jersey
I just picked up a mac on Friday. Hooked up my Presonus Firestudio Project and my Yamaha keyboard and I am having the exact problem. From the system to the keyboard works (sound emits from the keyboard speaker when I click the arrow in the MIDI utility) but when I hit the keyboard keys, I get nothing to the computer.
__________________
-Eddie
Aluminum iMac 24", 2.66Ghz C2D, 4GB RAM, 640GB HDD
TwoSpot is offline   0 Reply With Quote
Old Aug 10, 2009, 03:12 PM   #5
ChrisA
macrumors G4
 
Join Date: Jan 2006
Location: Redondo Beach, California
[QUOTE=TwoSpot;8254020]I just picked up a mac on Friday. Hooked up my Presonus Firestudio Project and my Yamaha keyboard and I am having the exact problem. From the system to the keyboard works (sound emits from the keyboard speaker when I click the arrow in the MIDI utility) but when I hit the keyboard keys, I get nothing to the computer.[/QUOTE


If your MIDI interface cable is like mine there are activity LEDs on it. If you are playing keys on the music keyboard and you don't see any flashing on the activity LED the problem is not with the Mac or software. The activity LED will flash whenever the keyboard sends midi data even if the computer is not "listening".

What you need to do is tell your keyboard to send midi. There is likely a menu option to turn this on and off. Most keyboards have dozens of midi setup options.
ChrisA is offline   0 Reply With Quote
Old Aug 10, 2009, 08:03 PM   #6
TwoSpot
macrumors newbie
 
Join Date: Aug 2009
Location: New Jersey
[QUOTE=ChrisA;8256615]
Quote:
Originally Posted by TwoSpot View Post
I just picked up a mac on Friday. Hooked up my Presonus Firestudio Project and my Yamaha keyboard and I am having the exact problem. From the system to the keyboard works (sound emits from the keyboard speaker when I click the arrow in the MIDI utility) but when I hit the keyboard keys, I get nothing to the computer.[/QUOTE


If your MIDI interface cable is like mine there are activity LEDs on it. If you are playing keys on the music keyboard and you don't see any flashing on the activity LED the problem is not with the Mac or software. The activity LED will flash whenever the keyboard sends midi data even if the computer is not "listening".

What you need to do is tell your keyboard to send midi. There is likely a menu option to turn this on and off. Most keyboards have dozens of midi setup options.
Thanks ChrisA. Interestingly enough, when I got home from work and sat down to mess with it, it magically worked. Go figure. I am good to go now. Thanks for your response!!
__________________
-Eddie
Aluminum iMac 24", 2.66Ghz C2D, 4GB RAM, 640GB HDD
TwoSpot is offline   0 Reply With Quote

Reply
MacRumors Forums > Special Interests > Digital Audio

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
MIDI to PC not working!? MxMCube Digital Audio 1 Mar 10, 2014 05:44 PM
MacBook and Midi davred MacBook 0 Jan 30, 2014 12:10 PM
Midi on iPad blastingas10 iPad Tips, Help and Troubleshooting 2 Jan 23, 2013 09:13 PM
Re Midi oldageidiot MacBook Pro 0 Jul 15, 2012 12:13 AM
Anyone using their Touch for MIDI? comatory iPod touch 1 Jun 9, 2012 02:51 PM

Forum Jump

All times are GMT -5. The time now is 07:14 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC