Go Back   MacRumors Forums > Apple Systems and Services > OS X

Reply
 
Thread Tools Search this Thread Display Modes
Old Aug 28, 2009, 06:07 PM   #1
ob22
macrumors newbie
 
Join Date: Aug 2009
Snow Leopard Font Smoothing?

Since I installed Snow Leopard I noticed that, system wide, font shading doesnt seem to be working at least for me or it looks different.
I've double checked that this is enabled and have no idea how to fix it but its annoying.
Did they change the way font shading works in 10.6 or is it my computer being weird?
Thanks
ob22 is offline   0 Reply With Quote
Old Aug 28, 2009, 06:14 PM   #2
r.j.s
Moderator emeritus
 
r.j.s's Avatar
 
Join Date: Mar 2007
Location: Fort Knox
I've noticed that the fonts look ... different as well.
r.j.s is offline   0 Reply With Quote
Old Aug 28, 2009, 06:16 PM   #3
drlunanerd
macrumors 65816
 
drlunanerd's Avatar
 
Join Date: Feb 2004
Location: UK
Subpixel font anti-aliasing working fine here. They may have ramped it up a notch from Leopard but I can't be bothered to do a side-by-side comparison at the moment
drlunanerd is offline   0 Reply With Quote
Old Aug 28, 2009, 07:08 PM   #4
ob22
Thread Starter
macrumors newbie
 
Join Date: Aug 2009
Ok so its not just me. One place I've really noticed it is in the Menu Bar, when I used to highlight something the text would almost seem bolded but now it doesnt do that.
ob22 is offline   0 Reply With Quote
Old Aug 29, 2009, 06:40 AM   #5
joerick
macrumors newbie
 
Join Date: Dec 2003
Have also noticed this. I always had font smoothing set to 'Light' in Leopard, now I've got no choice. The only place I really notice is the menus and in iTunes. Safari seems the same.

I'm sure I'll get used to it. It's just a little... unnerving!
joerick is offline   0 Reply With Quote
Old Aug 29, 2009, 07:04 AM   #6
Timan
macrumors member
 
Join Date: Dec 2003
Can try this in terminal, re-enabled subpixel font smoothing for me.

Code:
defaults -currentHost write -globalDomain AppleFontSmoothing -int 2
Timan is offline   0 Reply With Quote
Old Aug 29, 2009, 11:56 AM   #7
bob_the_gorilla
macrumors member
 
Join Date: Jun 2004
Location: Derby, UK
Send a message via AIM to bob_the_gorilla
Thanks, Timan. Seems my Mac doesn't know the display a new HP2159m, connected via DVI is an LCD? Or at least, an LCD capable of subpixel antialiasing. It didn't autodetect it in Leopard, and I had to choose it myself.

Stupidly, I saw the LCD font smoothing box was only half-checked under Snow Leopard, and wondered if the problem had been fixed so I fully checked it. Turned out it hadn't, and subpixel smoothing got disabled. This reenables it, and half-checks that box again. Cheers.
bob_the_gorilla is offline   0 Reply With Quote
Old Aug 29, 2009, 12:02 PM   #8
doug in albq
macrumors 65816
 
doug in albq's Avatar
 
Join Date: Oct 2007
10.6.1 better fix this
__________________
http://dougitdesign.com/blog
doug in albq is offline   0 Reply With Quote
Old Aug 29, 2009, 12:33 PM   #9
TheSpaz
Banned
 
Join Date: Jun 2005
I set my LCD font smoothing to OFF. Setting it to "off" is the same as Leopard's "Standard - Best for CRT" option.
TheSpaz is offline   0 Reply With Quote
Old Aug 29, 2009, 12:39 PM   #10
jhero
macrumors 6502
 
Join Date: Jan 2005
Location: Not near an Apple Store
Quote:
Originally Posted by Timan View Post
Can try this in terminal, re-enabled subpixel font smoothing for me.

Code:
defaults -currentHost write -globalDomain AppleFontSmoothing -int 2
This worked for me
__________________
| jhero | 1.5GHz PB G4 | 1.5GB DDR | 15"
jhero is offline   0 Reply With Quote
Old Aug 29, 2009, 12:43 PM   #11
ob22
Thread Starter
macrumors newbie
 
Join Date: Aug 2009
Quote:
Originally Posted by Timan View Post
Can try this in terminal, re-enabled subpixel font smoothing for me.

Code:
defaults -currentHost write -globalDomain AppleFontSmoothing -int 2
Before I do this, since I barely ever use the Terminal, what's the code to turn what this code does, off?
Thanks
ob22 is offline   0 Reply With Quote
Old Aug 29, 2009, 12:43 PM   #12
ventro
macrumors 6502a
 
Join Date: Sep 2006
Quote:
Originally Posted by TheSpaz View Post
I set my LCD font smoothing to OFF. Setting it to "off" is the same as Leopard's "Standard - Best for CRT" option.
Finally someone who knows what they'e talking about. You're NOT supposed to combine sub-pixel anti-aliasing and regular anti-aliasing. It makes all the text look bold, especially light text on a dark background. That's because it's being anti-aliased twice.

If you want your text to render properly, turn OFF sub-pixel anti-aliasing. Sure, it sounds cool, but it's actually really terrible, and distorts your text.
ventro is offline   0 Reply With Quote
Old Aug 29, 2009, 12:48 PM   #13
TheSpaz
Banned
 
Join Date: Jun 2005
Quote:
Originally Posted by ventro View Post
Finally someone who knows what they'e talking about. You're NOT supposed to combine sub-pixel anti-aliasing and regular anti-aliasing. It makes all the text look bold, especially light text on a dark background. That's because it's being anti-aliased twice.

If you want your text to render properly, turn OFF sub-pixel anti-aliasing. Sure, it sounds cool, but it's actually really terrible, and distorts your text.
True that! I've always hated LCD font smoothing. It looks like crap to me. I hate the bold reverse text. Standard font smoothing looks so nice to me.
TheSpaz is offline   0 Reply With Quote
Old Sep 4, 2009, 03:01 AM   #14
Arnoud
macrumors newbie
 
Join Date: Sep 2009
So if we should turn OFF sub-pixel anti-aliasing (which looked ugly on my Samsung monitor anyway and wasn't a solution for me), how do we get the Leopard font smoothing back?
Arnoud is offline   0 Reply With Quote
Old Sep 4, 2009, 07:13 AM   #15
TheSpaz
Banned
 
Join Date: Jun 2005
Quote:
Originally Posted by Arnoud View Post
So if we should turn OFF sub-pixel anti-aliasing (which looked ugly on my Samsung monitor anyway and wasn't a solution for me), how do we get the Leopard font smoothing back?
Just uncheck "Use LCD font smoothing when available"
TheSpaz is offline   0 Reply With Quote
Old Sep 4, 2009, 07:46 AM   #16
Arnoud
macrumors newbie
 
Join Date: Sep 2009
Quote:
Originally Posted by TheSpaz View Post
Just uncheck "Use LCD font smoothing when available"
I believe that's what it was set to before and it wasn't smoothing the fonts as in Leopard. I'll try it again when I get home though.. thanks.
Arnoud is offline   0 Reply With Quote
Old Sep 4, 2009, 12:27 PM   #17
Arnoud
macrumors newbie
 
Join Date: Sep 2009
Done, restarted, still no Leopard-like font smoothing. The menu bar actually looks fine again, but text in applications (such as the browser, text in this forum) do not and look more like ClearType (i.e. ugly font smoothing). *sigh* Hoping for a fix from Apple.
Arnoud is offline   0 Reply With Quote
Old Sep 4, 2009, 03:00 PM   #18
TheSpaz
Banned
 
Join Date: Jun 2005
Quote:
Originally Posted by Arnoud View Post
I believe that's what it was set to before and it wasn't smoothing the fonts as in Leopard. I'll try it again when I get home though.. thanks.
Quote:
Originally Posted by Arnoud View Post
Done, restarted, still no Leopard-like font smoothing. The menu bar actually looks fine again, but text in applications (such as the browser, text in this forum) do not and look more like ClearType (i.e. ugly font smoothing). *sigh* Hoping for a fix from Apple.
It's working for me. All my fonts look like they did in Leopard. No sub-pixel crap. You can tell that it's not using sub-pixel font smoothing by holding control and scrolling to zoom in. Black text should look monotone (no colors around the edges).

Also reverse text doesn't look bold.
TheSpaz is offline   0 Reply With Quote
Old Nov 10, 2009, 05:33 PM   #19
MrNibbles
macrumors newbie
 
Join Date: Nov 2009
Thank You

Quote:
Originally Posted by Timan View Post
Can try this in terminal, re-enabled subpixel font smoothing for me.

Code:
defaults -currentHost write -globalDomain AppleFontSmoothing -int 2
Thank you thank you THANK YOU!

I am a programmer, having just bought a shiny delicious new HPLP2475w, font legibility decreased tenfold. Unreadable at my preferred size, and headache inducing at best.

this has brought them back to readability again! I hope apple see the error of their ways... Thank you so much
MrNibbles is offline   0 Reply With Quote
Old Jan 11, 2010, 01:11 PM   #20
thecoffeeguy
macrumors newbie
 
Join Date: Jan 2010
Following up on this issue (as I am having it on my new Mac Pro), does anyone have suggestion for a couple 24" monitors?

I have the Dell Ultrasharps and it gives me a headache.

I have permission to purchase a couple more for my desk.

Any recommendations?

Thanks,

Saw a NEC EA241WM-BK 24in that look ok.

Anyone know if I can find out what monitors dont have this issue on Snow Leopard?

Thanks.

TCG
thecoffeeguy is offline   0 Reply With Quote
Old Jan 11, 2010, 01:34 PM   #21
TheSpaz
Banned
 
Join Date: Jun 2005
Just uncheck "Use LCD font smoothing when available"
TheSpaz is offline   0 Reply With Quote
Old Jan 13, 2010, 08:57 AM   #22
thecoffeeguy
macrumors newbie
 
Join Date: Jan 2010
Quote:
Originally Posted by TheSpaz View Post
Just uncheck "Use LCD font smoothing when available"
Did. Seemed to help a little on m Samsung monitor, but the Dell is still fugly.

Any recommendations for a new 24" set of monitors?

Thanks.
thecoffeeguy is offline   0 Reply With Quote
Old Mar 2, 2010, 02:55 PM   #23
jgray
macrumors newbie
 
Join Date: Mar 2010
Does anyone know if it's possible to adjust the font-smoothing settings from app to app? 0 looks best overall but Mail definitely looks better at 2 for some reason. Thanks!
jgray is offline   0 Reply With Quote
Old Mar 2, 2010, 04:28 PM   #24
jgray
macrumors newbie
 
Join Date: Mar 2010
http://codesnippets.joyent.com/posts/show/1191

This site discusses changing the style for Textmate. I'm curious how the command might be rewritten for other applications. Thanks.
jgray is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > OS X

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
rMBP Font Smoothing bobbydd21 MacBook Pro 0 Aug 15, 2013 09:18 AM
Font smoothing for Windows INVEST Web Design and Development 2 Mar 28, 2013 04:23 AM
Font smoothing unnecessary on rMBP? Modernape MacBook Pro 10 Feb 28, 2013 05:49 AM
Use LCD font smoothing when available, on or off? bobright iMac 1 Dec 25, 2012 08:47 AM
Getting used to font rendering/smoothing in OS X chaseychasem MacBook Pro 5 Sep 8, 2012 04:19 PM

Forum Jump

All times are GMT -5. The time now is 11:27 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC