Go Back   MacRumors Forums > Apple Systems and Services > OS X

Reply
 
Thread Tools Search this Thread Display Modes
Old Aug 30, 2009, 10:49 AM   #1
marisa8184
macrumors newbie
 
Join Date: Aug 2008
Lexmark printer no longer works on usb not wireless after snow leopard

Title of the post says it all really. My printer is one of the ones supposedly supported (x4690) and it works fine when connected by usb, but not wirelessly. I have tried everything I know to get this working.

The only clue I have is when I try to print and run a log, it says

Stopping job because the scheduler could not execute a filter.
E [30/Aug/2009:14:17:13 +0100] Unable to execute /usr/libexec/cups/backend/lexnet3: insecure file permissions (0100755)

So, any help with this would be really appreciated. I've tried to submit the problem to Lexmark, but the 'submit' button doesn't work on their website, so I emailed them directly, but am not holding my breath!
marisa8184 is offline   0 Reply With Quote
Old Aug 30, 2009, 04:25 PM   #2
scottackerson
macrumors newbie
 
Join Date: Aug 2009
Same here

I'm having the same problem with my Lexmark x4650.
scottackerson is offline   0 Reply With Quote
Old Aug 30, 2009, 04:27 PM   #3
xIGmanIx
macrumors 6502a
 
Join Date: Dec 2008
see what happens when third parties don't support your OS? sucks!! hopefully they will release drivers shortly to get you back on track. I personally wouldn't migrate until there are revised drivers for all my hardware
__________________
Loading Signature......
xIGmanIx is offline   0 Reply With Quote
Old Aug 30, 2009, 04:27 PM   #4
jmpage2
macrumors 68030
 
jmpage2's Avatar
 
Join Date: Sep 2007
Have you guys tried to reload the drivers for 10.5 from the Lexmark site?
jmpage2 is offline   0 Reply With Quote
Old Aug 30, 2009, 04:27 PM   #5
calderone
macrumors 68040
 
calderone's Avatar
 
Join Date: Aug 2009
Location: Seattle
Repair permissions? The line you posted from the logs suggests permissions.
calderone is offline   0 Reply With Quote
Old Aug 30, 2009, 08:32 PM   #6
marisa8184
Thread Starter
macrumors newbie
 
Join Date: Aug 2008
Eventually I managed to get this fixed.

I knew the new driver was OK because it worked when connected by USB
I knew my network was ok because all the pcs in the house can use and print to this printer, and everything else was OK.

What I did was to add the printer manually. I went to printers in the system preferences, clicked the plus sign to add another printer, chose the tab called IP and then manually put in the printer's IP address which I got from the printer itself. Mine has a mode on it where it will print out all it's information.

I called it Lexmark and then chose the correct driver from the list, for me this was the 3600-4600 series.

I can't remember which protocol I chose, I just kept fiddling about with this and all of a sudden it worked

I hope this helps someone else with a similar problem.

Good luck!
marisa8184 is offline   0 Reply With Quote
Old Sep 4, 2009, 06:08 PM   #7
snickers01
macrumors newbie
 
Join Date: Sep 2009
Lexmark 4550

Tried the optional installs from the SL disk, then went to Apple to check drivers
http://support.apple.com/kb/DL901?vi...S&locale=en_GB
knew that I had correct drivers as would print from USB
deleted the lexmark from prederences, then added new printer, chose to add through IP address, use HP printing protocol then add printer software from option dropdown. In this you will find the correct lexmark driver, will be named as a series.
hey presto it worked - still took 2 hours to solve this though.
snickers01 is offline   0 Reply With Quote
Old Sep 5, 2009, 05:33 AM   #8
lovelypit
macrumors newbie
 
Join Date: Mar 2009
Thanks marisa8184! I got it to work. I'm using the X4650...used the Hp protocols from the choices...I'll use it like this for now until lexmark makes a formal installer...Can't seem to get the scanner to work yet though. Any ideas peeps?
lovelypit is offline   0 Reply With Quote
Old Sep 5, 2009, 12:57 PM   #9
NoelEiffe
macrumors newbie
 
Join Date: Apr 2006
Quote:
Originally Posted by snickers01 View Post
Tried the optional installs from the SL disk, then went to Apple to check drivers
http://support.apple.com/kb/DL901?vi...S&locale=en_GB
knew that I had correct drivers as would print from USB
deleted the lexmark from prederences, then added new printer, chose to add through IP address, use HP printing protocol then add printer software from option dropdown. In this you will find the correct lexmark driver, will be named as a series.
hey presto it worked - still took 2 hours to solve this though.
Thank you very much...this is what worked for me too...the trick was to pick the HP JetDirect option. Worked on 3 machines. Go figure.

Scott
NoelEiffe is offline   0 Reply With Quote
Old Sep 7, 2009, 04:20 PM   #10
ManMonkey
macrumors newbie
 
Join Date: Sep 2009
Location: North East England
marisa8184, snickers01 and everyone else - huge thanks for this! ( I joined this forum just to thank you guys!)

Two minutes sorted this out for me - still can't use the scanner wirelessly so I have kept the usb printer set-up for that. I guess we'll have to wait for a new Lexmark driver for that.

If you are struggling to find the IP address - on the X4650 you'll get the Ip address from the printer's maintenance button and then Network set up then Print set up page.
ManMonkey is offline   0 Reply With Quote
Old Sep 8, 2009, 04:27 AM   #11
barfoed
macrumors newbie
 
Join Date: Sep 2009
The solution suggested by snickers01 and marisa8184 also works for Lexmark c530dn.

Add the printer manually and select HP protocol - then the printer will work.

If you select IPP protocol, the printer will be found, but will not print.

Thanks for the good solutions.

-e
barfoed is offline   0 Reply With Quote
Old Sep 10, 2009, 07:18 PM   #12
mrheisman
macrumors newbie
 
Join Date: Sep 2009
Howdy, first time poster, long time lurker.

I also have a Lexmark x4650 and running SL. I have the same problems and I've tried all the above suggestions. When I tried snickers01's suggestion of using the HP protocol everything seemed to work well. It connected to my printer, said it was completed successfully, and then went back to the "Printer Ready" status. However, it didn't print. It didn't attempt to spool or even make any kind of noise.

Does anyone have any idea what might be the problem? Thanks.
mrheisman is offline   0 Reply With Quote
Old Sep 10, 2009, 07:25 PM   #13
jmpage2
macrumors 68030
 
jmpage2's Avatar
 
Join Date: Sep 2007
Quote:
Originally Posted by mrheisman View Post
Howdy, first time poster, long time lurker.

I also have a Lexmark x4650 and running SL. I have the same problems and I've tried all the above suggestions. When I tried snickers01's suggestion of using the HP protocol everything seemed to work well. It connected to my printer, said it was completed successfully, and then went back to the "Printer Ready" status. However, it didn't print. It didn't attempt to spool or even make any kind of noise.

Does anyone have any idea what might be the problem? Thanks.
Did you reset the printing system afterwards? Running latest drivers for the printer?
jmpage2 is offline   0 Reply With Quote
Old Sep 10, 2009, 07:34 PM   #14
mrheisman
macrumors newbie
 
Join Date: Sep 2009
Quote:
Originally Posted by jmpage2 View Post
Did you reset the printing system afterwards? Running latest drivers for the printer?
Yea, I've tried those.

I can't figure it out to save my life. I may just have to wait until Lexmark updates their drivers.
mrheisman is offline   0 Reply With Quote
Old Sep 11, 2009, 11:23 PM   #15
jmpage2
macrumors 68030
 
jmpage2's Avatar
 
Join Date: Sep 2007
Quote:
Originally Posted by mrheisman View Post
Yea, I've tried those.

I can't figure it out to save my life. I may just have to wait until Lexmark updates their drivers.
Try loading the Leopard version of the drivers for your printer.
jmpage2 is offline   0 Reply With Quote
Old Sep 19, 2009, 09:57 PM   #16
efrenernesto
macrumors newbie
 
Join Date: Jul 2009
Lexmark x4690 driver for snow leopard doesn't work (wirelessly)

In short, lexmark has released drivers for snow leopard for a bunch of multi-functional printers, such as the x4690 which is what I have.

However, I found that the x4690 only works for the printer, not for the scanner. When I try to scan a page it stucks in trying to download the list of apps, with no success after a minute or two. All of the above is for working wirelessly.

Is any1 experiencing the same problem?

Thanks.

----

BTW, the x4690 driver for snow leopard apparently is version 1.0.2, but the latest driver for leopard is v 1.0.10, which kind of makes me feel lexmark really is releasing a previous driver that they found works with snow leopard.
efrenernesto is offline   0 Reply With Quote
Old Sep 20, 2009, 01:07 AM   #17
dustingold09
macrumors newbie
 
Join Date: Sep 2009
Location: Canada
Hi,

I have found a link which is related to printers issues. You should have check

it out. It might be very useful to resolve lexmark printer wireless

connectivity issue.



Laser Printer
dustingold09 is offline   0 Reply With Quote
Old Dec 9, 2009, 09:08 PM   #18
silversurfer001
macrumors newbie
 
Join Date: Dec 2009
Quote:
Originally Posted by marisa8184 View Post
Eventually I managed to get this fixed.

I knew the new driver was OK because it worked when connected by USB
I knew my network was ok because all the pcs in the house can use and print to this printer, and everything else was OK.

What I did was to add the printer manually. I went to printers in the system preferences, clicked the plus sign to add another printer, chose the tab called IP and then manually put in the printer's IP address which I got from the printer itself. Mine has a mode on it where it will print out all it's information.

I called it Lexmark and then chose the correct driver from the list, for me this was the 3600-4600 series.

I can't remember which protocol I chose, I just kept fiddling about with this and all of a sudden it worked

I hope this helps someone else with a similar problem.

Good luck!
This did the job for me. I used the HP protocol.
silversurfer001 is offline   0 Reply With Quote
Old Mar 11, 2010, 10:14 AM   #19
AgentRed
macrumors newbie
 
Join Date: Mar 2010
You need a static IP address

The fix described here will not be a permanent solution.

The problem is that for many Lexmark wireless inkjet printers the driver remembers where the printer is by it's IP address. The problem comes when the DHCP server (your router) assigns the printer a new IP address, the drivers on your Mac can no longer find it.

The answer is to assign a static IP address to the printer, and reinstall the drivers. This article explains how to do that. While you are at it you should check the Lexmark site for the latest drivers since there have been recent updates to most of the drivers.
AgentRed is offline   0 Reply With Quote
Old Sep 22, 2010, 11:50 AM   #20
julietetlours
macrumors newbie
 
Join Date: Sep 2010
iMac & Macbook pro don't work with Lexmark

I bought a Macbook Pro like a year ago and installed a HP printer which came with mac. However, when I tried to install my parent's wireless Lexmark 4600 at home it didn't work, actually it didn't do anything. It didn't recognise the device.
I recently bought an iMac, and tried to install the same wireless Lexmark (4600) printer. Now it does install it with no complications at all but it doesn't work. it always says Error

Does anyone have an idea why this happens? Are Apple Mac compatible with Lexmark?

thanks!
julietetlours is offline   0 Reply With Quote
Old Dec 2, 2010, 11:08 PM   #21
Spendt1
macrumors newbie
 
Join Date: Dec 2010
Got it to work

After several hours messing with my new x4650 printer I got the wireless printing/scanning and ipad printing to work by doing things in this order:

1. Download the OSX 10.6 driver from Lexmark site
2 Use Lexmark Wireless Setup Assistant and Download Apple Update when prompted (download will not complete without number one).
3. Restart your Mac like it is an old Windows 2000 device (probably not necessary but I was getting pissed)
4. Everything should work even scanning

For ipad
1. Downloaded Lexmark app
2. Would not find printer (tempted to restart ipad but didn't)
3. Downloaded Lexmark Listener on Mac with updated driver
4. WOW it worked. Now I am take screen shots of whatever I want on ipad and printing them to wireless printer. For whatever reason the app only prints from Photos and its own web browser. What the hell, its free and I got off cheap with this discontinued printer. Hope this saves you the hours of trial and error I put in.
Spendt1 is offline   0 Reply With Quote
Old Sep 24, 2011, 08:29 PM   #22
Urusai89
macrumors newbie
 
Join Date: May 2011
Location: Internet
Just stopping by to thank you guys for the help. I was messing with this issue for a while now, and I feel kind of stupid for not having gone to Lexmark's site in the first place.

Downloading their version of the installer for Snow Leopard solved everything. It installed, it didn't see the printer right away, but it actually popped up this time asking if I want to accept incoming connections (of course I said yes), and it allowed me to type in the IP address to add a remote printer (since it still wasn't showing in the list).

I have a DHCP reservation for the printer, which is basically like a static IP, so no issue there.
Urusai89 is offline   0 Reply With Quote
Old Jan 6, 2012, 06:47 AM   #23
dmedia
macrumors newbie
 
Join Date: Jan 2012
I stand very compatible
__________________
Lexmark Drivers
dmedia is offline   0 Reply With Quote
Old Sep 17, 2012, 06:44 PM   #24
han5
macrumors newbie
 
Join Date: Sep 2012
Update Lexmark driver to Snow Leopard stops printer

Hi,
when my Snow Leopard shows things to update I answer yes and the Lexmark PRO200-S500 driver is one of the updates. This makes the printer to stop work and then I have to find my installation CD and re-install the printer which then works until I make the mistake again.
Tired Hans
han5 is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > OS X

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Snow Leopard is no longer available purchase from Apple's site. alexreich OS X 17 May 11, 2014 01:45 PM
iPhone 5 no longer works with USB as result of 7.1 update kevingaffney iOS 7 3 Mar 10, 2014 03:58 PM
Downgrading from Lion to Snow using time machine and USB (Snow Leopard) djarsalan2006 OS X 0 Jan 19, 2013 12:37 AM
Printer Sharing no longer works after upgrading to Mountain Lion ravenvii OS X 0 Oct 18, 2012 09:05 PM
Resolved: Airport Express + USB printer = wireless printing? luci216 Mac Peripherals 1 Sep 26, 2012 11:11 AM

Forum Jump

All times are GMT -5. The time now is 07:23 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC