Go Back   MacRumors Forums > Apple Systems and Services > OS X

Reply
 
Thread Tools Search this Thread Display Modes
Old Aug 30, 2009, 06:20 PM   #1
one1
macrumors 65816
 
Join Date: Jun 2007
Location: Chattanooga, TN
The GLIMS fix for "no preferences menu"

In 10.6 Snow Leopard on Safari 4, the menu is there, you just can't see it. The text has no color. By sheer luck I was reaching down under my desk to grab something and looked up to see the GLIMS preference panel I had left open, then an outline of text.

It turns out that if you tilt your monitor back you can indeed see the GLIMS preference panel text outline enough to navigate and get it set up the way you want. Perhaps changing the contrast or something will help as well.

Either way, the menu is indeed there! Good luck.
__________________
iMac 2011 2.5 i5
iPad 2 white
iPhone 4s
one1 is offline   0 Reply With Quote
Old Sep 7, 2009, 07:29 AM   #2
tofagerl
macrumors 6502a
 
Join Date: May 2006
Holy crap, the man is right... That is just the weirdest bug ever. "Workaround: tilt screen"!?
tofagerl is offline   0 Reply With Quote
Old Sep 7, 2009, 07:46 AM   #3
VSMacOne
macrumors 68030
 
VSMacOne's Avatar
 
Join Date: Oct 2008
This might just be one of the best finds of the year!! I LOVE GLIMS and was missing having it set up the way I like it. Good job man!
__________________
- iBelong to Jesus -
VSMacOne is offline   0 Reply With Quote
Old Sep 7, 2009, 08:31 AM   #4
svndmvn
Guest
 
Join Date: Nov 2007
Location: Italy
can't seem to find any preferences on my 10.6 safari 4. I installed the plug in now though, can that be it?
svndmvn is offline   0 Reply With Quote
Old Sep 17, 2009, 08:42 AM   #5
MarkSieber
macrumors newbie
 
Join Date: Sep 2009
Thanks, this really helps. It's easier to read the faded text if you zoom in (control plus scroll or using the zoom function in the Accessibility panel in System Preferences.) At normal size I couldn't read some of the text.

Glims folks--a fix soon, please? : )
MarkSieber is offline   0 Reply With Quote
Old Sep 17, 2009, 08:43 AM   #6
Chrysaor
macrumors 6502
 
Join Date: May 2006
Install the beta version, works in 64-bit Safari.
Chrysaor is offline   0 Reply With Quote
Old Nov 22, 2009, 10:53 AM   #7
Jtlx
macrumors newbie
 
Join Date: Jul 2008
Location: South East England
Fix for problem

If you install Glims when Safari is closed you will get the proper Prefs Menu. Well it worked for me after I couldn't get the panel to appear no matter how weirdly I tilted my Macbook Pro! A proper install will tell you it has installed successfully. Took me 5 attempts until I worked this out.
Jtlx is offline   0 Reply With Quote
Old Oct 2, 2014, 07:55 PM   #8
ActionAmerica
macrumors newbie
 
Join Date: Jul 2009
Location: Texas
Easy FIX for Missing GLIMS Preference Panel Tab

Before I go any further, I want to emphasize one thing.

CLOSE THE SAFARI PREFERENCES WINDOW BEFORE TRYING THIS FIX!!!

If you don't do that, it won't work and you'll just have to do it again.

Now, on to the FIX.

=========

GLIMS is great. GLIMS is wonderful! GLIMS is better than chocolate… I take that back. It's almost as good as chocolate. But GLIMS has had a nagging problem through several iterations. The GLIMS Preference Panel fails to show up after a new install or upgrade. Well here's the good news.

The FIX is EASY.
  1. Open Safari.
  2. Make sure that the Safari Preferences Window is CLOSED! !!! This is CRITICAL !!! If the Safari Preferences Window is open when you quit Safari, this won't work!
  3. Quit Safari.
  4. Go to ~/Library/Preferences (to get to ~/Library, Option-Click on the "Go" menu in Finder and select "Library")
  5. Move the file "com.apple.Safari.plist" to the Trash. (This file will be recreated upon restarting Safari. If you had left the Safari Preferences Window open when quitting Safari, then the file would be re-created from Cache and this would not work.)
  6. Re-start Safari.
  7. Open Safari Preferences and you should see the GLIMS Preference Panel at the far right in the Preferences Tabs.

I have not tested my theory about installs yet. But it seems reasonable to assume that the reason why some people have this missing Preference Panel problem and some don't, is because the people who have this issue had the Safari Preferences window open when they quit Safari, before installing GLIMS. If anyone wants to try installing GLIMS with the Preferences window open and then again, with it closed, to verify this theory, I'm sure that lot's of people will appreciate whatever you have to say about it - especially the developers at MacHangout.

I've had people tell me that this didn't work, but in EVERY case, the Preferences window had not been closed before quitting Safari and it worked after this step was included, so I'll nag you about it one more time.

BEFORE TRYING TO APPLY THIS FIX, OPEN SAFARI, CLOSE THE SAFARI PREFERENCES WINDOW, AND QUIT SAFARI!

I hope this helps.

[UPDATE 10/17/14]
After performing the above procedure, the Glims Preference Tab will be visible again. But after a time, it will disappear once more. I have not yet taken the time to figure out what causes this. However, whatever changes you made to the Glims Preferences, before the Glims tab disappeared, are not lost when the Glims Tab eventually does go away again. All that this disappearance means for you, is that if you want to make further changes to the Glims Preferneces, after the tab goes away, you will have to repeat the above procedure, to bring the tab back. That's a small price to pay for the great functionality that Glims gives us, especially since most people set their Glims preferences only once or twice in the life of their computer.
__________________
John G.
Mad Genius (well at least half of that)
2-17" MB-Pros; 15" Retina MB-Pro; 20" iMac; iPhone 6+; iPad; iPad Mini

Last edited by ActionAmerica; Oct 17, 2014 at 02:08 PM. Reason: Update 10/17/14
ActionAmerica is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > OS X

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
iPad: Cracked Screen: How to "repair" "fix" adam9c1 iPad 8 Feb 1, 2014 12:31 PM
General: FIX "Error opening terminal: xterm-256color" for Terminal Commands (e.g., "top") iOS7 thelatinist Jailbreaks and iOS Hacks 9 Jan 10, 2014 07:46 PM
How can I set Preview preferences to open in "Two Pages" layout by default? valiant66 Mac Applications and Mac App Store 0 Oct 28, 2013 07:03 PM
"Applications" menu command - "item cannot be found" - owner/permissions? (10.6.8) MacOSExustio OS X 2 Jul 20, 2013 05:05 AM
"Other" System Preferences no longer loading on startup/login? jamie.shaw OS X 10.8 Mountain Lion 1 Dec 28, 2012 12:47 PM

Forum Jump

All times are GMT -5. The time now is 02:13 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC