Go Back   MacRumors Forums > Apple Systems and Services > OS X

Reply
 
Thread Tools Search this Thread Display Modes
Old Aug 31, 2009, 11:08 AM   #1
sn0warmy
macrumors 6502a
 
Join Date: Mar 2009
Location: Denver, CO
Snow Leopard + Apple Mail + Gmail = FAIL!!

I'm having such a hard time syncing Gmail with Apple Mail now that I've done a fresh install of SL.

First of all, in Gmail Settings, the instructions for setting up Apple Mail are for Apple Mail 3.0. But the Apple Mail with SL is 4.0

The instructions say to "Check the box next to Automatically set up your account."

Pic of what I'm talking about:


But my Apple Mail does not have that check box:


Once it's setup it says it's supposed to look like this:

Notice that it's POP and not IMAP.......WTF??

And in mine, once it's "automatically setup" it's IMAP and not POP:


When I leave the settings as is, and try to send and receive mail I keep getting an error that says something like "Can't send mail on outgoing mail server". And when I change the outgoing server to POP I get the same error.

I've tried everything, I've setup and deleted this e-mail account from Apple Mail at least 4 times now and I keep getting the same error.

This is unbelievably frustrating. Can anyone please help me?!?
sn0warmy is offline   0 Reply With Quote
Old Aug 31, 2009, 11:20 AM   #2
cswiger1
macrumors member
 
Join Date: Feb 2009
I don't have SL yet, but have you clicked to enable the POP server (or IMAP) in your gmail settings?
cswiger1 is offline   0 Reply With Quote
Old Aug 31, 2009, 11:28 AM   #3
duky
macrumors 6502
 
Join Date: Jun 2007
Location: North Carolina
So the settings you have on the last screenshot (the IMAP ones should work fine). How does your Advanced tab look? I've attached two images of how mine looks (and it works just fine). Pretty obvious--but are you sure your password is in correctly?
Attached Thumbnails
Click image for larger version

Name:	Screen shot 2009-08-31 at 12.24.14 PM.jpg
Views:	398
Size:	144.2 KB
ID:	191506   Click image for larger version

Name:	Screen shot 2009-08-31 at 12.24.11 PM.jpg
Views:	390
Size:	89.8 KB
ID:	191507  
__________________
2.6 rMBP; i7 Mini (xbmc); 64 GB iPad Air; 64GB iPhone 5s; 1080p aTV2; Canon 5DIII
duky is offline   0 Reply With Quote
Old Aug 31, 2009, 11:30 AM   #4
swiftaw
macrumors 603
 
swiftaw's Avatar
 
Join Date: Jan 2005
Location: Omaha, NE, USA
Firstly IMAP > POP, so you should use IMAP (unless there is a specific reason why you want POP).

Secondly, you need to go into the settings at gmail.com and specifically turn on POP and IMAP access, else it wont work.
swiftaw is offline   0 Reply With Quote
Old Aug 31, 2009, 11:39 AM   #5
sn0warmy
Thread Starter
macrumors 6502a
 
Join Date: Mar 2009
Location: Denver, CO
duky - My advanced tab looks EXACTLY like yours.

In GMail settings, both POP and IMAP are enabled:



Also, when I add my Gmail account to Mail, it imports ALL of my past Gmail e-mails (4,400) of them. Is there a way to turn this off so it doesn't import any mail received prior to today?
sn0warmy is offline   0 Reply With Quote
Old Aug 31, 2009, 11:44 AM   #6
chrono1081
macrumors 604
 
chrono1081's Avatar
 
Join Date: Jan 2008
Location: Isla Nublar
Make sure your gmail is set to enable imap or pop whichever you are using.

Here is the difference:

Pop will download all your mail into one computer. Not recommended because if you use multiple computers with mail, or outlook, or thunderbird etc set up only one computer will get the mail at any given time.

With iMap it downloads the mail headers (basically the subject of your email) and to read it you just click it and it downloads the rest of the mail, and still keeps your mail on the server so you can see it online or access it from other computers.

In Gmail when you log onto it online there is a preferences tab somewhere to change it to allow IMAP.
__________________
Mac Pro (2010): 3.33Ghz Intel Xeon (6 core) - 24 GB RAM - NVidia Quadro k5000
Macbook Air (2010): 2.13 Ghz Intel Core 2 Duo - 4GB RAM
chrono1081 is online now   0 Reply With Quote
Old Aug 31, 2009, 11:51 AM   #7
GroundLoop
macrumors 68000
 
GroundLoop's Avatar
 
Join Date: Mar 2003
Quote:
Originally Posted by sn0warmy View Post
duky - My advanced tab looks EXACTLY like yours.

In GMail settings, both POP and IMAP are enabled:

Also, when I add my Gmail account to Mail, it imports ALL of my past Gmail e-mails (4,400) of them. Is there a way to turn this off so it doesn't import any mail received prior to today?
I am having the same issues as you are. Here is what I did so far....

In GMail I disabled the IMAP, but left POP on. Then, when you go to create your GMail account in Mail 4.0, the IMAP will fail and you can follow the same setup as you did in 10.5. You can set your Incoming Mail Server to pop.gmail.com, etc.

This is all fine and dandy, but my issue is that I can send email via POP from Mail 4.0, but I cannot receive email. I have sent a test message from Mail to myself, and it shows up in my GMail inbox (not junk/spam) online, but MAIL 4.0 does not download it. When I access my gmail from my iPod Touch I can download the email just fine.

Very irritating.

Hickman

Last edited by annk; Aug 31, 2009 at 03:55 PM. Reason: Removed quoted image
GroundLoop is offline   0 Reply With Quote
Old Aug 31, 2009, 01:27 PM   #8
agentphish
macrumors 65816
 
agentphish's Avatar
 
Join Date: Sep 2004
I have massive issues with gmail as well. I have pop turned off on gmail's settings, have had it this way for probably 3 years. I have been using IMAP exclusively.


I know my server settings are 100% correct, it just seems that mail 4.0 doesn't work right with gmail.

I can't send mail about 80% of the time.
The spinning gear doesn't stop next to my 2 gmail IMAP accounts.

Come on apple what got broken?!
agentphish is offline   0 Reply With Quote
Old Aug 31, 2009, 01:28 PM   #9
PurrBall
macrumors 6502a
 
Join Date: Oct 2007
Location: Maine
Send a message via MSN to PurrBall
My Gmail IMAP is working fine.
__________________
iMac 24" 2.93 GHz C2D | MacBook Pro 15" 2.2 GHz i7 | iPad Air 16 GB | iPhone 5s 32 GB
PurrBall is offline   0 Reply With Quote
Old Aug 31, 2009, 01:34 PM   #10
Deej
macrumors regular
 
Join Date: Apr 2005
Location: UK
Guys you're getting your protocols all mixed up:

pop and imap are *incoming* mail protocols, smtp is *outgoing* mail.

So, if you're having a problem sending, check your smtp. If you're having problems receiving, check pop and imap.

Imap is better than pop, so I'd recommend using this.
Deej is offline   0 Reply With Quote
Old Aug 31, 2009, 03:01 PM   #11
GroundLoop
macrumors 68000
 
GroundLoop's Avatar
 
Join Date: Mar 2003
Quote:
Originally Posted by Deej View Post
Imap is better than pop, so I'd recommend using this.
Why does everyone insist on telling people that need to use POP to go to IMAP? I only access my mail from a single computer and I need to have access to that mail from a secure environment (zero internet access in the SCIF).

Can we please stay on topic and try to determine why GMail and Mail 4.0 do not play nicely with POP anymore. SMTP (for me) is working just fine.

Hickman
GroundLoop is offline   0 Reply With Quote
Old Aug 31, 2009, 03:06 PM   #12
sn0warmy
Thread Starter
macrumors 6502a
 
Join Date: Mar 2009
Location: Denver, CO
Quote:
Originally Posted by Deej View Post
Guys you're getting your protocols all mixed up:

pop and imap are *incoming* mail protocols, smtp is *outgoing* mail.

So, if you're having a problem sending, check your smtp. If you're having problems receiving, check pop and imap.

Imap is better than pop, so I'd recommend using this.
My SMTP protocols are setup correctly. everything is setup correctly. I've gone through it 5 times from scratch and I keep having the same problem.

I think what is possibly causing the issue is that every time I re-create the account in Apple Mail, the program attempts to import all 4,400+ e-mails dating all the way back to last October. This takes forever and has made Apple Mail crash 2 times now. I need to find a way to turn off the ability for Apple mail to import previous e-mails. Does anyone know how?

I should also mention that while Mail is attempting to import these thousands of e-mails from Gmail, if I try to log into my Gmail account manually (www.gmail.com) it keeps giving me errors and won't let me view my mail. But as soon as I delete the Gmail account from Apple Mail, www.gmail.com gives me full access to everything again.

WTF is going on?!?!??!
sn0warmy is offline   0 Reply With Quote
Old Aug 31, 2009, 03:09 PM   #13
madog
macrumors 65816
 
madog's Avatar
 
Join Date: Nov 2004
Location: Korova Milkbar
Quote:
Originally Posted by Brian Hickman View Post
Why does everyone insist on telling people that need to use POP to go to IMAP? I only access my mail from a single computer and I need to have access to that mail from a secure environment (zero internet access in the SCIF).

Can we please stay on topic and try to determine why GMail and Mail 4.0 do not play nicely with POP anymore. SMTP (for me) is working just fine.

Hickman
It's only a recommendation, he's not holding a gun to your head and forcing you to do anything.
__________________
CLEAN INSTALL - Format your hard drive, install your operating system of choice, install applications, and manually copy over personal data. For a good, clean feeling that lasts.
madog is offline   0 Reply With Quote
Old Aug 31, 2009, 03:10 PM   #14
sn0warmy
Thread Starter
macrumors 6502a
 
Join Date: Mar 2009
Location: Denver, CO
Quote:
Originally Posted by Brian Hickman View Post
Why does everyone insist on telling people that need to use POP to go to IMAP? I only access my mail from a single computer and I need to have access to that mail from a secure environment (zero internet access in the SCIF).

Can we please stay on topic and try to determine why GMail and Mail 4.0 do not play nicely with POP anymore. SMTP (for me) is working just fine.

Hickman

Do you think having both POP and IMAP enabled is causing this issue for us?

Meaning, should I just stick with one over the other?
sn0warmy is offline   0 Reply With Quote
Old Aug 31, 2009, 03:11 PM   #15
GroundLoop
macrumors 68000
 
GroundLoop's Avatar
 
Join Date: Mar 2003
Quote:
Originally Posted by sn0warmy View Post
My SMTP protocols are setup correctly. everything is setup correctly. I've gone through it 5 times from scratch and I keep having the same problem.

I think what is possibly causing the issue is that every time I re-create the account in Apple Mail, the program attempts to import all 4,400+ e-mails dating all the way back to last October. This takes forever and has made Apple Mail crash 2 times now. I need to find a way to turn off the ability for Apple mail to import previous e-mails. Does anyone know how?

I should also mention that while Mail is attempting to import these thousands of e-mails from Gmail, if I try to log into my Gmail account manually (www.gmail.com) it keeps giving me errors and won't let me view my mail. But as soon as I delete the Gmail account from Apple Mail, www.gmail.com gives me full access to everything again.

WTF is going on?!?!??!

How do you want to use Mail 4.0 for GMAIL- POP or IMAP? Seems to me that you want POP (like me). Did you try disabling IMAP in GMail (and leaving POP enabled)?

Quote:
Originally Posted by sn0warmy View Post
Do you think having both POP and IMAP enabled is causing this issue for us?

Meaning, should I just stick with one over the other?
I am just trying to reduce the number of variables so that we can determine what is a) wrong with our settings or b) what is broken in Mail 4.0.

Try disabling IMAP in GMail and see if everything then works for you.

Quote:
Originally Posted by madog View Post
It's only a recommendation, he's not holding a gun to your head and forcing you to do anything.
Understood. It is just that every thread seems to go back to the same recommendation. I just want to know if anyoine can get pure POP working with GMail in Mail 4.0.

Last edited by annk; Aug 31, 2009 at 03:56 PM. Reason: Merged 3 posts. Please use the multi-quote function.
GroundLoop is offline   0 Reply With Quote
Old Aug 31, 2009, 03:20 PM   #16
sn0warmy
Thread Starter
macrumors 6502a
 
Join Date: Mar 2009
Location: Denver, CO
Quote:
Originally Posted by Brian Hickman View Post
How do you want to use Mail 4.0 for GMAIL- POP or IMAP? Seems to me that you want POP (like me). Did you try disabling IMAP in GMail (and leaving POP enabled)?
The problem (if I'm reading correctly) is that without IMAP, any sent messages will not appear in my www.gmail.com account. They will simply stay on my machine. And if I read/delete a message on my machine it will not show up as read or deleted at www.gmail.com.

If this is true, then I certainly do need IMAP to work.

This is so annoying.
sn0warmy is offline   0 Reply With Quote
Old Aug 31, 2009, 03:27 PM   #17
GroundLoop
macrumors 68000
 
GroundLoop's Avatar
 
Join Date: Mar 2003
Quote:
Originally Posted by sn0warmy View Post
The problem (if I'm reading correctly) is that without IMAP, any sent messages will not appear in my www.gmail.com account. They will simply stay on my machine. And if I read/delete a message on my machine it will not show up as read or deleted at www.gmail.com.

If this is true, then I certainly do need IMAP to work.

This is so annoying.
I am not sure about the sent mail question as I am not at home to check my account. But, with pure POP, you can set-up GMail to delete the email once it is downloaded to your PC. POP is best for people who generally use a single computer to view his/her email or get annoyed seeing the same email every time to check their email.

So, I am not sure about your specific use case, but I am starting to believe that POP is broken at the moment.
GroundLoop is offline   0 Reply With Quote
Old Aug 31, 2009, 03:38 PM   #18
besler3035
macrumors 6502
 
Join Date: Oct 2004
Location: Grand Rapids, MI
Quote:
Originally Posted by sn0warmy View Post
The problem (if I'm reading correctly) is that without IMAP, any sent messages will not appear in my www.gmail.com account. They will simply stay on my machine. And if I read/delete a message on my machine it will not show up as read or deleted at www.gmail.com.

If this is true, then I certainly do need IMAP to work.

This is so annoying.
All of this is true. You definitely want to go with IMAP if you need any of that functionality. I believe Apple Mail defaults to IMAP in Snow Leopard, so you should be fine once you turn it on in Gmail.

Basically, think of POP like a one-way street. You send something, it goes to the recipient, and stays in your local sent box in Apple Mail. But it doesn't go over to Gmail. Same thing with Trash, or even your read/unread count. You say you have a few thousand emails; that's probably because you were trashing them via POP in Apple Mail, which doesn't delete them off the server.

In a nutshell, go with IMAP! Once I converted, I never went back to POP.
__________________
Retina MacBook Pro 15", iPad Air, iPhone 5, and an old PowerMac G5
Check out my photography at bryanesler.com | Nikon D800, 28-75 f/2.8, 50mm f/1.4, 70-200 f/2.8
besler3035 is offline   0 Reply With Quote
Old Aug 31, 2009, 03:52 PM   #19
sn0warmy
Thread Starter
macrumors 6502a
 
Join Date: Mar 2009
Location: Denver, CO
Well after going at all this and getting advice from a fellow IT guy/Mac user. I've decided to disabled both IMAP and POP and just forward all e-mails starting today to my MobileMe address. I'll just reply to all e-mails from my @me account as that is setup just fine in Apple Mail.
sn0warmy is offline   0 Reply With Quote
Old Aug 31, 2009, 03:57 PM   #20
vansouza
macrumors Demi-God
 
vansouza's Avatar
 
Join Date: Mar 2006
Location: West Plains, MO USA Earth
Send a message via Yahoo to vansouza
Quote:
Originally Posted by sn0warmy View Post
I'm having such a hard time syncing Gmail with Apple Mail now that I've done a fresh install of SL.

First of all, in Gmail Settings, the instructions for setting up Apple Mail are for Apple Mail 3.0. But the Apple Mail with SL is 4.0

The instructions say to "Check the box next to Automatically set up your account."

Pic of what I'm talking about:


But my Apple Mail does not have that check box:


Once it's setup it says it's supposed to look like this:

Notice that it's POP and not IMAP.......WTF??

And in mine, once it's "automatically setup" it's IMAP and not POP:


When I leave the settings as is, and try to send and receive mail I keep getting an error that says something like "Can't send mail on outgoing mail server". And when I change the outgoing server to POP I get the same error.

I've tried everything, I've setup and deleted this e-mail account from Apple Mail at least 4 times now and I keep getting the same error.

This is unbelievably frustrating. Can anyone please help me?!?
Edit your out going mail server so that the out going port is a 3 digit number; you will see the two choices when you get in there.
__________________
You don't have a soul. You are a soul. You have a body. C. S. Lewis
2013 iMac & MBPR
vansouza is offline   0 Reply With Quote
Old Aug 31, 2009, 04:22 PM   #21
Kocab
macrumors newbie
 
Join Date: Nov 2006
Quote:
Originally Posted by sn0warmy View Post
I should also mention that while Mail is attempting to import these thousands of e-mails from Gmail, if I try to log into my Gmail account manually (www.gmail.com) it keeps giving me errors and won't let me view my mail. But as soon as I delete the Gmail account from Apple Mail, www.gmail.com gives me full access to everything again.
It's my understanding that Apple's Mail.app tends to make more than the usual number of connections to a server when it's downloading mail, and then is very reluctant to give them up once done. Effectively Mail.app acts as if it's the only program talking to the server.

Google, probably for load balancing reasons, only allows a certain number of connections to their servers per account. That means it's very easy to get locked out of Gmail if you have more than one application trying to talk to Gmail. (I discovered this when I started having problems with my Gmail access when my iPhone, desktop and browser would all connect to Gmail at once.)

There's really nothing you can do about this except shut down Mail.app, wait a while for the connections to be truly released and then connect in a browser.

Gmail and Mail.app work okay together, but it's not the greatest marriage.
Kocab is offline   0 Reply With Quote
Old Aug 31, 2009, 10:47 PM   #22
shelo99
macrumors newbie
 
Join Date: Aug 2009
Changing the port to 995

After a couple hours struggling with mail and gmail, i found a solution: In advanced options > change the smtp port to 995 (it was 993) and bingo!

I don't know why, since it's no change to the incoming server, but after that i immediately could recieve mail.

Also, imap with gmail worked just fine, but everytime i tried to delete a message, mail just froze... son better safe than sorry, back to our old friend: pop

Hope it helps
Attached Thumbnails
Click image for larger version

Name:	Captura de pantalla 2009-08-31 a las 23.43.39.png
Views:	85
Size:	49.2 KB
ID:	191670  
shelo99 is offline   0 Reply With Quote
Old Aug 31, 2009, 10:55 PM   #23
robsaskibum
macrumors newbie
 
Join Date: Aug 2009
Location: Salt Lake City, UT
I've seen this problem a couple times. It seems that every once in a while (even in leopard) that the mail program itself has some weird little corruption in there. I would delete the mail program itself and re-install. Everyone I've tried helping with this this has worked. Hope that helps.
robsaskibum is offline   0 Reply With Quote
Old Aug 31, 2009, 11:16 PM   #24
agentphish
macrumors 65816
 
agentphish's Avatar
 
Join Date: Sep 2004
Possible Solution Found

Ok, I think I may have figured something out here....

I use IMAP as stated earlier.

I started from scratch with my gmail accounts in mail 4.0.
I hit Mailbox > Take all accounts offline.
Then created my 2 gmail accounts, following gmail's support page I unchecked all the options on the Mailbox Behaviors tab.

I used myemail@gmail.com for the username, not just the first part of my email, i.e. myemail@gmail.com. This is also suggested in the gmail help guide, but mail doesn't set it up this way.

I forced my SMTP port to 587 in mail's setting instead of just having it use "standard ports 25, 465, 587"

I created both accounts, set those options, and hit take all mailboxes online. Mail seems to be downloading my messages from gmail smoothly so far for both accounts at the same time.

Last edited by agentphish; Aug 31, 2009 at 11:35 PM.
agentphish is offline   0 Reply With Quote
Old Aug 31, 2009, 11:17 PM   #25
agentphish
macrumors 65816
 
agentphish's Avatar
 
Join Date: Sep 2004
995 is the gmail port for POP. 993 is the gmail port for IMAP. That is stated in the gmail help docs online. So I'm not sure if you accomplished anything or not...

Quote:
Originally Posted by shelo99 View Post
After a couple hours struggling with mail and gmail, i found a solution: In advanced options > change the smtp port to 995 (it was 993) and bingo!

I don't know why, since it's no change to the incoming server, but after that i immediately could recieve mail.

Also, imap with gmail worked just fine, but everytime i tried to delete a message, mail just froze... son better safe than sorry, back to our old friend: pop

Hope it helps
agentphish is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > OS X

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Moving Mail from Snow Leopard to Mavericks danqi OS X 0 Jan 31, 2014 07:15 AM
Mail quits all the time. snow leopard NeoCool Mac Basics and Help 0 Sep 13, 2013 10:56 AM
Transfer MAIL snow leopard a Mountain Lion otipep5 OS X 10.8 Mountain Lion 23 Mar 12, 2013 10:36 PM
Duplicate emails-Snow Leopard Apple mail Marjohnoliver OS X 0 Dec 6, 2012 11:48 AM
mail in snow leopard - hidden address database? toronado455 Mac Applications and Mac App Store 2 Jun 8, 2012 04:58 PM

Forum Jump

All times are GMT -5. The time now is 12:32 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC