Go Back   MacRumors Forums > iPhone, iPod and iPad > iPhone > iPhone Tips, Help and Troubleshooting

Reply
 
Thread Tools Search this Thread Display Modes
Old Sep 2, 2009, 07:17 PM   #1
EatMyApple
macrumors 6502
 
Join Date: Dec 2008
Not receiving Voice Mail that has been left for me....

First off, this isn't just me as it's also occurring to a friend of mine who starting having the issue first.

Whenever I miss a call and a voice mail is left, I receive no notification that I have a new voice mail. At first I was just assuming that no messages were being left. The other day, my phone froze up so I did a reset by holding the Home and Power button for 10-15 seconds. The phone took about 10 minutes to load up but after it did, it immediately loaded 25 voice mails dating to over a month old.

So I started to test my phone for voice mails. I would call from another number, leave a message, and nothing.

What do I need to do to fix this? Thanks!
__________________
iPhone 5 64GB Retina MacBook Pro iPad 64GB Wi-Fi + LTE Time Capsule 3TB Apple TV iPod Classic 120GB
EatMyApple is offline   0 Reply With Quote
Old Sep 2, 2009, 07:19 PM   #2
-aggie-
macrumors Demi-God
 
-aggie-'s Avatar
 
Join Date: Jun 2009
Location: Where bunnies are welcome.
That can happen if you're on EDGE and surfing and receive a phone call. However, 25?
__________________
Google with site:macrumors.com as a parameter.
DFU Mode
-aggie- is offline   0 Reply With Quote
Old Sep 2, 2009, 07:21 PM   #3
EatMyApple
Thread Starter
macrumors 6502
 
Join Date: Dec 2008
Quote:
Originally Posted by iphone.aggie View Post
That can happen if you're on EDGE and surfing and receive a phone call. However, 25?
I'm not on EDGE, got a strong 3G signal usually always.
__________________
iPhone 5 64GB Retina MacBook Pro iPad 64GB Wi-Fi + LTE Time Capsule 3TB Apple TV iPod Classic 120GB
EatMyApple is offline   0 Reply With Quote
Old Sep 2, 2009, 07:25 PM   #4
RaceTripper
macrumors 68030
 
RaceTripper's Avatar
 
Join Date: May 2007
I get the problem too now and then. ATT denies anything is wrong when I complain, but it does happen. Sometime I don't get the voice mail until I reboot. Sometimes it's just delayed by many hours.

And I thought Sprint was bad...
RaceTripper is offline   0 Reply With Quote
Old Sep 2, 2009, 07:27 PM   #5
EatMyApple
Thread Starter
macrumors 6502
 
Join Date: Dec 2008
Quote:
Originally Posted by RaceTripper View Post
I get the problem too now and then. ATT denies anything is wrong when I complain, but it does happen. Sometime I don't get the voice mail until I reboot. Sometimes it's just delayed by many hours.

And I thought Sprint was bad...
I have tried to reboot to see if they show and nothing. They just simply refuse to show. This goes on for days and apparently over a month as I never realized I was missing messages lol.
__________________
iPhone 5 64GB Retina MacBook Pro iPad 64GB Wi-Fi + LTE Time Capsule 3TB Apple TV iPod Classic 120GB
EatMyApple is offline   0 Reply With Quote
Old Sep 8, 2009, 12:36 PM   #6
greg486
macrumors newbie
 
Join Date: Aug 2009
Angry Same thing...on 3GS

I get the same problem on my 3GS, I'll get a call, miss it, and then assume no one leaves a message only to find out that after a reboot for a particular reason, they all show up, from a few days ago including the one I watched and missed purposely. AT&T needs to resolve this issue. If T-Mobile can support their non-AT&T comrads using the iPhone, then they should fix their issues for the customers that are legit subscribers. AT&T=FAIL IMO! FIX IT!!!
greg486 is offline   0 Reply With Quote
Old Sep 8, 2009, 12:46 PM   #7
MacDryCleaner
macrumors regular
 
Join Date: Jun 2007
Possible fix?

I took my iPhone into the ATT store when I was having similar issues. I was missing calls but my phone wasn't ringing ... voicemails were delayed hours ... calls were being cut off. The ATT person gave me a new sim card and everything has been great since.

Hope this helps.
MacDryCleaner is offline   0 Reply With Quote
Old Sep 8, 2009, 01:34 PM   #8
thelordnyax
macrumors regular
 
Join Date: Feb 2008
I was having the exact same problem, i would only get voicemails when the phone rebooted...and i found a solution

go to Settings > General > Reset > Reset Network Settings

you won't lose your tethering, if you have that, and voicemail will function properly again!
thelordnyax is offline   0 Reply With Quote
Old Sep 8, 2009, 01:45 PM   #9
nehunte
macrumors 6502
 
Join Date: Apr 2009
I had the same unfortunate problem. It was happening to me and didn't even realize it. I just assumed everybody was just saying they left voicemails and actually didn't. During this two month period, I was still getting voicemails every once in a while. So I assumed nothing was wrong. I had also power cycled my phone probably once a week too, and nothing new ever popped up.

Decided one day to restore my phone to factory settings cause my phone was a bit laggy compared to out-of-the-box standards. After my phone locked onto the network, it popped up saying I had 25 voicemails!! All of which were from the past two months. It was really strange. The strangest part is still the fact that I had been getting voicemails during that time intermittently. AT&T claims it was a phone problem. I can't really argue with them about it because I don't fully understand how visual voicemail works. But now I'm starting to understand why some people opt out of VVM. It does seem to have it's problems.
__________________
There are users who literally spend hours on this forum scolding other users for using the forum. Totally bizarre, I know.
nehunte is offline   0 Reply With Quote
Old Oct 15, 2009, 12:12 PM   #10
dgalvan123
macrumors 6502a
 
Join Date: Feb 2008
Had this same problem.

I reset network preferences as suggested in this thread, and my missing voicemails showed up! This is the first time I have had this problem. Now I will be more vigilant about this, though. . . will I have to reset my network preferences every week or so, I wonder? The only way I'd know that I am missing a voicemail is if someone tells me, which is unacceptable since I use this phone for business.
dgalvan123 is offline   0 Reply With Quote
Old Oct 21, 2009, 07:58 AM   #11
microman
macrumors newbie
 
Join Date: Jul 2007
I too had this same problem on 2 different 3Gs' after updating to 3.1.2. I also went in and reset network settings, and they both started working.. I hope I dont have to keep doing that to keep it working.
microman is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iPhone > iPhone Tips, Help and Troubleshooting

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Mail - mailbox not receiving mail. Miqs Mac Applications and Mac App Store 4 May 8, 2014 08:47 PM
OS X: Left 4 Dead 2 - no text or voice chat mentaluproar Mac and PC Games 0 Apr 30, 2014 10:49 PM
Mail receiving the same messages over and over happybird Mac Applications and Mac App Store 2 Jan 2, 2014 08:40 AM
Mail not receiving?! adonis3k OS X Mavericks (10.9) 6 Nov 27, 2013 04:03 PM
Mail not Receiving Messages Old Muley Mac Applications and Mac App Store 1 Nov 17, 2013 08:20 PM

Forum Jump

All times are GMT -5. The time now is 09:01 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC