Go Back   MacRumors Forums > Apple Hardware > PowerPC Macs

Reply
 
Thread Tools Search this Thread Display Modes
Old Sep 3, 2009, 11:47 PM   #1
Sawtooth811
macrumors 6502
 
Join Date: Oct 2007
Location: Charleston, IL
PowerBook G4 12" Alum 1GHz Display Issue

Hi, again. I've recently purchased a broken 1GHz Alum PowerBook G4 12", and the display isn't working. I have a total of two 12" PowerBook displays, and I've tested both. They've worked perfectly fine. Then I've tried reseting the PMU and PRAM, no luck, but they've attempted to work. Tried the Mini-DVI to VGA adapter with my display, still no luck. The keyboard, optical drive, and hard drive works as if it was booting, and there was always a clear chime, even when I've reset the PRAM and PMU (the beep sound when PRAM also attempted). I've inserted a Leopard install disk, and it sounded like it was working perfectly fine. Any Help? Hopefully it's not a motherboard issue! Thanks
__________________
Mac Pro 4,1 QC 2.66GHz 8GB PCS HD 7870 3.5TB X.10 DP5/W7U
iPhone 5 16GB
MSi Wind U123 1.66GHz Atom 2GB 160GB W7U
Sawtooth811 is offline   0 Reply With Quote
Old Sep 4, 2009, 01:41 AM   #2
bartelby
macrumors Core
 
Join Date: Jun 2004
So no display on the Powerbook's screen nor an external?

Sounds like the GPU is dead. Which means it's a logic board replacement in order to fix it...
bartelby is offline   0 Reply With Quote
Old Sep 4, 2009, 10:50 AM   #3
Sawtooth811
Thread Starter
macrumors 6502
 
Join Date: Oct 2007
Location: Charleston, IL
I thought there was a way to fix that, including with a 12" iBook. I've seen pictures of someone soldering something on an iBook motherboard to get the video working again....
__________________
Mac Pro 4,1 QC 2.66GHz 8GB PCS HD 7870 3.5TB X.10 DP5/W7U
iPhone 5 16GB
MSi Wind U123 1.66GHz Atom 2GB 160GB W7U
Sawtooth811 is offline   0 Reply With Quote
Old Sep 5, 2009, 12:26 AM   #4
Sawtooth811
Thread Starter
macrumors 6502
 
Join Date: Oct 2007
Location: Charleston, IL
I've taken it apart again. I've felt the GPU, and it gets very hot within 15 seconds. Is that a sign?
__________________
Mac Pro 4,1 QC 2.66GHz 8GB PCS HD 7870 3.5TB X.10 DP5/W7U
iPhone 5 16GB
MSi Wind U123 1.66GHz Atom 2GB 160GB W7U
Sawtooth811 is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > PowerPC Macs

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Think my 1Ghz 17" PowerBook G4 just died eyoungren PowerPC Macs 6 Dec 23, 2013 10:35 AM
Odd 5S display... "issue?" viperGTS iPhone 7 Nov 24, 2013 01:19 AM
MBP13" Display issue dieett MacBook Pro 0 Apr 29, 2013 03:35 PM
21.5" iMac 2012 Display Issue! Trojans iMac 175 Jan 10, 2013 06:03 PM
2012 13" MBP display issue? impilot MacBook Pro 1 Jun 29, 2012 12:35 PM

Forum Jump

All times are GMT -5. The time now is 11:35 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC