Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Systems and Services > OS X

Reply
 
Thread Tools Search this Thread Display Modes
Old Sep 4, 2009, 04:25 PM   #1
polobreaka
macrumors 6502a
 
Join Date: Aug 2009
Location: Huntington Beach, CA
Send a message via AIM to polobreaka
Snow Leopard Quartz Debugger - disable Beam Sync for smoother Spaces

There has been topics about choppy/stutter Spaces and other animation problems but no real solution. I've done numerous searches on google, mroogle, and the search function on the forum. most of the post about choppy animations did not provide with permanent solutions. if there were solutions, it was about how to disable Beam Sync.

Choppy animations such as stuttering spaces or expose seemed to have happened since back from Tiger. People have been able to disable Beam Sync in Quartz Debug tool from developers tools for smoother transitions.

i am finding mix reviews about disabling this, i would like to start a thread for people with experience on how this work and how to make your animations better.

Please try this and let us know if this is also working out for you guys:

Install Quartz Debugger from the SL disc if you dont have it. in my UTD disc, it was under Xcode.pkg.

- Open Quartz Debugger (i searched under spotlight)
- drop down Beam Sync
- click "Disable"
- Now move Spaces around and see if you can tell a difference
- on the net it says to Force Quit for this setting to stick, but it is not working for me. So i leave Quartz Debugger open, since i dont reboot/shut down my laptop, so its not a problem to leave open and it doesnt take up much resources. Ive been running with it disabled for a while and watched movies, i do not notice any tearing or anything anyone has claimed negatives about it. it works prefect for me under SL and that was probably my only 'annoyance' from SL. i am wondering is there a way in Terminal to make it stick?

Last edited by polobreaka; Sep 4, 2009 at 04:54 PM.
polobreaka is offline   0 Reply With Quote
Old Sep 4, 2009, 07:24 PM   #2
polobreaka
Thread Starter
macrumors 6502a
 
Join Date: Aug 2009
Location: Huntington Beach, CA
Send a message via AIM to polobreaka
anyone??
polobreaka is offline   0 Reply With Quote
Old Sep 5, 2009, 12:45 AM   #3
vega07
macrumors 65816
 
Join Date: Aug 2006
for me quartz debug says beam sync is automatic every time I open it, but I know it's disabled because my animations are now smooth as silk. you don't need it to open all the time.

Last edited by vega07; Sep 5, 2009 at 01:29 AM.
vega07 is offline   0 Reply With Quote
Old Sep 5, 2009, 11:58 AM   #4
polobreaka
Thread Starter
macrumors 6502a
 
Join Date: Aug 2009
Location: Huntington Beach, CA
Send a message via AIM to polobreaka
right after i close quartz debug, i can tell right away that the animation went back to being choppy. not working for me.
polobreaka is offline   0 Reply With Quote
Old Sep 5, 2009, 03:19 PM   #5
Ol!ver
macrumors 6502a
 
Join Date: Mar 2005
http://www.the-iblog.com/2009/08/31/...-snow-leopard/

Any use?

It saves the setting for me until I restart. I've gone back to leopard though - no printer drivers pushed me over the edge.
__________________
Oliver Haslam - Freelance writer currently working for -
Macworld UK
RedmondPie - iDownloadblog
Ol!ver is offline   0 Reply With Quote
Old Sep 5, 2009, 05:48 PM   #6
polobreaka
Thread Starter
macrumors 6502a
 
Join Date: Aug 2009
Location: Huntington Beach, CA
Send a message via AIM to polobreaka
yea ive been on that site. did exactly everything he posted. not working for me. i think i might just go back to Leopard also. i have a clone of my Leopard drive as a backup just in case SL wasnt working out. i booted externally with the Leopard and tried spaces, it is way smoother than SL.
polobreaka is offline   0 Reply With Quote
Old Sep 5, 2009, 09:15 PM   #7
surrealhope
macrumors newbie
 
Join Date: May 2008
Location: Canada

Switching from Space 2 to 1, Safari window flying in from the left. Macbook Pro; Intel C2D 2.5GHz; 8600M GT

TL;DR conclusion: It's fast, but ugly. Whether you want to keep Quartz Debug opened (or even install dev tools if you haven't) to see fast spaces artifacts is up to you.



Few things I noticed:
  1. To anyone who can't find it in Spotlight, OP means Quartz Debug NOT Quartz Debugger
  2. Force quitting the app does not retain the beam sync setting
  3. Disabling beam sync, while does improve the perceived "speed" (framerate, smoothness, etc.) it seems to do ease the motion to the eyes by compromising the animation quality.

The "tearing window" effect was not created by camera blur, and was clear to the eye every time I quick-switched spaces either via the menubar or my keyboard shortcuts. Horizontal motion (e.g. switching between spaces 1 and 2) are the worst, vertical being a lot less noticeable, and diagonal animations somewhere in between the two.

I'd rather wait for Apple to fix it up.
surrealhope is offline   0 Reply With Quote
Old Sep 5, 2009, 09:49 PM   #8
TheSpaz
Banned
 
Join Date: Jun 2005
Quote:
Originally Posted by surrealhope View Post

Switching from Space 2 to 1, Safari window flying in from the left. Macbook Pro; Intel C2D 2.5GHz; 8600M GT

TL;DR conclusion: It's fast, but ugly. Whether you want to keep Quartz Debug opened (or even install dev tools if you haven't) to see fast spaces artifacts is up to you.



Few things I noticed:
  1. To anyone who can't find it in Spotlight, OP means Quartz Debug NOT Quartz Debugger
  2. Force quitting the app does not retain the beam sync setting
  3. Disabling beam sync, while does improve the perceived "speed" (framerate, smoothness, etc.) it seems to do ease the motion to the eyes by compromising the animation quality.

The "tearing window" effect was not created by camera blur, and was clear to the eye every time I quick-switched spaces either via the menubar or my keyboard shortcuts. Horizontal motion (e.g. switching between spaces 1 and 2) are the worst, vertical being a lot less noticeable, and diagonal animations somewhere in between the two.

I'd rather wait for Apple to fix it up.
The reason for keeping beam sync enabled is to prevent tearing because the graphics will refresh at the same rate as the display. Keeping those things in sync shows a more visually pleasing effect. Keep beam sync on.
TheSpaz is offline   0 Reply With Quote
Old Sep 6, 2009, 12:04 AM   #9
vega07
macrumors 65816
 
Join Date: Aug 2006
I don't notice any tearing on mine.
vega07 is offline   0 Reply With Quote
Old Sep 6, 2009, 01:00 AM   #10
wankey
macrumors 6502
 
Join Date: Aug 2005
I believe BeamSync is currently bugged. Leopard was pretty smooth... it should be fixed eventually.
wankey is offline   0 Reply With Quote
Old Sep 6, 2009, 01:26 AM   #11
polobreaka
Thread Starter
macrumors 6502a
 
Join Date: Aug 2009
Location: Huntington Beach, CA
Send a message via AIM to polobreaka
i definitely dont see that on my screen. mine is really smooth. its pretty much like how Leopard was. i downgraded back to Leopard because the choppieness of animiation was a bug to me.

in snow leopard mine came up as Quartz Debugger. in Leopard/Tiger, its Quartz Debug.

so this seems like a hit or miss for some people. it worked perfect for me and looked terrible for others.
polobreaka is offline   0 Reply With Quote
Old Sep 6, 2009, 08:40 AM   #12
TheSpaz
Banned
 
Join Date: Jun 2005
My animations are smooth… maybe it's a video driver issue?
TheSpaz is offline   0 Reply With Quote
Old Sep 6, 2009, 04:38 PM   #13
polobreaka
Thread Starter
macrumors 6502a
 
Join Date: Aug 2009
Location: Huntington Beach, CA
Send a message via AIM to polobreaka
possibly? i have nvidia geforce 9400m.
polobreaka is offline   0 Reply With Quote
Old Sep 6, 2009, 06:13 PM   #14
bbrik
macrumors newbie
 
Join Date: Aug 2009
Hi, I have a unibody MacBook 13. Spaces and Exposé are really choppy compared to Leopard, specially when connected to ACD 24".

The beam sync on Disabled improves a lot and I don't see any tearing. But the setting doesn't stick, even with force quit.

Another weird thing is that, when iTunes is playing, it gets a lot more choppy. Does anybody get that too?
bbrik is offline   0 Reply With Quote
Old Sep 7, 2009, 05:27 AM   #15
chromescreen
macrumors newbie
 
Join Date: Sep 2009
Use Leopard's Quartz Debug (ger) in Snow Leopard

Yes, Snow Leopard's beamsync settings don't stick, but if you use Leopard's Quartz Debug, disable beamsync and force quit the app, it will stick.

Copied 10.5.x's Quartz Debug from a previous backup. Simply works.
__________________
www.chromescreen.com

1st gen MBP (MacbookPro 1.1, Intel Core Duo), 2.0GHz, 256Mb X1600 Radeon, 2 GB RAM, 160 HDD 7200rpm.

Last edited by chromescreen; Sep 7, 2009 at 05:33 AM.
chromescreen is offline   0 Reply With Quote
Old Sep 7, 2009, 06:15 AM   #16
Ol!ver
macrumors 6502a
 
Join Date: Mar 2005
Quote:
Originally Posted by chromescreen View Post
Copied 10.5.x's Quartz Debug from a previous backup. Simply works.
Can you expand on this please? Are you saying if you replace the app in Snow Leopard with the one in Leopard, all the problems go away ?
__________________
Oliver Haslam - Freelance writer currently working for -
Macworld UK
RedmondPie - iDownloadblog
Ol!ver is offline   0 Reply With Quote
Old Sep 7, 2009, 06:24 AM   #17
chromescreen
macrumors newbie
 
Join Date: Sep 2009
Quote:
Originally Posted by Ol!ver View Post
Can you expand on this please? Are you saying if you replace the app in Snow Leopard with the one in Leopard, all the problems go away ?
I'm not talking about any particular problems. It's just about disabled beamsync setting that doesn't stick if i try and force quit 10.6's Quartz Debugger (my experience), but sticks if I use Leopard's Quartz Debug instead (disable beamsync and force quit the app). Just happens that it works for me. And UI's speed increase is noticeable with beamsync off, it's choppy in the original setting, and I hope Apple fixes this (bug?) soon.

EDIT: And of course, the setting sticks only until restart, which is good enough for me
__________________
www.chromescreen.com

1st gen MBP (MacbookPro 1.1, Intel Core Duo), 2.0GHz, 256Mb X1600 Radeon, 2 GB RAM, 160 HDD 7200rpm.

Last edited by chromescreen; Sep 7, 2009 at 06:30 AM.
chromescreen is offline   0 Reply With Quote
Old Sep 7, 2009, 06:54 AM   #18
coolbits
macrumors member
 
Join Date: Nov 2006
disable beamsync with
Code:
sudo defaults write /Library/Preferences/com.apple.windowserver Compositor -dict deferredUpdates 0
At least this worked on leopard... You need to reboot after entering this command.
Change the 0 to 1 to go back to normal.
coolbits is offline   0 Reply With Quote
Old Feb 14, 2010, 07:14 PM   #19
mabaker
macrumors 6502a
 
Join Date: Jan 2008
Having the very same choppiness problems described here and on the lengthy thread in the official Apple Support forums. Got the 9400 chipset running and I doubt much it is its fault as the animation under Leopard were super soft and easy on the eye.

Disabling Beam-Synch didn't really help much - there is only minor improvement.

Also what I observed is that as soon as you hiz the Expose or Spaces activation keys a couple of times, the animations become smoother and smoother each time. But after you switch to another application, load a web page etc it's all jerkiness all over again. And that is not nice at all.

Seems like a driver issue to me.
mabaker is offline   0 Reply With Quote
Old Mar 30, 2010, 09:34 PM   #20
fpena
macrumors newbie
 
Join Date: Mar 2010
It's been some days since the last reply in this thread...

Anybody got news about this problem? I have been searching for a solution...
fpena is offline   0 Reply With Quote
Old Jun 5, 2010, 11:21 AM   #21
mabaker
macrumors 6502a
 
Join Date: Jan 2008
The only thing you can do is revert to the old Leopard Expose via the Snow Leopard Dock hack.

It makes Expose visibly smoother, yet the problem doesn’t seem to go away completely.
__________________
„Integrated Intel graphics chip steals power from the CPU and siphons off memory from system-level RAM. You'd have to buy an extra card to get the graphics performance of Mac Mini [..]” - Apple.com
mabaker is offline   0 Reply With Quote
Old Jun 10, 2010, 02:45 PM   #22
polobreaka
Thread Starter
macrumors 6502a
 
Join Date: Aug 2009
Location: Huntington Beach, CA
Send a message via AIM to polobreaka
this has been a while, so it looks like no fix has been done.

im currently still running Leopoard for this reason.
__________________
2009 uMBP 15" 5,4, 2.53ghz, 8 GB Crucial Ram, 500GB scorpio blue HD; Black 16 GB iPhone 3GS
polobreaka is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > OS X

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Original (Snow Leopard) spaces Knisse OS X 10.8 Mountain Lion 3 Jun 27, 2013 07:05 AM
Is there any way to get Snow Leopard-like Spaces on Lion/Mountain Lion? mossme89 OS X 4 Sep 28, 2012 03:27 PM
Possible to disable minimize animation in snow leopard? varian55zx OS X 7 Sep 9, 2012 02:03 AM
Anyone know how to disable hyperthreading in Snow Leopard? lloyd709 OS X 0 Sep 8, 2012 09:44 PM
how to sync iTunes in Snow Leopard? LeandrodaFL Mac Applications and Mac App Store 6 Jul 30, 2012 10:17 AM

Forum Jump

All times are GMT -5. The time now is 09:35 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC