Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Hardware > PowerPC Macs

Reply
 
Thread Tools Search this Thread Display Modes
Old Oct 11, 2009, 09:03 AM   #1
dazzerj
macrumors newbie
 
Join Date: Oct 2009
12" G4 Powerbook boot problem

Hi all,

I have an 867MHz 12" G4 PowerBook. I've had the machine from new, some 5 years now. A few months ago whilst using it I got some slight glitches and I think a lock-up (I can't remember the details now, it was too long ago), this caused me to restart at which point I got an error along the lines of something... Couldn't find root user. Sleeping and trying again.

After running a disk repair, which found no problems, the machine lost the hdd all together, so I bought a a replacement hdd and fitted it, reinstalled 10.4 and for a couple of months all was well. I then got a similar error and failure to find the hdd during a reboot. I bought a USB hard disk enclosure, put the new disk in and tried connecting it to my PC to see if it would be recognised by the pc. It didn't register on the pc, so I returned it for a refund assuming it was a faulty disk. A few weeks ago I received my replacement which I installed and again put on 10.4. This disk ran for a week, when the same thing has happened again! missing hdd at boot up

Does anybody have any idea what might be causing this corruption of hard disks?
As soon as I have installed the OS, I run all the upgrades to bring it up to 10.4.11, so that is the OS I'm using, which it appears should not be any problem for this particular PowerBook.

Searching the web, I can't find a definitive identification of the problem. Someone suggested the PRAM battery, but failure of that doesn't seem to manifest in this way... or does it?
Could it be a firmware issue, although I think it is up to date also.

I have to borrow the install DVD from my workplace, so I don't have it available all the time, which makes life a little difficult to diagnose this as I have to return it each day.

My current hard disk, when placed in the USB enclosure, is seen by my work G5 and all seems present and correct.

If anybody can help I would be most appreciative as I love my little PowerBook and miss the Mac OS experience.

Thanks
dazzerj is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > PowerPC Macs

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
thread Thread Starter Forum Replies Last Post
FS: 12" G4 Powerbook. Combo/Airport/640mb adamjay Marketplace Archive 1 (Posts count) 7 Jul 21, 2004 09:24 PM
12" G4 Powerbook doesn't startup! whyrichard Mac Applications and Mac App Store 2 Jul 21, 2004 09:09 AM
12" G4 iBook 1Ghz Combo OR 12" G4 PowerBook 1Ghz Combo? dustcase Buying Tips, Advice and Discussion (archive) 7 Jun 22, 2004 01:20 PM
12" G4 Powerbook 1.33 ???'s keysersoze Buying Tips, Advice and Discussion (archive) 14 May 21, 2004 12:36 AM
Long time lurker and potential switcher needs advice on 12" G4 Powerbook uv23 Buying Tips, Advice and Discussion (archive) 35 Nov 28, 2003 11:53 PM


All times are GMT -5. The time now is 12:33 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC