Go Back   MacRumors Forums > iPhone, iPod and iPad > iPhone > iPhone Tips, Help and Troubleshooting

Reply
 
Thread Tools Search this Thread Display Modes
Old Oct 13, 2009, 07:38 PM   #26
e.m.
macrumors 6502
 
Join Date: Mar 2005
Location: San Francisco
Quote:
Originally Posted by Mystikal View Post
Doubt it. Her mom is very computer illiterate. And that's very true. This is obviously a security risk relating to AT&T. This definitely should not be happening.
Have you tried calling ATT?

When I called, I was told there's no problem on their end, even though they were able to confirm my wife sent me 3 MMS messages that were showing up as being sent from a different number on my phone. Hm, ATT doesn't think that's their problem?

You might be told the same, but regardless, I think the more they hear from us the better (hopefully).
e.m. is offline   0 Reply With Quote
Old Oct 13, 2009, 07:45 PM   #27
Mystikal
Thread Starter
macrumors 68020
 
Mystikal's Avatar
 
Join Date: Oct 2007
Location: Irvine, CA
Send a message via AIM to Mystikal
Quote:
Originally Posted by e.m. View Post
Have you tried calling ATT?

When I called, I was told there's no problem on their end, even though they were able to confirm my wife sent me 3 MMS messages that were showing up as being sent from a different number on my phone. Hm, ATT doesn't think that's their problem?

You might be told the same, but regardless, I think the more they hear from us the better (hopefully).
Oh yeah. Last time I called i went from att>att tech support> apple> apple tech support > one level up from att tech support. After all that all they did was tell me to reset network settings. One rep from AT&T blamed Apple obviously. I plan to call them again thursday and give them more information to add to this.

EDIT: Im going to post this on the apple forum later and see if anyone replies.

EDIT2: I havent used google voice / received google voice messages for a few months.
Mystikal is offline   0 Reply With Quote
Old Oct 13, 2009, 07:50 PM   #28
MasterDev
Banned
 
Join Date: Sep 2009
Under settings -> phone -> My Number - Is your number showing up correctly there?
MasterDev is offline   0 Reply With Quote
Old Oct 13, 2009, 07:51 PM   #29
Mystikal
Thread Starter
macrumors 68020
 
Mystikal's Avatar
 
Join Date: Oct 2007
Location: Irvine, CA
Send a message via AIM to Mystikal
Quote:
Originally Posted by MasterDev View Post
Under settings -> phone -> My Number - Is your number showing up correctly there?
Yes yes yes. Ive never changed that setting.

More info: At first I thought this problem was caused by using a custom profile (to enable tethering / mms) but clearly that is not the case since I dont have one installed anymore.
Mystikal is offline   0 Reply With Quote
Old Oct 13, 2009, 07:52 PM   #30
MasterDev
Banned
 
Join Date: Sep 2009
Quote:
Originally Posted by Mystikal View Post
Yes yes yes. Ive never changed that setting.

More info: At first I thought this problem was caused by using a custom profile (to enable tethering / mms) but clearly that is not the case since I dont have one installed anymore.
Then what about refreshing the actual carrier file?
MasterDev is offline   0 Reply With Quote
Old Oct 13, 2009, 07:53 PM   #31
Mystikal
Thread Starter
macrumors 68020
 
Mystikal's Avatar
 
Join Date: Oct 2007
Location: Irvine, CA
Send a message via AIM to Mystikal
Quote:
Originally Posted by MasterDev View Post
Then what about refreshing the actual carrier file?
Do you mean reinstalling? That cant be the case since Ive been having problems using carrier 5.1, 5.5, and 5.6.
Mystikal is offline   0 Reply With Quote
Old Oct 13, 2009, 07:55 PM   #32
MasterDev
Banned
 
Join Date: Sep 2009
Quote:
Originally Posted by Mystikal View Post
Do you mean reinstalling? That cant be the case since Ive been having problems using carrier 5.1, 5.5, and 5.6.
Yeah... My friend had the same issue, and I ended up reinstalling the official carrier file and presto, it worked.

Other than that, this is a tough one... All I can say is a full clean restore (Not from backup)... But there may be other options! I hope for the best man!

Last edited by MasterDev; Oct 13, 2009 at 08:07 PM.
MasterDev is offline   0 Reply With Quote
Old Oct 13, 2009, 07:59 PM   #33
Mystikal
Thread Starter
macrumors 68020
 
Mystikal's Avatar
 
Join Date: Oct 2007
Location: Irvine, CA
Send a message via AIM to Mystikal
Did someone post on the AT&T facebook page?

Erin Marshall: why is my phone number showing up in text as coming from a number in WASHINGTON when I live in Southern California? my mom got my text but when she responded the number went to someone in WA. Then when she forwarded the text to me I got the text but my number was showing as the 425 area code. what is going on AT&T??

AT&T: Hi Erin, Thanks for letting us know. Happy to help. We need a few more details to look into this for you. Please e-mail us at help@attnews.us with your contact and account numbers. We're also on Twitter at twitter.com/ATTCustomerCare.

I have a feeling this problem is MUCH MORE widespread than we think...
Mystikal is offline   0 Reply With Quote
Old Oct 13, 2009, 08:40 PM   #34
e.m.
macrumors 6502
 
Join Date: Mar 2005
Location: San Francisco
My wife or I've never changed number settings either, never jail broken, no custom carrier settings.

The issue seems to have started recently. When I google "iphone mms from number different," and limit the results to within the last week, relevant results come up.

I just called ATT again; while the person was helpful, she was not able to resolve my issue, and was also very surprised to hear about my issue. She was also able to verify that my wife had sent me 3 MMS messages earlier today from her phone to mine, but it showed up as different numbers on my phone. So she acknowledged the problem, but there's no fix.

Now to people are having this issue: once the problem started, has it continued to be a problem? Or is it on and off? Ours started this afternoon, so I'm not sure.

Is this why ATT was afraid of rolling out MMS for the iPhone? Wait, is this an iPhone specific issue, or does it happen with other ATT phones?
e.m. is offline   0 Reply With Quote
Old Oct 13, 2009, 08:43 PM   #35
Mystikal
Thread Starter
macrumors 68020
 
Mystikal's Avatar
 
Join Date: Oct 2007
Location: Irvine, CA
Send a message via AIM to Mystikal
Quote:
Originally Posted by e.m. View Post
My wife or I've never changed number settings either, never jail broken, no custom carrier settings.

The issue seems to have started recently. When I google "iphone mms from number different," and limit the results to within the last week, relevant results come up.

I just called ATT again; while the person was helpful, she was not able to resolve my issue, and was also very surprised to hear about my issue. She was also able to verify that my wife had sent me 3 MMS messages earlier today from her phone to mine, but it showed up as different numbers on my phone. So she acknowledged the problem, but there's no fix.

Now to people are having this issue: once the problem started, has it continued to be a problem? Or is it on and off? Ours started this afternoon, so I'm not sure.

Is this why ATT was afraid of rolling out MMS for the iPhone? Wait, is this an iPhone specific issue, or does it happen with other ATT phones?
This random number problem has happened to me only once, and my GF only once. As for me having random MMS problems (wrong thumbnails shown and sent, receiving MMS instead of text, sms adding text to itself), ive been having those problems since the MMS rollout.

Its not just AT&T. The MMS I sent out was seen wrong by people with Verizon. Thats definitely odd. And even if there is a fix, I think it would take time for AT&T to sort it out. I dont think were going to find a software / hardware fix.
Mystikal is offline   0 Reply With Quote
Old Oct 13, 2009, 08:49 PM   #36
Tarantino
macrumors newbie
 
Join Date: Nov 2007
Quote:
Originally Posted by wallstreet View Post
Let me share my experiences! My girlfriend sent me an mms last night from her iPhone to mine and it sent from a random (707) area code. Her area code is (559). I sent her a mms and it came from a (415) area code. My area code, (209). Sent another mms to my buddy, who also has an iPhone and it sent to him also from a (415) area code. He sent his brother a mms message from his iPhone and it sent from a (714), his home area code is also (209). None of our iPhones are jailbroken, my phone has the newest carrier update and has 3.1.2 iPhone software. There's do not. Something seems fishy here!
I called the number of some lady who sent wallstreet an SMS with the picture of a kitty. She was confused. She said, "I no send you nothing".

Weird ol' lady.
Tarantino is offline   0 Reply With Quote
Old Oct 13, 2009, 08:58 PM   #37
wallstreet
macrumors newbie
 
Join Date: Aug 2005
Location: California
Quote:
Originally Posted by e.m. View Post
to those that are having this problem: have you received messages from iChat or Google Voice? In the other thread, there was another person that stated the problem started after getting messaged from Google Voice. My wife's problem started today after I texted her through iChat. Could be coincidence, or not. We need more data.
Both my girlfriend and I both have never used iChat or Google Voice.

Quote:
Originally Posted by MasterDev View Post
Under settings -> phone -> My Number - Is your number showing up correctly there?
The number listed is my correct number. The MMS messages that I have sent out seem to be generating different phone numbers, not just the same generic number each time.
wallstreet is offline   0 Reply With Quote
Old Oct 13, 2009, 09:01 PM   #38
Tarantino
macrumors newbie
 
Join Date: Nov 2007
Quote:
Originally Posted by wallstreet View Post
Both my girlfriend and I both have never used iChat or Google Voice.

The number listed is my correct number. The MMS messages that I have sent out seem to be generating different phone numbers, not just the same generic number each time.
wallstreet is lying. I've seen them both use iChat and Google Voice.

Also, that old lady called back. She wants her cat picture back. She fessed up.
Tarantino is offline   0 Reply With Quote
Old Oct 14, 2009, 02:11 AM   #39
Mystikal
Thread Starter
macrumors 68020
 
Mystikal's Avatar
 
Join Date: Oct 2007
Location: Irvine, CA
Send a message via AIM to Mystikal
Tomorrow im going to add the rest of my problems to my first post to see if any of you have had anything similar happen. Plus ill post this to apple tomorrow hoping there are others out there who have this problem, ironically.
Mystikal is offline   0 Reply With Quote
Old Oct 14, 2009, 08:29 AM   #40
ctdavid20
macrumors newbie
 
Join Date: Oct 2009
I'm having a problem too. Sent a MMS to my wife. Both on AT&T. Both iPhones that have never been jailbroken. Her carrier setting have not been updated, mine have the most recent, but not custom. We have 925 area codes and this has happened several times. Each time the incoming number is from a different area code. AT&T needs to fix this.
ctdavid20 is offline   0 Reply With Quote
Old Oct 14, 2009, 11:57 AM   #41
Mystikal
Thread Starter
macrumors 68020
 
Mystikal's Avatar
 
Join Date: Oct 2007
Location: Irvine, CA
Send a message via AIM to Mystikal
I just thought of something crazy. Does anyone else leave location services off to save battery?
Mystikal is offline   0 Reply With Quote
Old Oct 14, 2009, 11:59 AM   #42
e.m.
macrumors 6502
 
Join Date: Mar 2005
Location: San Francisco
Quote:
Originally Posted by Mystikal View Post
I just thought of something crazy. Does anyone else leave location services off to save battery?
ours is both set to on.
e.m. is offline   0 Reply With Quote
Old Oct 14, 2009, 12:52 PM   #43
maokh
macrumors regular
 
Join Date: Jun 2007
Location: Seattle, WA
Would explain the unusual amount of wrong number MMS'es i get.
maokh is offline   0 Reply With Quote
Old Oct 14, 2009, 12:57 PM   #44
Mystikal
Thread Starter
macrumors 68020
 
Mystikal's Avatar
 
Join Date: Oct 2007
Location: Irvine, CA
Send a message via AIM to Mystikal
Quote:
Originally Posted by maokh View Post
Would explain the unusual amount of wrong number MMS'es i get.
How many have you received?
Mystikal is offline   0 Reply With Quote
Old Oct 14, 2009, 04:42 PM   #45
Mystikal
Thread Starter
macrumors 68020
 
Mystikal's Avatar
 
Join Date: Oct 2007
Location: Irvine, CA
Send a message via AIM to Mystikal
I SHOULD have an AT&T rep calling me in 20 minutes. He called me early (contacted him through twitter). Hopefully he listens well...
Mystikal is offline   0 Reply With Quote
Old Oct 14, 2009, 04:44 PM   #46
e.m.
macrumors 6502
 
Join Date: Mar 2005
Location: San Francisco
Quote:
Originally Posted by Mystikal View Post
I SHOULD have an AT&T rep calling me in 20 minutes. He called me early (contacted him through twitter). Hopefully he listens well...
Let us know what he says.
e.m. is offline   0 Reply With Quote
Old Oct 14, 2009, 05:15 PM   #47
Mystikal
Thread Starter
macrumors 68020
 
Mystikal's Avatar
 
Join Date: Oct 2007
Location: Irvine, CA
Send a message via AIM to Mystikal
Apple thread created by someone else:

http://discussions.apple.com/thread....96823&tstart=0
Mystikal is offline   0 Reply With Quote
Old Oct 14, 2009, 05:49 PM   #48
Mystikal
Thread Starter
macrumors 68020
 
Mystikal's Avatar
 
Join Date: Oct 2007
Location: Irvine, CA
Send a message via AIM to Mystikal
AT&T rep says it could be anything...he has no idea whats going on. He called Apple and they didnt know anything.

Clearly were not going to get very far at the moment. This is definitely not widespread enough.

He was reading my twitter about how my phone was JBed and hes blaming that as the cause. I told him of these reports about how you guys have used non JB updated phone OTB but that didnt convince him. He doesnt know enought about jailbreaking though since he said "if you use whitera1n or purplera1n". He also said I was using pwnangel. Now that I think about it, he must have meant pwnage tool.

The only helpful thing he suggested was using a DIFFERENT computer to restore and set up as new phone so theres no chance of anything carrying over. Im not going to go un jailbroken for an amount of time since I had an SMS problem on 3.0.1

This is OBVIOUSLY a network problem. I may have to go into AT&T myself and see what a store rep has to say...
Mystikal is offline   0 Reply With Quote
Old Oct 14, 2009, 06:18 PM   #49
Mystikal
Thread Starter
macrumors 68020
 
Mystikal's Avatar
 
Join Date: Oct 2007
Location: Irvine, CA
Send a message via AIM to Mystikal
CHECK ENGADGET!!!!

http://www.engadget.com/2009/10/14/i...r-number-poll/
Mystikal is offline   0 Reply With Quote
Old Oct 15, 2009, 06:08 AM   #50
emc350
macrumors newbie
 
Join Date: Oct 2009
I think its definitely a AT&T network problem and not just an iphone problem.

I was texting back and forth with a friend who has AT&T when I received a MMS from her from a completely different number. The thing is she has the Nokia e71x on AT&T while I have a Palm Pre on Sprint. We were both baffled and I dismissed it until I saw it mentioned on engadget. I decided to register just to post this reply. To be honest I dont understand how AT&T is number 2 in the nation. Over priced for a 30% call drop rate and slow 3g service. But to each their own.
emc350 is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iPhone > iPhone Tips, Help and Troubleshooting

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Mac Mail sending from the wrong email address Souli OS X 2 Jan 24, 2014 05:20 PM
Sending mms kenjiro75 iPhone Tips, Help and Troubleshooting 1 Jun 4, 2013 10:13 AM
Wrong name when sending email's from @me.com address KeeleeK iCloud and Apple Services 2 Aug 14, 2012 07:53 AM
iMessage not sending MMS after Jailbreak Nick A Jailbreaks and iOS Hacks 2 Jul 24, 2012 04:54 PM

Forum Jump

All times are GMT -5. The time now is 03:59 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC