Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Hardware > PowerPC Macs

Reply
 
Thread Tools Search this Thread Display Modes
Old Oct 23, 2009, 07:51 PM   #1
OrangeSVTguy
macrumors 601
 
OrangeSVTguy's Avatar
 
Join Date: Sep 2007
Location: Northeastern Ohio
Flashed PC eVGA Nvidia 6800 Ultra 256mb installed in AGP G5 (w/ Pics)

Well I got my eVGA Nvidia 6800 Ultra in the mail today and boy is it a nice looking card. Looks great in the G5! After flashing it in my PC a few times trying to find a correct ROM, got scared when it wouldn't boot the first time in the Mac but I screen shared with my PB and noticed it wasn't listing in the System Profiler correctly. So I had to reflash it blindly in the PC since I couldn't see what was going on . Yes I did it with no PCI graphics card .

The Arti Roms wouldn't work so I used the 6800 Ultra Retail rom and it shows up as the DDL(Dual dual-link) OEM mac 6800. I am using it with a VGA monitor as I don't have a DVI anymore so I don't know if that works yet. Will include screen shots below. I only have one molex splitter so my DVD-RW is disconnected until I can pick up another one.

This is my first flashing attempt with an Nvidia card and I'm very happy with the results! Go StrangeDogs! woof woof.
Attached Thumbnails
Click image for larger version

Name:	Picture 1.png
Views:	96
Size:	95.1 KB
ID:	200063   Click image for larger version

Name:	1023092045-01.jpg
Views:	60
Size:	584.6 KB
ID:	200067   Click image for larger version

Name:	1023092044-01.jpg
Views:	14
Size:	444.4 KB
ID:	200068  

Click image for larger version

Name:	1023092044-00.jpg
Views:	35
Size:	528.3 KB
ID:	200069  
__________________
Browsing the forums from my Powerbook G4

Last edited by OrangeSVTguy; Oct 24, 2009 at 12:02 PM.
OrangeSVTguy is offline   0 Reply With Quote
Old Oct 23, 2009, 07:58 PM   #2
MacVidCards
macrumors 601
 
Join Date: Nov 2008
Location: Hollywood, CA
 
see vendor information in user profile
glad to see our work still in good use.

Ultra ROM won't have DVI...but maybe you don't need?

If you want DVI, you just need to mod the device id in the Arti GT ROM.

(do a search for de10, will show you where it is...needs to be 40 for Ultra, GT was 45)
MacVidCards is offline   0 Reply With Quote
Old Oct 23, 2009, 08:15 PM   #3
OrangeSVTguy
Thread Starter
macrumors 601
 
OrangeSVTguy's Avatar
 
Join Date: Sep 2007
Location: Northeastern Ohio
Quote:
Originally Posted by The Rominator View Post
glad to see our work still in good use.

Ultra ROM won't have DVI...but maybe you don't need?

If you want DVI, you just need to mod the device id in the Arti GT ROM.

(do a search for de10, will show you where it is...needs to be 40 for Ultra, GT was 45)
Of course! I couldn't have done it without you guys. Wish there was a way that I could contribute. Maybe I can make a complete step-by-step in this thread for others to find. I searched google quite a bit and didn't really find much of anything with anyone flashing this card. Is there anyway to adjust the fan speed with an app or something?

Not to bad as I don't think this card was used because it had everything it came with and all the cables were still in the plastic lol. Not bad for $48 shipped.

OK I'm happy with it now with just VGA which I hate but I'm using VNC on my PB more than my monitor. I ran it all week encoding video without a graphics card lol .
__________________
Browsing the forums from my Powerbook G4
OrangeSVTguy is offline   0 Reply With Quote
Old Oct 23, 2009, 09:32 PM   #4
macgeek18
macrumors 65816
 
Join Date: Sep 2009
Location: Murrieta,CA
Nice,I just got a Nvidea Geforce 6200 with 256MB DDR2 Vram AGP card for my Power Mac G4.
__________________
MacBook Pro 13";2.5Ghz Core i5;8GB DDR3;480GBSSD;OSX 10.9.2 Mavericks
iPhone 5c, 16GB, White, Verizon 4G LTE.
macgeek18 is offline   0 Reply With Quote
Old Oct 24, 2009, 09:51 AM   #5
OrangeSVTguy
Thread Starter
macrumors 601
 
OrangeSVTguy's Avatar
 
Join Date: Sep 2007
Location: Northeastern Ohio
I found an extra female molex connection and carefully removed the wires from the pins and did the same with 3 male molex connectors from old PSUs and made my own 3-way splitter Cut the wires to length so they are not all over the place as if I had used the normal splitters. Now I got everything up and running. Should have used all black wiring too to match the G5s factory molex wires. Guess I'm kinda a nerd when it comes to things like that .


I wonder if the S-Video on the card works? Probably not with the OEM rom but maybe with an edited one? I remember my 9800 Pro's S-Video output worked with no problems when I had it in my G4... hmm...
__________________
Browsing the forums from my Powerbook G4
OrangeSVTguy is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > PowerPC Macs

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
thread Thread Starter Forum Replies Last Post
NVIDIA 6800 GT DDL coming in november! Converted2Truth Games 29 Dec 29, 2005 04:14 AM
nVIDIA 6800 Ultra DDL risc Macintosh Computers 10 Oct 18, 2005 07:03 AM
FS: Apple nVidia 6800 Ultra MINT ! Captnroger Marketplace Archive 1 (Posts count) 1 Jul 22, 2005 08:16 AM
Nvidia 6800 Ultra CLOSE UP PICS Converted2Truth Games 50 Aug 7, 2004 10:00 PM


All times are GMT -5. The time now is 10:36 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC