Go Back   MacRumors Forums > Apple Hardware > Notebooks > MacBook Air

Reply
 
Thread Tools Search this Thread Display Modes
Old Dec 18, 2009, 05:07 AM   #1
bikerinside
macrumors newbie
 
Join Date: Dec 2009
macbook air usb problem

Hi, last day my macbook air usb port don't work well...
I don't know how but if I plug a mouse, pendrive, usb hd the light on the devices is on... I think it's must be ok... BUT I can't use... no mouse no pendrive no superdrive nothing on my desk I don't see nothing.
So I called the apple center near my city and he said that I can try the PRAM
reset... well... but the situation not change... how appened? my air
is never fall down...

thanks for answers.
bikerinside is offline   0 Reply With Quote
Old Dec 18, 2009, 10:17 AM   #2
jimboutilier
macrumors 6502a
 
Join Date: Nov 2008
Location: Denver
Send a message via AIM to jimboutilier
I've occasionally had similar issues on various MACs.

Typically removing the device and reinserting or rebooting and removing/reinserting the device would solve the problem.

Your issue could be a corrupted preference file (Apple may get you to delete the pref file if thats the case) or if you have a Virtual Machine software running when you are doing this it may be the VM is capturing the device rather then your MAC so look on your VM desktop.

Hope this helps. One presumes these devices used to work fine on your MBA before and something is different now?
__________________
2013 MBA 11.6, 1.7ghz i7, 8gb RAM, 512gb SSD
2012 Mini 2.6 ghz QCi7, 16gb RAM, 1TB Fusion Drive
iPad mini GSM 64gb, iPhone 5S GSM 32gb
jimboutilier is offline   0 Reply With Quote
Old Dec 19, 2009, 05:45 AM   #3
bikerinside
Thread Starter
macrumors newbie
 
Join Date: Dec 2009
very thanks jimboutilier,

but after some time, I called Apple and I talk
with a assistance operator... and I realized that my mbair DON'T see any
devices... because in the system profiler, usb section there isn't
anything only the isight camera, bluetooth, ir and so on, BUT my plugged
device... no... for the mac was unplugged!!! the strange thing was that
I run the applecare test "techtool" and the usb passed test!!!
one more time... I realized that was an hw problem... so in late afternoon
I bringed my air and I went in apple assistance center now...
I wait for an email or a call... a last thing my air had only six months..

thanks...

biker
bikerinside is offline   0 Reply With Quote
Old Dec 19, 2009, 03:45 PM   #4
stoconnell
macrumors 6502
 
Join Date: Mar 2009
Location: Rockville (Despite REM's plea.)
That sounds almost like an issue between the motherboard and the port door (or a bad motherboard).

Good luck.
__________________
MacBook Air Rev B 1.86/128 SSD 1st Gen iPhone
stoconnell is offline   0 Reply With Quote
Old Jan 5, 2010, 06:00 AM   #5
SergiiBratus
macrumors newbie
 
Join Date: Jan 2010
I had the exact same situation. The way to fix it is - first reset the EFI, then reset the SMC. These steps are described in the instruction that goes with MacBook Air. It'll work.
SergiiBratus is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Notebooks > MacBook Air

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
How do you Format a USB on a macbook air hssxn OS X Mavericks (10.9) 3 Apr 7, 2014 05:37 PM
Problem with Air & USB 3.0 hub zlayde MacBook Air 6 Jan 5, 2013 04:44 PM
Macbook Air with 10.8.2 doesn't allow install from USB? waloshin Windows, Linux & Others on the Mac 1 Dec 28, 2012 04:52 PM
MacBook Air USB 3.0 Port Question/Problem dlbmacfan MacBook Air 4 Jun 19, 2012 01:35 AM

Forum Jump

All times are GMT -5. The time now is 10:50 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC