Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > iPhone, iPod and iPad > iPhone > iPhone Tips, Help and Troubleshooting

Reply
 
Thread Tools Search this Thread Display Modes
Old Jan 3, 2010, 09:48 PM   #1
SskillzX
macrumors newbie
 
Join Date: Jan 2010
Picture Txt MSG not working on iPhone 3G

Hello.
I just received an iPhone from my friend today which I unlocked so that I could use on my T-mobile phone. Well everything works fine besides the fact that I can't sent picture text messages. I'm using a 3G 8GB iPhone with a firmware of 3.1.2. Does anyone know what the problem is?
SskillzX is offline   0 Reply With Quote
Old Jan 3, 2010, 10:49 PM   #2
patrickvanzandt
macrumors member
 
Join Date: Sep 2007
Location: U.S.A.
Send a message via Skype™ to patrickvanzandt
"I can't sent picture text messages".
Poor grammar aside, what does this mean? What error are you getting? What do you see on the screen? Etc?

Without knowing the sympom, two things already some to mind:
  1. Have you added MMS capability to your T-Mobile account? If no, call 611 to talk to T-Mobile support.
  2. Have you properly configured the iPhone for data and MMS service? http://modmyi.com/wiki/index.php/Car...tings#T-Mobile
patrickvanzandt is offline   0 Reply With Quote
Old Jan 3, 2010, 10:57 PM   #3
SskillzX
Thread Starter
macrumors newbie
 
Join Date: Jan 2010
I'm oh so sorry. Didn't think class started this late. If you still want to help a poorly educated scum like me, then here is what I am experiencing. There is no picture message symbol that would usually appear next to the text box near the sent button is not there.
SskillzX is offline   0 Reply With Quote
Old Jan 3, 2010, 11:15 PM   #4
patrickvanzandt
macrumors member
 
Join Date: Sep 2007
Location: U.S.A.
Send a message via Skype™ to patrickvanzandt
Quote:
Originally Posted by SskillzX View Post
I'm oh so sorry. Didn't think class started this late. If you still want to help a poorly educated scum like me, then here is what I am experiencing. There is no picture message symbol that would usually appear next to the text box near the sent button is not there.
In "Settings > Messages",

1) Does you iPhone have the option to turn MMS messaging on/off? (as seen in example below)?


2) If yes, is this option currently turned on (as seen above)? If MMS is turned off, this will cause the symptom you described (no camera icon across from the send button).
patrickvanzandt is offline   0 Reply With Quote
Old Jan 3, 2010, 11:18 PM   #5
zunairryk
macrumors regular
 
Join Date: Mar 2009
Location: Vancouver, BC
Quote:
Originally Posted by SskillzX View Post
I'm oh so sorry. Didn't think class started this late. If you still want to help a poorly educated scum like me, then here is what I am experiencing. There is no picture message symbol that would usually appear next to the text box near the sent button is not there.
you would have to manually set the t-mobile APN for MMS in settings >general> network>cellular data

google t-mobile MMS settings for iphone.

don't forget to restart your iphone after you are done
zunairryk is offline   2 Reply With Quote
Old Jan 3, 2010, 11:19 PM   #6
SskillzX
Thread Starter
macrumors newbie
 
Join Date: Jan 2010
Nope, only options are Show Preview and Repeat Alert.
SskillzX is offline   0 Reply With Quote
Old Jan 3, 2010, 11:27 PM   #7
SskillzX
Thread Starter
macrumors newbie
 
Join Date: Jan 2010
Thank You zunairryk! it now works. atleast we got someone who knows what hes talking about.
SskillzX is offline   0 Reply With Quote
Old Jan 3, 2010, 11:31 PM   #8
zunairryk
macrumors regular
 
Join Date: Mar 2009
Location: Vancouver, BC
Quote:
Originally Posted by SskillzX View Post
Thank You zunairryk! it now works. atleast we got someone who knows what hes talking about.
not a problem Glad it worked for you
zunairryk is offline   0 Reply With Quote
Old Apr 9, 2012, 10:12 AM   #9
GlennieBoy18
macrumors newbie
 
Join Date: Apr 2012
Ok I did all this and the message is failing to send..any know why??
GlennieBoy18 is offline   0 Reply With Quote
Old Apr 10, 2012, 09:46 AM   #10
flashyman
Banned
 
Join Date: Apr 2012
Quote:
Originally Posted by zunairryk View Post
you would have to manually set the t-mobile APN for MMS in settings >general> network>cellular data

google t-mobile MMS settings for iphone.

don't forget to restart your iphone after you are done
Oh, You are really a expert. Thanks for your answer.
flashyman is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iPhone > iPhone Tips, Help and Troubleshooting

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
thread Thread Starter Forum Replies Last Post
Custom and purchased ringtones not working on iPhone 3G astarling06 iPhone 1 Sep 29, 2009 06:02 PM
Geo Tagging not working on Iphone 3g biasx31 iPhone Tips, Help and Troubleshooting 2 Jul 19, 2009 04:39 AM
Audio only playback from Video Podcasts not working on iPhone 3G minhaferzz iPhone Tips, Help and Troubleshooting 3 Sep 8, 2008 01:43 PM
Phone Not Working On Iphone 3g algire79 Jailbreaks and iOS Hacks 6 Aug 15, 2008 04:31 PM
GPS not working on iphone 3G with o2 36183 iPhone 2 Jul 13, 2008 08:56 AM


All times are GMT -5. The time now is 02:24 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC