Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Systems and Services > Programming > Mac Programming

Reply
 
Thread Tools Search this Thread Display Modes
Old Jan 16, 2010, 02:41 AM   #1
ellie:)
macrumors newbie
 
Join Date: Jan 2010
Gnuplot - bad data on line 1

Hi there,
I am having a problem with Gnuplot.
when I try to plot the graph, I got this error " bad data on line 1"

here are the first few rows of my data:
1 0.0193608
2 0.089262
3 0.0302174
4 0
5 0
6 0
7 0
8 0
9 0
10 0
11 -0.0302174
12 -0.0892561
13 -0.0192659
14 0.109624
15 0.0466765
16 -0.0663904
17 -0.0152822
18 0.0355062
19 0.0137621
20 0
21 0

I tried plotting another data file which I just plotted one week ago, and I got this error again..

Thanks in advance~
ellie:) is offline   0 Reply With Quote
Old Jan 16, 2010, 05:50 AM   #2
MrFusion
macrumors 6502a
 
Join Date: Jun 2005
Location: West-Europe
Quote:
Originally Posted by ellie:) View Post
Hi there,
I am having a problem with Gnuplot.
when I try to plot the graph, I got this error " bad data on line 1"

here are the first few rows of my data:

I tried plotting another data file which I just plotted one week ago, and I got this error again..

Thanks in advance~
Posting the original file and the command that you are using is much more useful that posting some data. There is nothing magic about a bunch of numbers. However, the difference between line endings (\n or \r or \r\n) and the delimiters (;,:\t) can make the difference between getting a nice plot or a bunch of errors.

And are you sure you are using the same command as last week?
__________________
24" iMac, 13" MacBook, iPod Touch. iPod mini and PowerPC Mac Mini gathering dust somewhere.
MrFusion is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > Programming > Mac Programming

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
thread Thread Starter Forum Replies Last Post
Mac untethered jailbreak for iPod Touch 1st gen on 3.1.3 ? hyperipod iPod touch Hacks 4 Mar 23, 2011 08:29 AM
Canon 60D issue - horizontal banding on dark colours Schtumple Digital Photography 13 Dec 25, 2010 03:57 AM
Quick Question - Wiping 3G on 3.1.2 Krafty Jailbreaks and iOS Hacks 3 Nov 12, 2010 08:51 AM
iPhone Newbie - 3g running on 4.1 unlock questions xlisalovely Jailbreaks and iOS Hacks 2 Oct 6, 2010 08:47 AM
Iphone 2G - Wifi Data on but network data off? AFKMatrix iPhone Tips, Help and Troubleshooting 0 Dec 3, 2008 07:32 AM


All times are GMT -5. The time now is 08:56 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC