Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Hardware > Mac Peripherals

Reply
 
Thread Tools Search this Thread Display Modes
Old Jan 25, 2010, 07:44 PM   #1
macstatic
macrumors 6502a
 
Join Date: Oct 2005
Location: Norway
Epson 810 network configuration

I'm having some setup problems with my newly purchased Epson Stylus Photo PX810FW (Artisan 810) which I want to connect to a cabled home network (LAN) so as to be shared among two Macs.

1) No thanks to the supplied Epson software I figured out how to connect the printer to my network (by going to the Print & Fax System preference panel and adding a new printer). It's now connected to both USB and LAN, but for some reason I'm able to choose between 3 printers: USB, EPSON TCPIP and Bonjour.
What is "Bonjour", and should I choose between that or "EPSON TCPIP" when connecting to my network?

2) I figured out how to be able to scan via LAN: by configuring it with "Epson scan settings" found inside the /Applications/Utilities/ folder, so now I can scan without USB!
However, the printer has the ability to scan documents directly from its front-panel (press the Scan button on the LCD-display, then Scan to PC or Scan to PDF). However, it only displays a "USB connection" button choice with either scanning mode, and even that doesn't work (there's no scanner response, and after a while I get an error message saying there's a communication error).

So, why won't it work even if both USB and Ethernet connectors are inserted?
And is it possible at all to use those scan options via a LAN network (so I can scan to the other computer farthest away from the printer, without having to run back and forth)?
macstatic is offline   0 Reply With Quote
Old Jan 26, 2010, 02:09 AM   #2
milk242
macrumors 6502a
 
Join Date: Jun 2007
Just use bonjour, bonjour is a communication protocol for Macs which is equivalent to upnp.

The Scan to PC could be a limitation of the software that it can't communicate back via LAN. I'm not sure about this and would probably be best to ask someone with this printer or contact Epson. You could ask Epson if this feature works on Windows and if it does, there should be a way to get it to work on OSX.
milk242 is offline   0 Reply With Quote
Old Jan 30, 2010, 06:39 PM   #3
macstatic
Thread Starter
macrumors 6502a
 
Join Date: Oct 2005
Location: Norway
I was hoping someone else with a 710 or 810 here could tell me of their experiences first, then call customer support as a last resort.


This is what happens if I press the Scan button on the printer, followed by pressing Scan to PC or Scan to PDF (then USB connection, which oddly is the only choice I get -I was expecting to be able to choose between USB or network):

An application on the Mac starts up called "Event manager" (found inside the "Epson software" folder within "Applications", along with "EScanAssistant" (found inside the "Event manager" package: /Contents/Resources/Assistants/Scan Assistant/) and a window pops up:


Around 30 seconds goes by without anything happening, then the printer beeps and tells me there's a "communication error" and I should check my connection etc.

When I press on the OK button in "The scanner is warming up window" (above) a new window pops up:


Anyone here have different experiences when pressing the same buttons on the printer? And has anyone got a different option than "USB connection"? I'm assuming it's actually supposed to be able to scan via a LAN connection by pressing those buttons on the printer, or else why would there be a need to choose which connection type to use? Besides, the "USB connection" button clearly activates something on the Mac, so communicating both ways does indeed work, indicating that at least with USB it should be possible to control scanning directly from the printer and not just from the Mac.

On a sidenote I discovered something interesting.
If I double-click "Event manager" on its own, this window comes up:


Click on the "Make job settings" button which allows you to configure the different button presses (e.g. which folder to save a scanned document etc.). Press "Test button" (lower left in that same window) and scanning actually works, so at least something is working, but of course that's from the Mac and not from the buttons on the printer.
Getting back to the Event Manager's main window, there's a button at the bottom marked "Network scan settings" which brings up a new window with an "Enable network scan" option which is ticked (turned on) here.
So where else should I look in order to resolve my issues?

Last edited by macstatic; Jan 30, 2010 at 06:53 PM.
macstatic is offline   0 Reply With Quote
Old Jun 6, 2010, 03:03 PM   #4
geforce83
macrumors newbie
 
Join Date: Jun 2010
hi hopefully you have managed to solve this by now, if not i have just downloaded the latest drivers etc from Epson and this has fixed my px710w which had the same exact problem (URL below).
good luck Rich





http://www.epson.co.uk/Store/Printer...rivers-Support
geforce83 is offline   0 Reply With Quote
Old Jun 7, 2010, 04:22 AM   #5
macstatic
Thread Starter
macrumors 6502a
 
Join Date: Oct 2005
Location: Norway
Yes, I solved it.
For some reason everything worked fine on one of the computers, so I reinstalled the Epson software on the other computer and all was OK!

A great printer. I especially love the auto document feeder which means that I can for instance scan a bunch of sheets and turn it all into a single PDF file! I haven't tried out the fax nor the CD printing functions, but all in all I have to say I'm very pleased with the printer.
macstatic is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Mac Peripherals

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Does Epson Scan (Epson's included scanning software) work with non-Epson scanners? glitch44 Mac Applications and Mac App Store 2 May 30, 2013 02:08 PM
Can't Print from iMac to Epson Stylus TX121 Shared Network Printer rbhunia iMac 0 Dec 19, 2012 06:28 AM
Airprint and Epson 810 Lyons00 iPad 3 Oct 20, 2012 08:48 PM
Apple network configuration tomfri Mac Peripherals 4 Oct 11, 2012 03:11 AM
Epson on network keeps crashing my Air pj4444 MacBook Air 0 Jul 6, 2012 10:06 AM

Forum Jump

All times are GMT -5. The time now is 04:10 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC