Go Back   MacRumors Forums > Apple Hardware > Mac Peripherals

Reply
 
Thread Tools Search this Thread Display Modes
Old Feb 3, 2010, 10:15 AM   #1
tucker3434
macrumors regular
 
Join Date: Dec 2009
magic mouse scrolls on its own

Every once in a while my cursor will flash on the screen and it will scroll to the bottom of the page I'm viewing. If I scroll up, it goes right back down. It quits after about 30 seconds. What's going on?
tucker3434 is offline   0 Reply With Quote
Old Feb 5, 2010, 01:16 AM   #2
tucker3434
Thread Starter
macrumors regular
 
Join Date: Dec 2009
Nobody has had this problem? I've had it happen on two separate Imacs in two separate locations.
tucker3434 is offline   0 Reply With Quote
Old Feb 5, 2010, 02:52 AM   #3
King Mook Mook
macrumors 6502
 
Join Date: Apr 2008
Location: Who can it be now? (Werewolves, go 'way, don't come 'round here no more!)
That happened once to me, but I just cleaned the Magic Mouse and then it never happened again.
__________________
Colour my life with the chaos of trouble - Belle & Sebastian.
[insert witty comment here]
King Mook Mook is offline   0 Reply With Quote
Old Dec 2, 2010, 04:23 AM   #4
t-munny
macrumors newbie
 
Join Date: Dec 2010
me too

I have the same problem, so annoying.
t-munny is offline   0 Reply With Quote
Old Dec 11, 2010, 02:29 PM   #5
kathmac
macrumors newbie
 
Join Date: Oct 2007
uncontrollable scrolling and beeping

I often experiencing occasionally uncontrollable scrolling and often beeping and the cursor moves around on its own. I have disconnected the mouse and keyboard and used different ones but the same thing occurs. I can see no pattern to the problems so what could this be?
kathmac is offline   0 Reply With Quote
Old Dec 13, 2010, 12:03 AM   #6
Rob.G
macrumors 6502
 
Join Date: Jan 2010
Location: NW Oregon
I have been having this problem for almost a year. I've posted about it in different threads here and nobody has had any idea what to do with it.

Since my last post about it, I've learned a few things. First, after a trip to an Apple Store, they were ready to replace the motherboard and bluetooth board in my 17" MBP because of the problems. But then there was a warranty issue and that never happened.

Being thoroughly pissed, I bought a Windows machine and was ready to be rid of all things Apple. That lasted about fifteen minutes before I boxed up and returned the Windows machine.

So I went out a few days ago and got a new 11.6" MacBook Air. I thought, cool, I can finally be rid of this damn scrolling problem. Guess what? IT STILL EXISTS, even on the new machine!

I know it's not the mouse itself, necessarily (or if it is, it's a hardware flaw). I destroyed my first Magic Mouse last March one day when I was already pissed off and it sent me over the edge. So I bought a new one, and lo and behold, the problem still existed.

Back to now. So yeah, my new MBA is doing it too. I'm not sure what to do. It's not doing it as often as on my MBP (yet). I was unable to reproduce it the day I had the MBP at the Apple Store. I think the machine has to be on for a while before it does it.

What's really bad is it makes using Google Maps almost completely useless. Almost any mouse movement results in the maps zooming in and out. I LOVE this mouse, but I hate it too.

Rob
__________________
Late 2012 Mac Mini 2.6 i7/16gb/256gb SSD/1tb HD
Late 2013 rMBP 13 i5/16gb/512gb SSD
Galaxy Note 3 32gb AT&T
Rob.G is offline   0 Reply With Quote
Old Jan 7, 2011, 10:11 AM   #7
MayTrix
macrumors newbie
 
Join Date: Jan 2011
Quote:
Originally Posted by Rob.G View Post
What's really bad is it makes using Google Maps almost completely useless. Almost any mouse movement results in the maps zooming in and out. I LOVE this mouse, but I hate it too.

Rob
I was about to write that I've had the exact same problem, as well as constantly flipping pages back and forth while using the internet...

However, I had opened "mouse" in system preferences before reading this post and got side tracked. I was actually trying to look up what scrolling with or without inertia meant and hoped that would be the problem - and well I think I've fixed the problem. You simply have to change it to 'without' as inertia means momentum. When I took it off and tried google maps, no more craziness! I can still zoom in and out, it just doesn't fly around uncontrollably!


I hope this helps - I have been pretty close to throwing my mouse as well!
: )
MayTrix is offline   2 Reply With Quote
Old Jan 7, 2011, 11:27 AM   #8
Rob.G
macrumors 6502
 
Join Date: Jan 2010
Location: NW Oregon
So the bug appears to be in the Inertia code. Thing is, Inertia for me is what I LOVE about the Magic Mouse, or the Mac in general. Without it, it's no better than Windows.

FWIW, I recently experienced the "random scroll" bug when using just the touchpad. It was brief, but I also don't use the touchpad often. So I suspect this bug is amplified by the Magic Mouse. Maybe one day Apple will fix it.

Rob
__________________
Late 2012 Mac Mini 2.6 i7/16gb/256gb SSD/1tb HD
Late 2013 rMBP 13 i5/16gb/512gb SSD
Galaxy Note 3 32gb AT&T
Rob.G is offline   1 Reply With Quote
Old Jan 7, 2011, 01:09 PM   #9
JRoDDz
macrumors 68000
 
JRoDDz's Avatar
 
Join Date: Jul 2009
Location: NJ
What did you expect? It's a "magic" mouse. It magically scrolls by itself.
JRoDDz is offline   0 Reply With Quote
Old Jan 15, 2011, 02:36 PM   #10
Rob.G
macrumors 6502
 
Join Date: Jan 2010
Location: NW Oregon
Update... it's not the inertia code that's buggy. It's the entire scrolling routine.

I was just in Google Maps trying to plan a motorcycle ride today, and it was doing that damn zoom thing, so I opened Prefs and disabled Inertia, went back to using it. It was better, but after a few minutes it did it again. Frack. So I disabled scrolling entirely, and that solved it. Then I turned it back on when I was done.

Rob
__________________
Late 2012 Mac Mini 2.6 i7/16gb/256gb SSD/1tb HD
Late 2013 rMBP 13 i5/16gb/512gb SSD
Galaxy Note 3 32gb AT&T
Rob.G is offline   1 Reply With Quote
Old Feb 11, 2011, 08:58 AM   #11
keybon
macrumors newbie
 
Join Date: Feb 2011
Quote:
Originally Posted by Rob.G View Post

So I disabled scrolling entirely, and that solved it. Then I turned it back on when I was done.
I suppose nobody found a good solution for it, yet?

I have exactly the same problems and found a clue on Live View from Better Touch Tool. It looks like a mouse sends some random signals every 2 seconds and some of them are recognized as a scroll.

Short screencast: http://cl.ly/113J0X2d2V1R0b204001

Unfortunately I don't have any solution for it. I'll try to get a response from Apple support.
keybon is offline   0 Reply With Quote
Old Feb 11, 2011, 06:51 PM   #12
mindquest
macrumors regular
 
Join Date: Oct 2009
Quote:
Originally Posted by MayTrix View Post
I was about to write that I've had the exact same problem, as well as constantly flipping pages back and forth while using the internet...
Same problem when using the internet, it sucks especially when filling out forms and it goes back to the previous page.

Fingers crossed somebody has a fix otherwise I am thinking of getting a logitech mouse.
mindquest is offline   0 Reply With Quote
Old May 23, 2011, 01:53 PM   #13
d4niel
macrumors newbie
 
Join Date: May 2011
Location: Brazil
My solution

I got the same weird problem with my brand new 21" iMac. A blinking cursor, the magic mouse scrolls on its own while about long 30 seconds.

After three days hamming the mouse against the table, I accidentally turned off the wireless keyboard. It solved the problem.

So stupid...
d4niel is offline   0 Reply With Quote
Old Sep 30, 2011, 02:51 PM   #14
dbrok23
macrumors newbie
 
Join Date: Sep 2011
Had the Same Problem

I had a similar problem where the mouse pointer would disappear and the page would automatically keep scrolling to the bottom in an endless loop. I tried putting in new batteries in the wireless keyboard, and that seems to have worked so far. This error almost seems like it's caused by the space bar getting stuck, so if the battery swap doesn't work, try cleaning out your keyboard. Sometimes dust, crumbs, etc can cause problems. Try cleaning the keyboard with a can of air.
dbrok23 is offline   0 Reply With Quote
Old Jun 29, 2012, 12:38 PM   #15
offtoyoga
macrumors newbie
 
Join Date: Jun 2012
Quote:
Originally Posted by MayTrix View Post
I was about to write that I've had the exact same problem, as well as constantly flipping pages back and forth while using the internet...

However, I had opened "mouse" in system preferences before reading this post and got side tracked. I was actually trying to look up what scrolling with or without inertia meant and hoped that would be the problem - and well I think I've fixed the problem. You simply have to change it to 'without' as inertia means momentum. When I took it off and tried google maps, no more craziness! I can still zoom in and out, it just doesn't fly around uncontrollably!


I hope this helps - I have been pretty close to throwing my mouse as well!
: )

Finally! This worked for me! The uncontrolled scrolling was getting worse and worse ... changed batteries, got new keyboard, lost my mind (ha ha). Thank you so much for posting the solution to this incredibly annoying problem.
offtoyoga is offline   1 Reply With Quote
Old Jun 29, 2012, 10:33 PM   #16
harrisonw1998
macrumors regular
 
Join Date: Jul 2011
Try cleaning the top. If some oil or liquid gets on it, the tracking is messed up...... Happens to trackpads too.
harrisonw1998 is offline   0 Reply With Quote
Old Aug 29, 2013, 10:59 PM   #17
sircosti
macrumors newbie
 
Join Date: Aug 2013
I had the same problem, with a new iMac: I was getting a lot of random scrolling, in the middle of editing work, and it was very annoying.

Contacted Apple and they told me to do an SMC (?) reset, which changed nothing, of course.

I then realized that the problem was from an over-sensitive Magic Mouse. Many users seem to complain about this over-sensitivity, especially for newer computers.

So, a while ago, I took the following advice the website at the end of this post.

Control the touch-sensitive area of this mouse with the free app MagicPrefs (not clear why Apple does not provide something this useful):

download it from http://magicprefs.com/ and install

then go to its Preferences

in the new window that opens, click on Configure Scrolling, at the bottom right

you will then see the sensitive area of your mouse

click and drag to reduce that area

I had found that especially touching the edges of the mouse start the random scrolling

so, I made the touch-sensitive area for scrolling very small, and in the top-middle of the mouse, about where the scroll-wheel would be on a normal mouse.

Hope this saves you all a lot of frustration.

P.S. I learned about MagicPrefs from one of these frustrated people
http://blog.digitaltavern.com/mac-my...es-a-bad-combo
sircosti is offline   0 Reply With Quote
Old Oct 5, 2013, 02:32 PM   #18
Hermanvs
macrumors newbie
 
Join Date: Oct 2013
I had the same trouble. Then I noticed when the battery of the mouse was about 30% the irratic scrolling started. Disabling bluetooth and replacing batteries of the wireless mouse stopped the magic scrolling
Hermanvs is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Mac Peripherals

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
[Magic Mouse] Magic mouse scratched surface fix? MacDude21 Mac Basics and Help 8 Jan 18, 2014 07:26 PM
RSI? Should I Move from Magic Mouse to Magic Trackpad? ryan101 iMac 14 Aug 23, 2013 04:11 AM
buying apple magic tracpad or magic mouse for MBP? tbluhp Mac Peripherals 14 Jul 4, 2012 09:04 PM

Forum Jump

All times are GMT -5. The time now is 09:29 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps