Go Back   MacRumors Forums > Apple Applications > Mac Applications and Mac App Store

Reply
 
Thread Tools Search this Thread Display Modes
Old Feb 3, 2010, 11:41 AM   #1
Lava Lamp Freak
macrumors 65816
 
Join Date: Jun 2006
Google Chrome crashing iMac?

Twice in the last two days my iMac has turned off while I was in the middle of browsing, automatically rebooting itself. Both times the only console messages from the time that the crash occurred were from Chrome. Has anyone else experienced Google Chrome bringing a system down? The previous console messages were from 10:05. This is all there is before the crash happened, which was at 10:32:03. The iMac completed rebooting at 10:32:45. There was no error messages in the console or Finder upon rebooting.

2/3/10 10:32:01 AM [0x0-0x2d72d7].com.google.Chrome[2930] [0203/103201:WARNING:/b/slave/chrome-official-mac/build/src/chrome/app/breakpad_mac.mm(62)] Breakpad disabled
2/3/10 10:32:01 AM sandboxd[4622] Google Chrome He(4621) deny file-read-data /Library/InputManagers
2/3/10 10:32:01 AM sandboxd[4622] Google Chrome He(4621) deny file-read-data /Library/InputManagers
2/3/10 10:32:01 AM sandboxd[4622] Google Chrome He(4621) deny mach-lookup com.apple.windowserver.session
2/3/10 10:32:03 AM [0x0-0x2d72d7].com.google.Chrome[2930] [0203/103203:WARNING:/b/slave/chrome-official-mac/build/src/chrome/app/breakpad_mac.mm(62)] Breakpad disabled
2/3/10 10:32:03 AM sandboxd[4622] Google Chrome He(4623) deny file-read-data /Library/InputManagers
2/3/10 10:32:03 AM sandboxd[4622] Google Chrome He(4623) deny file-read-data /Library/InputManagers
2/3/10 10:32:03 AM [0x0-0x2d72d7].com.google.Chrome[2930] [2930:519:129394459522932:ERROR:/b/slave/chrome-official-mac/build/src/chrome/browser/cocoa/browser_window_cocoa.mm(139)] Not implemented reached in virtual void BrowserWindowCocoa::ShelfVisibilityChanged()

2/3/10 10:32:45 AM DirectoryService[15] Improper shutdown detected
Lava Lamp Freak is offline   0 Reply With Quote
Old Feb 3, 2010, 01:12 PM   #2
mac2x
macrumors 65816
 
Join Date: Sep 2009
I don't use Chrome, but in a Unix environment an application crash should not bring the entire system down. Try using another browser for a while and see if it happens again.
__________________
Retina MBP | 2.6 GHz i7 | 16 GB RAM

Gaming Rig | Core i7-2600K | 16 GB RAM | 160 GB OCZ Agility 2 | EVGA GTX 770 SC | Windows 7 Pro x64 | ASUS VG248QE
mac2x is offline   0 Reply With Quote
Old Mar 22, 2010, 01:06 PM   #3
Spiffman
macrumors newbie
 
Join Date: Mar 2010
The very same thing happened to me yesterday 3 times in a row.
Was browsing (idle) www.aftonbladet.se and bam - reboot.
No messages or anything, just a superfast clean reset.

Have not occurred since then...
Could not find any useful in the console to help me figure out what happened
Spiffman is offline   0 Reply With Quote
Old Nov 18, 2010, 03:03 PM   #4
lsixecho
macrumors newbie
 
Join Date: Nov 2010
Same Here

That is the exact same thing that is happening with my iMac I just purchased 2 months ago. This is a pretty old thread (9 months old) but it looks like the same problem still exists. My iMac just completely shuts down instantly like somebody unplugged the power cord when using chrome and I do notice that improper shutdown console message right near the shutdown. It might be my extensions or something because I went for quite a while and this didn't happen. It only recently started and I can't figure out why. I've since switched back to Safari, but I really love chrome and the extensions you can have. It's too bad some of us can't use this browser without our macs totally crashing on us.
lsixecho is offline   0 Reply With Quote
Old Nov 19, 2010, 12:20 AM   #5
macintoshtoffy
macrumors 6502a
 
macintoshtoffy's Avatar
 
Join Date: Jul 2009
Location: New Zealand
Quote:
Originally Posted by lsixecho View Post
That is the exact same thing that is happening with my iMac I just purchased 2 months ago. This is a pretty old thread (9 months old) but it looks like the same problem still exists. My iMac just completely shuts down instantly like somebody unplugged the power cord when using chrome and I do notice that improper shutdown console message right near the shutdown. It might be my extensions or something because I went for quite a while and this didn't happen. It only recently started and I can't figure out why. I've since switched back to Safari, but I really love chrome and the extensions you can have. It's too bad some of us can't use this browser without our macs totally crashing on us.
Have you run a memory test? did a clean install with all updates then run it? what are the hardware specifications because I wonder if you're running an iMac that has Flash which uses hardware acceleration whether a bug in the device driver is causing a kernel panic. Personally for me I haven't seen it happen on my iMac or my MacBook Pro - even still, run memtest86 and see what the results are.
__________________
iMac 2.66Ghz 20inch w/ 4GB RAM; MacBook Pro 'Unibody' 2.53Ghz w/ 4GB RAM; Mac OS X 'Snow Leopard'; 160GB iPod Classic; 1TB Western Digital USB EXT Hard Disk
macintoshtoffy is offline   0 Reply With Quote
Old Nov 19, 2010, 12:58 AM   #6
Roofy.
macrumors 6502a
 
Join Date: Jan 2009
I thought Chrome was amazing because of the slick interface. Then after awhile I realized it kinda sucked. GIF's cause the browser to lock up and freeze sometimes, Flash would cause it to freeze up, the most recent sites took forever to load on start up, it would automatically restart every freakin time I would restart the computer which was so damn annoying (and there was no way of changing it under preferences), and the typical "Do you want the browser to save your information" pop up was annoying with the way it popped up beneath the toolbar.

Then I installed Safari 5 and realized how much better it is. Its faster, the scrolling is smoother, the top pages don't take forever to load like chrome, and the new article reader is AMAZING. Every time there is an article I click on that. It actually gets me to want to read it just because its so much more simplified.
__________________
macmini | iPhone 4 | iPod touch | Pearl Jam iPod nano- SOLD for $500
Roofy. is offline   0 Reply With Quote
Old Nov 20, 2010, 12:11 AM   #7
lsixecho
macrumors newbie
 
Join Date: Nov 2010
Quote:
Originally Posted by macintoshtoffy View Post
Have you run a memory test? did a clean install with all updates then run it? what are the hardware specifications because I wonder if you're running an iMac that has Flash which uses hardware acceleration whether a bug in the device driver is causing a kernel panic. Personally for me I haven't seen it happen on my iMac or my MacBook Pro - even still, run memtest86 and see what the results are.
I just ran memtest (the default 3 times) and I have also run Apple Hardware Test from the boot disc and tech tool pro's memory test as well and all did not report any problems or errors. I am working on a mid-2010 iMac the i7 quad core, 16gb ram, every software is up to date.

I did speak too soon though because the same power down/crash thing happen inside safari once. Not nearly happening as often as in Chrome but still happening. I wish I could figure out why. The weird part is in the console, the log is always mixed up about the time things happen, e.g. there is always one log entry that is after it should be when this crash occurs and I power back on; ex:

11/18/10 2:57:59 PM [0x0-0x69069].com.google.Chrome[1010] [1010:34051:4890445963875:ERROR:/b/slave/chrome-official-mac/build/src/chrome/browser/sync/notifier/registration_manager.cc(126)] Registration failed with code: 12
11/18/10 2:57:59 PM [0x0-0x69069].com.google.Chrome[1010] [1010:34051:4890445983736:ERROR:/b/slave/chrome-official-mac/build/src/chrome/browser/sync/notifier/registration_manager.cc(126)] Registration failed with code: 12
11/18/10 2:57:59 PM [0x0-0x69069].com.google.Chrome[1010] [1010:34051:4890446003635:ERROR:/b/slave/chrome-official-mac/build/src/chrome/browser/sync/notifier/registration_manager.cc(126)] Registration failed with code: 12
11/18/10 2:57:59 PM [0x0-0x69069].com.google.Chrome[1010] [1010:34051:4890446023236:ERROR:/b/slave/chrome-official-mac/build/src/chrome/browser/sync/notifier/registration_manager.cc(126)] Registration failed with code: 12
11/18/10 2:57:59 PM [0x0-0x69069].com.google.Chrome[1010] [1010:34051:4890446042588:ERROR:/b/slave/chrome-official-mac/build/src/chrome/browser/sync/notifier/registration_manager.cc(126)] Registration failed with code: 12
11/18/10 2:57:59 PM [0x0-0x69069].com.google.Chrome[1010] [1010:34051:4890446061837:ERROR:/b/slave/chrome-official-mac/build/src/chrome/browser/sync/notifier/registration_manager.cc(126)] Registration failed with code: 12
11/18/10 2:57:59 PM [0x0-0x69069].com.google.Chrome[1010] [1010:34051:4890446081206:ERROR:/b/slave/chrome-official-mac/build/src/chrome/browser/sync/notifier/registration_manager.cc(126)] Registration failed with code: 12
11/18/10 2:57:59 PM [0x0-0x69069].com.google.Chrome[1010] [1010:34051:4890446100859:ERROR:/b/slave/chrome-official-mac/build/src/chrome/browser/sync/notifier/registration_manager.cc(126)] Registration failed with code: 12
11/18/10 3:15:40 PM [0x0-0x79079].com.apple.systemevents[1168] com.apple.FolderActions.enabled: Already loaded
11/18/10 3:19:35 PM kernel npvhash=4095
11/18/10 3:15:40 PM [0x0-0x79079].com.apple.systemevents[1168] launchctl: CFURLWriteDataAndPropertiesToResource(/var/db/launchd.db/com.apple.launchd.peruser.501/overrides.plist) failed: -10
11/18/10 3:19:35 PM kernel PAE enabled
11/18/10 3:19:35 PM kernel 64 bit mode enabled
11/18/10 3:19:35 PM kernel Darwin Kernel Version 10.5.0: Fri Nov 5 23:20:39 PDT 2010; root:xnu-1504.9.17~1/RELEASE_I386
11/18/10 3:19:35 PM kernel vm_page_bootstrap: 4094157 free pages and 67379 wired pages
11/18/10 3:19:35 PM kernel standard timeslicing quantum is 10000 us
11/18/10 3:19:35 PM kernel mig_table_max_displ = 73
11/18/10 3:19:35 PM kernel AppleACPICPU: ProcessorId=1 LocalApicId=0 Enabled



Do you see how the kernel npvhash=4095 is in at 3:19:35 PM but is located in-between two 3:15:40 Pm's? That happens every time it crashes. I don't know if it suggests anything, but it is certainly weird from what I've seen other people posting on Apple Discussion Forums. Also there is a different log entry before every reboot or else I would be able to pin down what caused it (for example, it is not always the case that the failed launchctl is prior to the reboot)
lsixecho is offline   0 Reply With Quote
Old Nov 20, 2010, 09:23 PM   #8
JuanGuapo
macrumors 6502
 
Join Date: May 2009
Location: Los Angeles, CA
Chrome 7 is the latest version, it supposedly fixed "hundreds" of bugs.

****************m67Wy
JuanGuapo is offline   0 Reply With Quote
Old Nov 21, 2010, 12:20 AM   #9
macintoshtoffy
macrumors 6502a
 
macintoshtoffy's Avatar
 
Join Date: Jul 2009
Location: New Zealand
Quote:
Originally Posted by lsixecho View Post
I just ran memtest (the default 3 times) and I have also run Apple Hardware Test from the boot disc and tech tool pro's memory test as well and all did not report any problems or errors. I am working on a mid-2010 iMac the i7 quad core, 16gb ram, every software is up to date.

I did speak too soon though because the same power down/crash thing happen inside safari once. Not nearly happening as often as in Chrome but still happening. I wish I could figure out why. The weird part is in the console, the log is always mixed up about the time things happen, e.g. there is always one log entry that is after it should be when this crash occurs and I power back on; ex:

11/18/10 2:57:59 PM [0x0-0x69069].com.google.Chrome[1010] [1010:34051:4890445963875:ERROR:/b/slave/chrome-official-mac/build/src/chrome/browser/sync/notifier/registration_manager.cc(126)] Registration failed with code: 12
11/18/10 2:57:59 PM [0x0-0x69069].com.google.Chrome[1010] [1010:34051:4890445983736:ERROR:/b/slave/chrome-official-mac/build/src/chrome/browser/sync/notifier/registration_manager.cc(126)] Registration failed with code: 12
11/18/10 2:57:59 PM [0x0-0x69069].com.google.Chrome[1010] [1010:34051:4890446003635:ERROR:/b/slave/chrome-official-mac/build/src/chrome/browser/sync/notifier/registration_manager.cc(126)] Registration failed with code: 12
11/18/10 2:57:59 PM [0x0-0x69069].com.google.Chrome[1010] [1010:34051:4890446023236:ERROR:/b/slave/chrome-official-mac/build/src/chrome/browser/sync/notifier/registration_manager.cc(126)] Registration failed with code: 12
11/18/10 2:57:59 PM [0x0-0x69069].com.google.Chrome[1010] [1010:34051:4890446042588:ERROR:/b/slave/chrome-official-mac/build/src/chrome/browser/sync/notifier/registration_manager.cc(126)] Registration failed with code: 12
11/18/10 2:57:59 PM [0x0-0x69069].com.google.Chrome[1010] [1010:34051:4890446061837:ERROR:/b/slave/chrome-official-mac/build/src/chrome/browser/sync/notifier/registration_manager.cc(126)] Registration failed with code: 12
11/18/10 2:57:59 PM [0x0-0x69069].com.google.Chrome[1010] [1010:34051:4890446081206:ERROR:/b/slave/chrome-official-mac/build/src/chrome/browser/sync/notifier/registration_manager.cc(126)] Registration failed with code: 12
11/18/10 2:57:59 PM [0x0-0x69069].com.google.Chrome[1010] [1010:34051:4890446100859:ERROR:/b/slave/chrome-official-mac/build/src/chrome/browser/sync/notifier/registration_manager.cc(126)] Registration failed with code: 12
11/18/10 3:15:40 PM [0x0-0x79079].com.apple.systemevents[1168] com.apple.FolderActions.enabled: Already loaded
11/18/10 3:19:35 PM kernel npvhash=4095
11/18/10 3:15:40 PM [0x0-0x79079].com.apple.systemevents[1168] launchctl: CFURLWriteDataAndPropertiesToResource(/var/db/launchd.db/com.apple.launchd.peruser.501/overrides.plist) failed: -10
11/18/10 3:19:35 PM kernel PAE enabled
11/18/10 3:19:35 PM kernel 64 bit mode enabled
11/18/10 3:19:35 PM kernel Darwin Kernel Version 10.5.0: Fri Nov 5 23:20:39 PDT 2010; root:xnu-1504.9.17~1/RELEASE_I386
11/18/10 3:19:35 PM kernel vm_page_bootstrap: 4094157 free pages and 67379 wired pages
11/18/10 3:19:35 PM kernel standard timeslicing quantum is 10000 us
11/18/10 3:19:35 PM kernel mig_table_max_displ = 73
11/18/10 3:19:35 PM kernel AppleACPICPU: ProcessorId=1 LocalApicId=0 Enabled



Do you see how the kernel npvhash=4095 is in at 3:19:35 PM but is located in-between two 3:15:40 Pm's? That happens every time it crashes. I don't know if it suggests anything, but it is certainly weird from what I've seen other people posting on Apple Discussion Forums. Also there is a different log entry before every reboot or else I would be able to pin down what caused it (for example, it is not always the case that the failed launchctl is prior to the reboot)
According to that dump you're running in 64bit mode (boot using the 64bit kernel) - have you loaded it into 32bit mode? I've heard rumours that the 64bit kernel can cause problems so you might wish to try booting using the 32bit kernel.
__________________
iMac 2.66Ghz 20inch w/ 4GB RAM; MacBook Pro 'Unibody' 2.53Ghz w/ 4GB RAM; Mac OS X 'Snow Leopard'; 160GB iPod Classic; 1TB Western Digital USB EXT Hard Disk
macintoshtoffy is offline   0 Reply With Quote
Old May 18, 2011, 12:49 AM   #10
lifeform
macrumors member
 
Join Date: Jan 2009
I am getting the same problemes here now.

See these console message + error report (that was supposed to be send to Apple Inc): http://dl.dropbox.com/u/8355845/Feilmeldingene.rtf

Brand new iMac... Maybe Chrome has something to do with this?

Also have problems with it renedering some webpages properly. Love the all sync experience with Google, but I canīt continue with if this is being the error. :-)

Excellent if you can help out bros (and female friends). Already e-mailed my local dealer about this + the national forum for Mac.
lifeform is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Applications > Mac Applications and Mac App Store

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Google Chrome on Imac 27" frankandsteph Mac Applications and Mac App Store 3 Feb 28, 2014 12:27 PM
Google Chrome & Google Chrome Renderer Activity Problem Rossagues Mac Basics and Help 15 Jul 18, 2013 12:13 AM
Google Chrome Causing Freezing and Crashing on New Mac Notebooks MacRumors MacRumors.com News Discussion 304 Apr 29, 2013 04:24 PM
Google chrome so slow On new imac 27 inch HELP joeycool iMac 4 Apr 25, 2013 05:11 AM
Google Chrome Browser, Google Drive Coming to iOS [Now Available] MacRumors MacRumors.com News Discussion 453 Dec 16, 2012 09:12 PM

Forum Jump

All times are GMT -5. The time now is 12:37 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC