Go Back   MacRumors Forums > Apple Systems and Services > OS X > Mac OS X Server, Xserve, and Networking

Reply
 
Thread Tools Search this Thread Display Modes
Old Mar 3, 2010, 08:58 PM   #1
EdTyler
macrumors newbie
 
Join Date: Feb 2010
Location: Alabama
Multiple Web sites configured for single IP

It is my understanding that the Mac Mini running OSX 10.6 server can be configured to run multiple web sites with different domain names on a single IP address. I have set up two sites with totally different domain names and can access them by toggling the port numbers. Port 80 default or 8080 as the alternate. I can force access by changing the web domain naming, ie domain.com vs www.domain.com. Incoming requests go to the first site in the list and they are sorted alphabetically.

The question is how do I set them up so that site xdomain.com receives only its reuests and site ydomain.com receives only the requests directed to it.

I used the server manager software to set up the second site as a custom site and the site works using the port numbers to force direction but not by using only the domain name for a URL.

Any help would be very much appreciated.

Ed
EdTyler is offline   0 Reply With Quote
Old Mar 3, 2010, 09:50 PM   #2
Les Kern
macrumors 68030
 
Les Kern's Avatar
 
Join Date: Apr 2002
Location: Alabama
no need to mess with ports. buy your domain names and point them to your IP, then tell their DNS servers what the exact path is for each site. Like www.mysite.com/site1, then mask that so the address is seen by the user as the domain name of the site. You can have as many sites do that as you want.
Les Kern is offline   0 Reply With Quote
Old Mar 3, 2010, 11:26 PM   #3
hakuryuu
macrumors 6502
 
Join Date: Sep 2007
Location: Lomita, CA
http://developer.apple.com/server/optimizexserve.html

Yeah it says xserve, but its all about the software.
__________________
ACTC
MBP 2.9GHz i7 | 8GB | 13" Retina
MBP 2.3GHz i7 | 8GB | 15" Retina
Mac Pro 3.7GHz | 12GB | D300
hakuryuu is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > OS X > Mac OS X Server, Xserve, and Networking

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Mail will not open in with multiple Exchange accounts configured Sbowen67 OS X Mavericks (10.9) 5 Oct 29, 2013 07:03 AM
The worst web sites I've ever seen! SrWebDeveloper Web Design and Development 2 Jun 6, 2013 09:18 AM
Host Multiple Sites 10.7 Server cclloyd Mac OS X Server, Xserve, and Networking 0 Mar 15, 2013 10:26 PM
Some web sites take long to load after 6.0.1 rd261 iPhone 0 Nov 10, 2012 08:38 AM
SuperDuper copy single/multiple folders only? Orlandoech Mac Applications and Mac App Store 1 Aug 17, 2012 02:50 AM

Forum Jump

All times are GMT -5. The time now is 12:16 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC