Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > iPhone, iPod and iPad > iPod

Reply
 
Thread Tools Search this Thread Display Modes
Old Mar 24, 2010, 01:27 AM   #1
michael31986
macrumors 65816
 
Join Date: Jul 2008
iPod skips songs halfway through, but plays fine through itunes?

ok i have a song that everytime i play it on my ipod at the 2 min and 15 second mark it skips to the next song. so i tried to play the song on my itunes and see if it also skipped. it doesn't, which makes me believe the song isn't corrupt. so i then thought to myself maybe it was transferred wrong, but i re transfered it and it still skips to the next song at the same part. i even plugged my iPod into my itunes and played it through the iPod on my computer and it plays through.

Only place it skips is if it play it on my actual iPod. i restarted the ipod and it still does it. I am wondering if it could just be my iPod? it doesn't do it to any other songs that i know of. Also if it is the iPod and not the actual songs. if i transfer my songs from the iPod to my computer they should all be fine right?

sorry if this sounds confusing!

my iPod is almost 3 yrs old. its the old 160gb, and the battery is shot on it already. What you think it is?
michael31986 is offline   0 Reply With Quote
Old Mar 24, 2010, 01:32 AM   #2
Surely
Guest
 
Join Date: Oct 2007
Location: Los Angeles, CA
When you retransferred it, was it removed from the iPod first?


What song is it?

Last edited by Surely; Mar 24, 2010 at 01:44 AM. Reason: A welcomed joy plays above the feminist average.
Surely is offline   0 Reply With Quote
Old Mar 24, 2010, 09:40 AM   #3
michael31986
Thread Starter
macrumors 65816
 
Join Date: Jul 2008
Yes I deleted nd then retransfered it. The same song plays on my nano fine. It's a Justin beiber song that a friend bought on iTunes so it's not like it's authorized. I don't get it.

It must be my iPod. I played a song just a min ago and it started skipping at the end then I replayed it and it played fine no skipping at the end. And the same song that stopped playing plays fine on my nano. Same file. So I dontget it.

Last edited by SilentPanda; Mar 24, 2010 at 01:31 PM. Reason: post merge
michael31986 is offline   0 Reply With Quote
Old Mar 24, 2010, 01:12 PM   #4
chown33
macrumors 603
 
Join Date: Aug 2009
^^^
Hard drive going bad?
chown33 is offline   0 Reply With Quote
Old Mar 24, 2010, 01:22 PM   #5
michael31986
Thread Starter
macrumors 65816
 
Join Date: Jul 2008
Does that mean if I copy songs back from iPod to my comuter and transfer it to a new iPod that they will play corrupted on another iPod? What I dontget is why all my songs that I put on iPod work great except for on or two randomly. And I rtransfer it so wth. If it was HD why would it keep picking same song.
michael31986 is offline   0 Reply With Quote
Old Mar 24, 2010, 01:28 PM   #6
erch63
macrumors member
 
Join Date: Aug 2007
Weird the same thing happens to me...

For me it is Kings of Leon on my iphone. Only song that ever does that. At least I am not alone.
erch63 is offline   0 Reply With Quote
Old Mar 24, 2010, 02:00 PM   #7
michael31986
Thread Starter
macrumors 65816
 
Join Date: Jul 2008
Ooh. How have u triEd to fix it? Is it a song u bought on iTunes?
michael31986 is offline   0 Reply With Quote
Old Mar 24, 2010, 02:27 PM   #8
erch63
macrumors member
 
Join Date: Aug 2007
Quote:
Originally Posted by michael31986 View Post
Ooh. How have u triEd to fix it? Is it a song u bought on iTunes?
I really haven't yet. I will try to take the song of and reload it, but it is just one song out of a 1000 so I never really thought much about it. I will try it when i get home and check back. I did buy the song from itunes BTW.
erch63 is offline   0 Reply With Quote
Old Mar 24, 2010, 02:49 PM   #9
michael31986
Thread Starter
macrumors 65816
 
Join Date: Jul 2008
I just don get how my nano plays it full and iPod classic doesn't. Th song can't be corrupt if it plays on iTunes. I just hope if I transfer all my songs from my iPod to a new classic that they will play fine there but I'm not sure how that works in terms of hds.
michael31986 is offline   0 Reply With Quote
Old Mar 24, 2010, 08:25 PM   #10
michael31986
Thread Starter
macrumors 65816
 
Join Date: Jul 2008
If it is harddrive failing. If I copy songs to my computer to put onto anothr iPod will some songs be corrupt or something or no? I'm so scared.
michael31986 is offline   0 Reply With Quote
Old Mar 25, 2010, 11:22 PM   #11
michael31986
Thread Starter
macrumors 65816
 
Join Date: Jul 2008
so i restored my ipod and put the same song back on and it still skips around same spot. someone told me it can be a problem with the ipod accessing the hd and it buffering or something. either way i went ahead and purchased the song myself on itunes and dragged it and now it plays in full, but the one that skipped was purchased by someone else so either way both were itunes purchased drm free files. and like i said earlier the song plays fine on itunes, nano and through my ipod classic on my itunes, so its wierd how just on the classic itself it skipped.
michael31986 is offline   0 Reply With Quote
Old Mar 25, 2010, 11:59 PM   #12
Jayyy
macrumors newbie
 
Join Date: Mar 2010
Location: Virginia
Have the same problem with one song on mine but I just delted the sing completly off iPod iTunes a hard drive redownloaded it and it works
fine.
__________________
Hakuna Matata
Jayyy is offline   0 Reply With Quote
Old Mar 26, 2010, 06:12 AM   #13
michael31986
Thread Starter
macrumors 65816
 
Join Date: Jul 2008
I Tried that originally but it still skipped and it was a purchased song. Mind u I didn't purchase it but still
michael31986 is offline   0 Reply With Quote
Old Mar 27, 2010, 12:00 AM   #14
michael31986
Thread Starter
macrumors 65816
 
Join Date: Jul 2008
if someone could help me out by putting the file on their ipod and seeing if it plays in full i would be very happy. i just don't seem to get how a song can't be accessed right by an ipod. i wanna make sure its the ipod and not the file. i already tried my nano and it plays on itunes, but idk if thats enough. if someone could try it on an older classic or something and let me know what happens. thank you so much

http://www.mediafire.com/?ngyw1wmkmqv
michael31986 is offline   0 Reply With Quote
Old Mar 27, 2010, 11:15 PM   #15
michael31986
Thread Starter
macrumors 65816
 
Join Date: Jul 2008
ok so here is an update. i decided to try the song on my friends 3rd generation nano and conclusion is it also skips on there at the same mark.

i am SO ****ING CONFUSED! lol maybe the old ipods just can't play it correctly?

i mean the 160gb classic and 3rd generation ipod nano came out same yr maybe its something with those ipods, cause it still plays on my 5th generation ipod nano and on itunes. its all very confusing.
michael31986 is offline   0 Reply With Quote
Old Oct 16, 2010, 08:02 PM   #16
BallerBoy
macrumors newbie
 
Join Date: Oct 2010
It's weird and annoying. I have a new iPod Touch 3rd gen and it is doing the exact same things to my songs as it is to yours. Not even halfway through, at the 12 second mark it changed song.

The songs play fine in iTunes. The songs are from legit CD's and have no scratches. They just skip on my ipod.

I have a feeling it's something to do with the software of itunes when it synces to the pod. it musn't complete a full sync or something. cos no one has an answer to fix this.

Last edited by BallerBoy; Oct 16, 2010 at 09:48 PM.
BallerBoy is offline   0 Reply With Quote
Old Oct 28, 2010, 04:06 AM   #17
Gajtani
macrumors newbie
 
Join Date: Oct 2010
I had the same issue, through alot of searching, I found out that the problem was the song itself. I downloaded a program to fix the song and it worked perfectly, only problem is I don't remember what that program was called.
Gajtani is offline   0 Reply With Quote
Old Apr 25, 2012, 01:37 PM   #18
tmlesinski
macrumors newbie
 
Join Date: Apr 2012
Same Problem

I am having the same shortened song problem. I noted 5 songs that stopped and skipped on my 6th gen. nano, and they also skip on my itunes, 4 of the songs at 2:56. How weird is that? All of these songs were purchased on iTunes. I do not want to repurchase all of the songs that skip, as I have hundreds that skip. I'll keep checking and trying other solutions.
tmlesinski is offline   0 Reply With Quote
Old Apr 25, 2012, 07:43 PM   #19
SLBear
macrumors newbie
 
Join Date: Feb 2010
It's the Music

It's Justin Beiber, and your older iPod just wants to puke.
SLBear is offline   1 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iPod

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
iPod nano 7th gen skips some songs in the middle - help fix it! sun surfer iPod 4 Jan 18, 2014 02:05 PM
No need to download songs? iPod Plays From Cloud iBreatheApple iOS 7 17 Jun 24, 2013 08:09 PM
iTunes plays 8 seconds then skips to next track knotgreen Mac Applications and Mac App Store 5 May 27, 2013 07:34 PM
iPhone 4 1080p video plays fine jeff92k7 iPhone 1 Jan 29, 2013 05:55 AM
Music app skips all songs iPhone4UK iOS 6 7 Oct 8, 2012 03:07 PM

Forum Jump

All times are GMT -5. The time now is 02:32 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC