Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Hardware > Notebooks > MacBook Pro

Reply
 
Thread Tools Search this Thread Display Modes
Old Apr 7, 2010, 10:09 AM   #1
KSBOOM
macrumors newbie
 
Join Date: Apr 2008
Macbook Pro HANGS - Can anyone help?

To whoever reads this, thank you in advance. My UbMBP 13 inch becomes completely non-functional from time to time - and won't work until I do a manual reboot by switching it off and turning it on by pressing the power button.

Could someone help me understand what may be wrong with my system? I've posted the data below.

Thank you.


ERROR REPORT

Wed Apr 7 20:20:39
panic(cpu 1 caller 0x2269e4): "thread_invoke: preemption_level -1, possible cause: unlocking an unlocked mutex or spinlock"@/SourceCache/xnu/xnu-1504.3.12/osfmk/kern/sched_prim.c:1471
Backtrace (CPU 1), Frame : Return Address (4 potential args on stack)
0x5899be18 : 0x21b449 (0x5ce420 0x5899be4c 0x2238a5 0x0)
0x5899be68 : 0x2269e4 (0x585e1c 0xffffffff 0x585db4 0x2262a8)
0x5899bee8 : 0x2270ea (0x813bb98 0x0 0x43dd7000 0x1)
0x5899bf58 : 0x227155 (0x22fa8f 0x863ea0 0x0 0x2a1596)
0x5899bf78 : 0x22fc29 (0x22fa8f 0x863ea0 0x0 0x0)
0x5899bfc8 : 0x29e6cc (0x863ea0 0x0 0x10 0x8b0b9e0)

BSD process name corresponding to current thread: kernel_task

Mac OS version:
10D573

Kernel version:
Darwin Kernel Version 10.3.0: Fri Feb 26 11:58:09; root:xnu-1504.3.12~1/RELEASE_I386
System model name: MacBookPro5,5
KSBOOM is offline   0 Reply With Quote
Old Apr 7, 2010, 10:12 AM   #2
Hellhammer
Moderator
 
Hellhammer's Avatar
 
Join Date: Dec 2008
Location: Helsinki, Finland
Send a message via MSN to Hellhammer
Repair permissions with Disk Utility and verify disk too. Give OnyX a try as well.

If that doesn't help, reinstall OS X. Make a backup ASAP if you don't have one
__________________
SSD Editor for AnandTech
You can also follow me in Twitter!
Hellhammer is offline   0 Reply With Quote
Old Apr 7, 2010, 10:17 AM   #3
thejadedmonkey
macrumors 604
 
thejadedmonkey's Avatar
 
Join Date: May 2005
Location: Pa
Send a message via AIM to thejadedmonkey
That model should still be under Applecare, take it to an Apple store and have them look at it.
__________________
MacBook 17" MacBook Pro iPod Nano Apple TV
PS4 Custom Windows 8.1 Desktop WP8.1
"Good judgment comes from experience,
experience comes from bad judgment."
- Mulla Nasrudin
thejadedmonkey is offline   0 Reply With Quote
Old Apr 7, 2010, 01:38 PM   #4
KSBOOM
Thread Starter
macrumors newbie
 
Join Date: Apr 2008
I'm definitely going to take it to an AASP. But was hoping someone could help me understand what's going wrong before that. Thank you to all of you for your helpful advice though. And If anyone does know what this is about, please do let me know.

Thank you
KSBOOM is offline   0 Reply With Quote
Old Apr 8, 2010, 06:02 PM   #5
jockey2
macrumors newbie
 
Join Date: Apr 2010
Same problem

I have totally the same problem with the same message. I am about to reinstall the whole OS.
Did you figure out your case?
jockey2 is offline   0 Reply With Quote
Old Apr 8, 2010, 07:22 PM   #6
Relznuk
macrumors 6502
 
Join Date: Sep 2009
Location: UT, USA
Quote:
Originally Posted by KSBOOM View Post
I'm definitely going to take it to an AASP. But was hoping someone could help me understand what's going wrong before that. Thank you to all of you for your helpful advice though. And If anyone does know what this is about, please do let me know.

Thank you
Sounds like an issue with your RAM.
Relznuk is offline   0 Reply With Quote
Old Apr 11, 2010, 01:26 AM   #7
KSBOOM
Thread Starter
macrumors newbie
 
Join Date: Apr 2008
No - I haven't been able to figure out the case. Spoke to an Apple technician on the phone, he said to repair permissions, reset pram etc etc. The basic steps (don't quite remember all of them) That hasn't helped. I've tested my ram with Tech Tool Pro 5, it doesn't seem to indicate any problems with the ram sticks.

Jockye2 - I haven't been able to figure out what the problem is yet. If you manage to find the cause before I do, let me know.

Thank you to everyone who has taken the time out to suggest solutions.
KSBOOM is offline   0 Reply With Quote
Old Apr 11, 2010, 01:54 AM   #8
ayeying
macrumors 601
 
ayeying's Avatar
 
Join Date: Dec 2007
Location: Yay Area, CA
Send a message via AIM to ayeying
Quote:
Originally Posted by KSBOOM View Post
No - I haven't been able to figure out the case. Spoke to an Apple technician on the phone, he said to repair permissions, reset pram etc etc. The basic steps (don't quite remember all of them) That hasn't helped. I've tested my ram with Tech Tool Pro 5, it doesn't seem to indicate any problems with the ram sticks.

Jockye2 - I haven't been able to figure out what the problem is yet. If you manage to find the cause before I do, let me know.

Thank you to everyone who has taken the time out to suggest solutions.
Just because it didn't indicate any problems doesn't mean there aren't any. Real memory tests take 48 hours to run to see if theres any problems.
__________________
MacBook Pro 15" | 2.6GHz Core i7, 16GB DDR3L, 1TB SSD, Iris Pro + GT 750M 2GB, Retina, 10.9.4, 8.1 Pro Update 1
iPhone 5 | White, 64GB, AT&T, iOS 7.1.2
iPad Mini | White, 32GB, AT&T, iOS 7.1.2
ayeying is offline   0 Reply With Quote
Old Apr 12, 2010, 02:37 AM   #9
KSBOOM
Thread Starter
macrumors newbie
 
Join Date: Apr 2008
Alright, I'll take it in to an AASP. Jockey2 - I'll let you know when they let me know what's wrong. But it may take a while because the AASP in my area works at their own pace. Thank you everyone for your help.
KSBOOM is offline   0 Reply With Quote
Old Apr 12, 2010, 06:46 AM   #10
Weirddoc
macrumors newbie
 
Join Date: Apr 2010
Quote:
Originally Posted by KSBOOM View Post
Alright, I'll take it in to an AASP. Jockey2 - I'll let you know when they let me know what's wrong. But it may take a while because the AASP in my area works at their own pace. Thank you everyone for your help.
Please keep me posted as well, because I have the same issue!

panic(cpu 1 caller 0x2269e4): "thread_invoke: preemption_level -1, possible cause: unlocking an unlocked mutex or spinlock"@/SourceCache/xnu/xnu-1504.3.12/osfmk/kern/sched_prim.c:1471
Backtrace (CPU 1), Frame : Return Address (4 potential args on stack)
0x58753e28 : 0x21b449 (0x5ce420 0x58753e5c 0x2238a5 0x0)
0x58753e78 : 0x2269e4 (0x585e1c 0xffffffff 0x585db4 0x2262a8)
0x58753ef8 : 0x2270ea (0x81227c4 0x3 0x2c 0x0)
0x58753f68 : 0x219096 (0x29e695 0x0 0x1 0x4ec9dc)
0x58753fa8 : 0x2a7a07 (0xffffffff 0x1 0x58753fc8 0x7f9aea4)
0x58753fc8 : 0x29e8a6 (0x0 0x0 0x10 0x7f9aea4)
Weirddoc is offline   0 Reply With Quote
Old Jun 17, 2010, 12:50 PM   #11
wilsonhaven
macrumors member
 
Join Date: Oct 2009
Possible Virtualization Issue

I am having the same issue. After some research it seems that all of the recent users having this problem are using either VMware Fusion (Version 3.0.2 and 3.1), Parallels, or VirtualBox. It seems that something in how they interact with the kernel is causing the problem. Is anyone with Apple Care support getting any information from Apple? I haven't found an answer yet on the VMware Fusion forum yet.

Thanks!

Model Name: MacBook Pro
Model Identifier: MacBookPro5,3
Processor Name: Intel Core 2 Duo
Processor Speed: 2.8 GHz
Number Of Processors: 1
Total Number Of Cores: 2
L2 Cache: 6 MB
Memory: 4 GB
Bus Speed: 1.07 GHz
Boot ROM Version: MBP53.00AC.B03
SMC Version (system): 1.48f2

Last edited by wilsonhaven; Jun 17, 2010 at 12:51 PM. Reason: Typo
wilsonhaven is offline   0 Reply With Quote
Old Jun 17, 2010, 02:10 PM   #12
wilsonhaven
macrumors member
 
Join Date: Oct 2009
I checked my system with OnyX and found that i have a boot volume structure issue. It passed the S.M.A.R.T. tests. I'll update with the results. Have others with this problem ruled out disk issues?

Thanks!
wilsonhaven is offline   0 Reply With Quote
Old Aug 3, 2010, 11:46 PM   #13
KSBOOM
Thread Starter
macrumors newbie
 
Join Date: Apr 2008
I'm not using any of these - neither VMware Fusion (Version 3.0.2 and 3.1), Parallels, or VirtualBox. I even changed my hard drive to rule out boot issues and the problem is still occurring. If anyone has any updates or solutions to this problem, please let us know.
Thanks.
KSBOOM is offline   0 Reply With Quote
Old Aug 4, 2010, 12:02 AM   #14
J&JPolangin
macrumors 68020
 
Join Date: Jul 2008
Location: Japan...at the waters edge...
I had a similar problem with my netbook and tech's said it "couldn't be fixed

I swapped the upgraded HDD back to the original HDD, same issue... installed a SSD with a clone of the original HDD...issue developed...

Finally did a full install from the included OS disks and the problems went away... have you tried reloading OSX from your restore disks yet?
__________________
2011 21" iMac, AEBS, 2009 2.0Ghz nVidia 9400M WB 4GB RAM & 64Gb SSD, 2011 13" MBP w/ 512Gb SSD/8Gb RAM, 2013 11.6" MBA & iPad3 64gb 4G
PC's: X6, H60, 12Gb RAM, 3x1Tb HDD, 128Gb SSD
J&JPolangin is offline   0 Reply With Quote
Old Aug 4, 2010, 04:41 AM   #15
KSBOOM
Thread Starter
macrumors newbie
 
Join Date: Apr 2008
Yes. This is a fresh install - installed from the 10.6 Macbook Pro discs. It seems to be more of a Mac hardware issue than a hard disk issue. The same issue is occurring with 2 different hard disks indicating the common factor may be the Macbook Pro instead of the hard disks. However if anyone has any more helpful information, I'd appreciate it. I will update when I receive any more information also. As always, thank you for your help.
KSBOOM is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Notebooks > MacBook Pro

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Late 2008 white macbook screen hangs at logo mcfortunato MacBook 1 Nov 10, 2013 09:03 AM
Mac Pro hangs on reboot grapefruitmoon Mac Basics and Help 0 Jun 13, 2013 02:14 PM
MacBook Air hangs for a few moments on wake someguy MacBook Air 10 Oct 28, 2012 08:18 AM
MacBook Air (Snow Leopard) hangs at boot rpdhuk OS X 0 Sep 27, 2012 10:57 AM
2010 macbook occasionally hangs in dock therealseebs MacBook Pro 0 Jun 1, 2012 10:43 AM

Forum Jump

All times are GMT -5. The time now is 03:12 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC