Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > iPhone, iPod and iPad > iPad

Reply
 
Thread Tools Search this Thread Display Modes
Old Apr 20, 2010, 08:34 PM   #1
Cyroceon
macrumors 6502
 
Join Date: Feb 2008
iPad Youtube Buffering...

Is it me or are you guys also noticing how UNGODLY slow it is to load a video on Youtube? It feels like FOREVER to load a video on youtube, and it seems to be on the iPad only. However, I was able to replicate the problem ONCE on my MacBook, but the internet in general is blazingly fast. Could it be Youtube?
__________________
CyRo
MC505LL/A MacBook Air 1.4Ghz, 4GB DDR3 Ram, 128GB SSD
iPad Air 16GB Black & Space Gray
iPhone 5 16GB Black & Slate
Cyroceon is offline   0 Reply With Quote
Old Apr 20, 2010, 08:38 PM   #2
ZombiePete
macrumors 6502a
 
Join Date: Aug 2008
Location: San Antonio, TX
YouTube loads slower on my iPhone than on my other computers. Do you see it in just the YouTube app or on the YouTube site as well?
ZombiePete is offline   0 Reply With Quote
Old Apr 20, 2010, 08:38 PM   #3
MythicFrost
macrumors 68040
 
MythicFrost's Avatar
 
Join Date: Mar 2009
Location: Australia
Some people, including myself have this issue. I'm not sure what it is, but it also happens on my iPhone on WiFi. You'll find a lot of posts I think if you searched for YouTube WiFi problems or something.
__________________
(Log Book Buddy) - (Quick Kana)
MythicFrost is offline   0 Reply With Quote
Old Apr 20, 2010, 08:41 PM   #4
kirchnrd
macrumors 6502
 
Join Date: Jun 2009
Y E S... And it drives me crazy. It is related to the iPad for me. Mac and iPhone are ok. My guess is that the YouTube iPad app defaults to the highest quality video.
__________________
13" MacBook Pro 32GB iPhone 4S iPod Nano iPad 32GB WiFi on the way!
kirchnrd is offline   0 Reply With Quote
Old Apr 20, 2010, 08:42 PM   #5
RawBert
macrumors 68000
 
RawBert's Avatar
 
Join Date: Jan 2010
Location: North Hollywood, CA
I have that too, but only on hi Rez videos. The crappy quality ones load quick. But I have the same effect on my iPod.

Quote:
Originally Posted by kirchnrd View Post
My guess is that the YouTube iPad app defaults to the highest quality video.
I think you're right.
__________________
THE ART OF RAW
Steve Lives On
RawBert is offline   0 Reply With Quote
Old Apr 20, 2010, 10:24 PM   #6
bluehaze013
macrumors 6502
 
Join Date: Nov 2007
Happens to me all the time, I wonder if it si something to do with HTML 5 because when it's happening on my iPad I can load the same videos up on my net book or desktop (only they are the flash versions) and everything works fine everything else being the same. I use to think it was lack of ram but it seems to do it even after a full reboot so I doubt it.
bluehaze013 is offline   0 Reply With Quote
Old Apr 20, 2010, 11:02 PM   #7
Cinder6
macrumors 6502
 
Join Date: Jul 2009
My Youtube app is slow, but the site loads videos just fine. It's annoying.
Cinder6 is offline   0 Reply With Quote
Old Apr 20, 2010, 11:02 PM   #8
GrindedDown
macrumors regular
 
Join Date: Jun 2009
Location: Las Vegas
I have been testing the HTML5 beta YouTube on my MBP and it is really slow. Not a huge fan of it and have been trying to disable it for now.

Edit: After comparing the HTML5 and non HTML5 versions on my comp the speed difference is actually pretty negligble.

Last edited by GrindedDown; Apr 20, 2010 at 11:46 PM.
GrindedDown is offline   0 Reply With Quote
Old Apr 20, 2010, 11:26 PM   #9
jeffy777
macrumors 6502
 
Join Date: Mar 2010
Yup, it's definitely slow, even on a very fast wifi network.

The same videos load fine on my other computers on the network.
jeffy777 is offline   0 Reply With Quote
Old Apr 21, 2010, 04:25 AM   #10
usher
Banned
 
Join Date: Apr 2010
Send a message via ICQ to usher
have you guys known how to convert youbube video to MKV? or directly find MKV from youtube?
usher is offline   0 Reply With Quote
Old Apr 21, 2010, 05:41 AM   #11
Ramiarna
macrumors newbie
 
Join Date: Apr 2010
Same problem here. Websites load fast and everything is great. Only Youtube vids both on the Youtube app and youtube through safari are extremely slow.
Ramiarna is offline   0 Reply With Quote
Old Apr 21, 2010, 08:40 AM   #12
Ak8s
macrumors newbie
 
Join Date: Mar 2010
Well, this morning on my Windows PC, youtube was a pain. Very slow to load and the search feature was unavailable.
So, based on that, my guess is it's a youtube problem and not an ipad problem.
Someday soon I'll get to try it on MY ipad...if I can get my hands on one ha!
Ak8s is offline   0 Reply With Quote
Old Apr 21, 2010, 08:55 PM   #13
jb32828
macrumors newbie
 
Join Date: Apr 2010
I played around with this for an hour tonight and i believe this is a software issue in the ipad. Specifically having to do with the way the ipad is buffering the streams from youtube and itunes.

I tested this watching three different versions of the avatar trailer on youtube. Of all of them satlled after about ten seconds of video. Peering further, i noticed that the activity light on the access point in my living room was blinking as in heavy nonstop activity. It kept blinking even while the video was stalled out. This particular access point repeats to the access point in the office via wds. All of my home access points are running ddwrt on the linksys wrt 54g platform.

I looked at the router in the office which is the head end, and the activity light was going non stop as well, and a look at the activity on the status page indicated that indeed the data was coming in like a rocket.

I had the same result using youtube and also trying to view the trailer on itunes.

Now contrast this behavior to the behavior of the ipad while running the abc player app. I started the latest episode of lost in abcplayer. This runs flawlessly. The video starts after about 6 seconds, and does not stutter or stall, ever.

While the video was playing, i noticed that the activity light on the access point would only blink activity in bursts. This bursts would last 2-4 seconds and in between for 2-4 seconds there would be no acitivity. I confirmed this on the status page on the internet connected ap, the data transfer was coming in small bursts rather than constant non stop.

While i am disappointed in the performance of the ipad, it leaves me hope that it is simply a software fix and not a hardware problem or worse simply not enough ram and a major design flaw.

I hope apple gets it fixed soon. The youtube thing and especially itunes is really annoying.
jb32828 is offline   0 Reply With Quote
Old Apr 21, 2010, 11:08 PM   #14
kirchnrd
macrumors 6502
 
Join Date: Jun 2009
I am running html5 beta on YouTube via the Mac, and it is very slightly faster for me. I think it might be the app itself now as well. Should be very fixable.
__________________
13" MacBook Pro 32GB iPhone 4S iPod Nano iPad 32GB WiFi on the way!
kirchnrd is offline   0 Reply With Quote
Old Apr 21, 2010, 11:21 PM   #15
rorschach
macrumors 68000
 
Join Date: Jul 2003
YouTube is always ungodly slow for me - Mac, PC, iPhone, iPad. Whatever internet connection.

I blame YouTube.
__________________
MacBook Air 13-inch (Mid 2012), iPhone 5
rorschach is offline   0 Reply With Quote
Old Apr 22, 2010, 12:06 AM   #16
1appleAday
macrumors regular
 
Join Date: Mar 2008
yes i notice it buffers a lot too. pretty annoying
1appleAday is offline   0 Reply With Quote
Old Apr 22, 2010, 12:14 AM   #17
1appleAday
macrumors regular
 
Join Date: Mar 2008
sorry for double post. mod: please remove this
1appleAday is offline   0 Reply With Quote
Old Apr 22, 2010, 12:27 AM   #18
lilo777
Banned
 
Join Date: Nov 2009
Quote:
Originally Posted by rorschach View Post
YouTube is always ungodly slow for me - Mac, PC, iPhone, iPad. Whatever internet connection.

I blame YouTube.
So you are saying that YouTube is terrible on all computers and all internet connections. I am not sure many people will agree with you.
lilo777 is offline   0 Reply With Quote
Old Apr 22, 2010, 12:45 AM   #19
kepner
macrumors 6502
 
Join Date: Sep 2003
Quote:
Originally Posted by kirchnrd View Post
My guess is that the YouTube iPad app defaults to the highest quality video.
That's my guess too.
kepner is offline   0 Reply With Quote
Old May 3, 2010, 07:55 PM   #20
Alexamo
macrumors newbie
 
Join Date: May 2010
Location: West Hollywood
Hi,
Just wanted to let you know that I tried with 2 different provider and router. It worked great with one and very bad/slow with the other one. I Madeleine a little video on youtube so you can how it is when it doesn't work for me...

http://www.youtube.com/watch?v=j0TRbhynL_4
Alexamo is offline   0 Reply With Quote
Old May 3, 2010, 09:42 PM   #21
Thetwins
macrumors newbie
 
Join Date: May 2010
Registered just to complain about this!

I love the iPad...I really do! YouTube videos are obscenely slow, though. I even visited the Genius Bar today. Of course, on Speedtest, my home connection was 1.26 Mbps, and YouTube is just as everyone describes..slow, freezes, never able to play more than 10sec @ a time. At the apple store, YouTube acted perfectly (slight freeze once, but the apple guy just shrugged it off as a buffering hiccup). Speedtest there showed 8+ Mbps, of course. So the guy chalked it up to my slow Internet speed. Sigh.

The problem though, is that with the SAME home connection, I have no prob. Watching Youtube on my Mac mini OR my old pc laptop. I really hope they fix it soon....if anyone has a temporary fix, I'd love to hear it!
Thetwins is offline   0 Reply With Quote
Old May 4, 2010, 05:24 AM   #22
Alexamo
macrumors newbie
 
Join Date: May 2010
Location: West Hollywood
At home, I havé optimal fibre and n wifi. So like at The Apple store, I have 8+ mbps.... But it freeze! But it works fine with my old unbundled ADSL that I still have for a few days...
I beleive it is a question of router.
I also hope that Apple will come with an update...
Alexamo is offline   0 Reply With Quote
Old May 4, 2010, 05:30 AM   #23
Cyroceon
Thread Starter
macrumors 6502
 
Join Date: Feb 2008
Quote:
Originally Posted by Thetwins View Post
I love the iPad...I really do! YouTube videos are obscenely slow, though. I even visited the Genius Bar today. Of course, on Speedtest, my home connection was 1.26 Mbps, and YouTube is just as everyone describes..slow, freezes, never able to play more than 10sec @ a time. At the apple store, YouTube acted perfectly (slight freeze once, but the apple guy just shrugged it off as a buffering hiccup). Speedtest there showed 8+ Mbps, of course. So the guy chalked it up to my slow Internet speed. Sigh.

The problem though, is that with the SAME home connection, I have no prob. Watching Youtube on my Mac mini OR my old pc laptop. I really hope they fix it soon....if anyone has a temporary fix, I'd love to hear it!
I think YouTube knows about this. The problem that iPads are having is that they attempt to load HD video, unlike iPhones, and the YouTube app is not set up to buffer well with certain connections. I know that I still receive this problem sometimes, but for the most part they fixed something. Just hang in there, they should be fixing this stuff soon.
__________________
CyRo
MC505LL/A MacBook Air 1.4Ghz, 4GB DDR3 Ram, 128GB SSD
iPad Air 16GB Black & Space Gray
iPhone 5 16GB Black & Slate
Cyroceon is offline   0 Reply With Quote
Old May 4, 2010, 05:49 PM   #24
Alexamo
macrumors newbie
 
Join Date: May 2010
Location: West Hollywood
Hi guys,
I may have found a solution. I changed my provider DNS by statics DNS from opendns.com
Don't need to pay. Just register for a free account. I am not even sure you need an account...
Here are the DNS : 208.67.222.222 and 208.67.220.220

Tell me if it works for you!!!
Alexamo is offline   0 Reply With Quote
Old May 9, 2010, 05:05 PM   #25
johnniewalker
macrumors member
 
Join Date: Jun 2006
Location: Blackpool, England
Yep, just to confirm the above post changing the DNS settings worked for me!

YouTube vids now load fine
__________________
My Websites built and maintained with a Mac!
dekoded.com
Coffee Beans, Machines & More Coffee Beans, Machines & More
johnniewalker is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iPad

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
All iPads: Why does YouTube stop buffering video when switching to home screen? Zolitoo iPad 9 Aug 3, 2013 09:55 AM
Background buffering problem on youtube with chrome and OSX Husky1992 OS X 10.8 Mountain Lion 2 Jun 12, 2013 12:54 PM
YouTube keeps re-buffering fenjen MacBook Pro 1 May 25, 2013 01:38 PM
Help... Youtube just stops buffering/freezing every 30 seconds! Jonny77w iMac 4 Nov 14, 2012 10:31 PM
iPad: ipad 3/ipad 4 Speed test..youtube MrMacBookPro iPad 8 Nov 9, 2012 11:42 AM

Forum Jump

All times are GMT -5. The time now is 05:37 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC