Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > iPhone, iPod and iPad > iPad

Reply
 
Thread Tools Search this Thread Display Modes
Old Apr 24, 2010, 05:27 AM   #1
Kahnyl
macrumors 68000
 
Join Date: Feb 2009
You've already purchased this but it hasn't been downloaded....."

"You've already purchased this but it hasn't been downloaded. To download it, go to Purchases and tap Redownload."

I bought a book earlier but the download stopped a fifth of the way through. When I went back to the store and clicked purchase again I got that message. So I went to Purchases and tapped on Redownload. I got the same message again!

I just know it's because there's a partially downloaded file somewhere and that if I deleted that this would probably be fixed but obviously I can't do that yet.

Has anyone run into this problem and know of a solution besides rebooted and resyncing, which didn't work?
Kahnyl is offline   0 Reply With Quote
Old Apr 24, 2010, 01:02 PM   #2
BaronStein
macrumors regular
 
Join Date: Feb 2010
Location: NY
Just restart your iPad. And check whether the app is downloading. If it says paused, then tap it. Or, if you can't find, try to download it from app store again.

Sometimes, I have similar problems on my iPad too. Restarting usually make things work...
__________________
Baronstein Watches You!
BaronStein is offline   0 Reply With Quote
Old Apr 24, 2010, 01:46 PM   #3
Kahnyl
Thread Starter
macrumors 68000
 
Join Date: Feb 2009
It's an iBook.

It's not on my bookshelf except for the brief moment between tapping it in purchases, the shelf spinning around and me getting the message. I've tried uninstalling iBooks but if there's corrupt data somewhere that isn't helping because when I re-install iBooks all my books show up without me reloading them from iTunes. Even ones I haven't bought from Apple, so it's not like they're being redownloaded.

So for some reason the iPad isn't deleting that app's data after it's gone.

EDIT: Got this (second) reply from support. Crappy solution.

"Heather here again, and I am so sorry that you are still unable to download this book.

I am just letting you know that since you have been unable to download this book, I have removed this from your download queue for you, and refunded your purchase in the amount of $7.99.

The credit will be posted to your account in three to five business days.

Please wait at least two weeks before repurchasing this title. This will give us time to investigate the issue and make any corrections that may be necessary."

EDIT 2:

I tried the download again, and it worked.

Last edited by Kahnyl; Apr 24, 2010 at 02:23 PM.
Kahnyl is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iPad

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
iOS7 not saving downloaded music to Purchased playlist treycopeland86 iOS 7 0 Oct 4, 2013 09:43 AM
Twitter shows up in "Updates" of Mac App Store even though I never downloaded it? superriku11 Mac Applications and Mac App Store 6 May 22, 2013 08:44 PM
Show Downloaded Media as 'Purchased' in iTunes -BigMac- Mac Applications and Mac App Store 0 Jan 8, 2013 10:38 PM
Movie purchased on iPhone not showing up in "purchased" hafr iPhone 0 Jan 2, 2013 03:30 AM
How long will a purchased movie stay downloaded on Apple TV 2? Jman13 Apple TV and Home Theater 2 Oct 7, 2012 01:48 PM

Forum Jump

All times are GMT -5. The time now is 09:58 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC