Go Back   MacRumors Forums > Apple Systems and Services > OS X

Reply
 
Thread Tools Search this Thread Display Modes
Old May 3, 2010, 03:43 PM   #1
markw10
macrumors 6502
 
Join Date: Sep 2006
Snow Leopard Hanging-Running VERY SLOW

I am having a problem with running Snow Leopard on my MBP. It's running extremely slow and beachballing a lot. Here is the issue.

The computer is almost 3 years old to the day and is a Core 2 Duo MBP and has 4GB of memory. I upgraded to Snow Leopard a few months ago and am running the newest update.
About 6 months ago I experienced a video problem and the Apple Store replaced it with a new logic board. A few days later I experienced networking issues. it would connect to Wi-Fi but would not get any internet. The Apple store tried a few things to fix corrupt files and was unable to fix it. They suggested a reinstall of Leopard which is what I was running at that time but instead I did an upgrade to Snow Leopard. It immediately fixed the problem and my computer was running fast. I left this out but as part of the Snow Leopard upgrade I upgraded the hard drive to a 640GB drive.

Then a few days ago it began running slow. It seems to start slow so I thought it was just too many programs running and my computer was showing it's age. Yet it has gotten far worse and I know it may be a deeper issue.

I have questioned if it could be an issue with memory. Would this slow it down?
I tend to think its' software related, not hardware.

The question: How do I troubleshoot something like this? It happens as soon as I boot it up, I don't even have to start any programs. I have looked at my login items in accounts and see a few things like growl and a scanner application. The only other thing I see is I noticed there is 4 items relating to SOHO Organizer. I don't believe these should be slowing it down.

As an example when I boot it and log on at that point, it can beachball for 10 minutes before I get into the screen with the dock, etc. Dashboard won't even work. When I click on dashboard it brings up the calculator, weather, etc. but nothing opens up. i simply see the blank calculator but nothing is lighting up to type on it, no weather details, etc. and this is after bootup or using it.

When I try to close an application it can take a minute, it can take a minute to switch, it. My computer is nearly unusable.

If necessary I'll go to the Apple store but it just left the warranty period and I'm convinced its' simply something software related, maybe something that's hanging it. Any ideas of what could be wrong or how to troubleshoot to find out?

Thank you in advance for your help.
markw10 is offline   0 Reply With Quote
Old May 3, 2010, 04:44 PM   #2
calderone
macrumors 68040
 
calderone's Avatar
 
Join Date: Aug 2009
Location: Seattle
Login Items are a small part of the equation.

1. To troubleshoot the login issue, read the advice I gave in this current thread: http://forums.macrumors.com/showthread.php?t=909602

2. Check Activity Monitor, you want to see if there is a process using an abnormal amount of resources

3. More generally, try Safe Boot (which implies Safe Login). Hold Shift after you power on your Mac. See how things run in this mode. From here, you will need to find what is causing the issue. You can check Console for errors.

3. Run Apple Hardware Test
It sounds like yours came with a version of OS X pre 10.5.4, so put in the Install Disc 1 that came with your machine and hold down the D key to start the hardware test.
__________________
ACSA, ACMT
calderone is offline   0 Reply With Quote
Old May 3, 2010, 06:58 PM   #3
flipster
macrumors 6502a
 
Join Date: Mar 2010
Location: Boston
Your going to like me and hate me for this. Your going to need to do a clean install of Snow Leopard. Look it up, it basically saved my iMac. Like you, after I upgraded to Snow Leopard I had encountered many problems. My hard drive had been noisy, and it was slow. I didn't want to erase everything and start over but I did and it's literally so much faster now. I really think this could help you. What a clean install of Snow Leopard is is when you stick the Snow Leopard disk in your computer and then shut it off. You then hold down the option key and boot from the cd. You have to eraser everything on your computer. Look up instructions for how to do this though because you don't want to mess up your computer. I really think you should do that. When I did that I can't hear my hard drive anymore and everything is faster.
flipster is offline   0 Reply With Quote
Old May 4, 2010, 01:33 AM   #4
markw10
Thread Starter
macrumors 6502
 
Join Date: Sep 2006
I did some work this evening. For some reason I was unable to get into safe mode and I pressed and held the Shift key hoping to go into safe mode.

After that I tried the option of a hardware test by inserting the #1 CD that came with the MBP and booting up using D. I ran the extensive hardware test and it found no errors.

Yet I have even pulled the power cord and battery and did a restart and am having the same problem. I even had a few times it would not even boot. It would get to the grey apple with the progress indicator below and would be like that for 15-20 mins, never going further so I may have even deeper issues.

Fortunately I had been doing hard drive backups using Super Duper so I connected that drive and did a boot from it. I was excited since it seemed to boot at first and then was very slow and appeared to freeze as the icons were appearing on the desktop. I have only tried this once but since that's the case I didn't think it was the internal hard drive that was the issue.

Then I decided to hook the external back up drive to the other MBP our family has. I then booted up and was shocked how well it ran. It was running on USB but I got straight into the OS and opened a few documents, programs, etc. and had absolutely no problems.

What would this mean?
I originally though after it didn't work on the MBP that maybe it was indeed a problem with the internal hard drive and there were likely corrupted files or so that then got backed up onto this backup drive when I did the last backup a couple weeks ago. Yet it works fine on the other MBP.

I actually did the hardware test after I attempted the boot from the hard drive on the MBP so can try another boot later in case something just went wrong that time but since it boots fine on another MBP I tend to think the hard drive is not the issue. The good news is maybe I won't have to do a complete clean install of Snow Leopard and then all data, etc.

Could it be some type of hardware problem with the MBP? The hardware test found nothing but could it be a memory problem or would it have caught a memory problem or a hard drive problem? I had to have the Apple Store put a new logic board in this computer about 6 months ago. It was a video problem and the computer had no video at all. Would a more serious problem relating to the logic board or something on it cause a problem like this?

Once the hardware test is done I will try to boot again from this hard drive. I was ready to check into replacing through warranty the new hard drive I put in but I'm not sure if that is the problem now.
markw10 is offline   0 Reply With Quote
Old May 4, 2010, 01:42 PM   #5
markw10
Thread Starter
macrumors 6502
 
Join Date: Sep 2006
I tried a PRAM reset but unfortunately that didn't help so it seems like I'll be going by Apple.
I purchased the AppleCare for 2 additional years but it just expired in April. I had a logic board replaced in this MBP less than 6 months ago. Since this may be a problem with the logic board would Apple cover it or is all coverage over since the AppleCare expired? Unfortunately since I'm probably just a couple weeks past AppleCare being over I'm hoping there's some type of chance of coverage.
markw10 is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > OS X

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Running Snow Leopard, security risk? 2012Tony2012 OS X 13 Apr 21, 2014 08:56 PM
iMac was running Snow Leo; Genius put Mtn Lion; I NEED Snow Leopard back; have disk SophiaSapphire Mac Basics and Help 14 Oct 20, 2013 01:17 PM
For those still running Snow Leopard imanidiot Mac Applications and Mac App Store 24 Dec 8, 2012 09:02 PM

Forum Jump

All times are GMT -5. The time now is 10:24 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC