Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Special Interests > Visual Media > Digital Video

Reply
 
Thread Tools Search this Thread Display Modes
Old May 11, 2010, 01:43 PM   #1
vicki4
macrumors newbie
 
Join Date: Jan 2010
imovie not responding - please HELP!

I have spent 2 hrs searching for an answer, and trying various fixes, but nothing is working. Can someone please give me advice on what to do?

imovie was working fine til I was adding a 4th pip photo to one of my clips in my 9 min. project. Then, it just stopped responding. None of the features work - i.e. the clips can't be clicked on transitions accessed...none of the buttons in imovie work. Shutting down, updating software, did not help.

I have enough memory, the hard disk is showing 25% free. imovie will not allow me to delete rejected clips (error msg: "unable to delete rejected clips The operation could not be completed NSCFArray objectAtIndex:]: index (0) beyond bounds (0). That, of course, is completely greek to me.

I did delete a project, but that didn't help. It just freed up a bit more of the hard disk space.

I am in the middle of this project that I must finish! My macbook is 1 yr + 1 week old. Please, I would be sooo grateful for any kind offer of potential fixes.

I should say though, if you wouldn't mind sort of explaining any suggestions in layman's terms...I'm still learning the lingo and sometimes I have to do searches just to understand what a step of an instruction is.

THanks so so so much! I have a love/hate relationship w/ imovie (mostly hate right now) and the life of my laptop is in jeopardy (contemplating various destructive actions) until I get imovie going again.

Thank you!
Vicki
vicki4 is offline   0 Reply With Quote
Old May 11, 2010, 03:53 PM   #2
xStep
macrumors 68000
 
Join Date: Jan 2003
Location: Lost in Minneapolis
That error message is geek alright. iMovie thinks it should have some data but it can't find it where it thinks it has placed it. In this case, it looks like it lost the list to those rejected clips. Rejected clips would be part of an Event. I'm not sure that this is fixable.

The common suggestions will likely be; remove the iMovie preferences file, restore that Event from a backup if you have one from something like TimeMachine, use Disk Utility to fix 'Disk Permissions', boot up from the install DVD and use Disk Utility from there to do a 'Repair Disk'. Based on my thinking in the first paragraph, that last three would make the most sense. I think I'd try the last two suggestions first.

Can you create and edit a new project?
xStep is online now   0 Reply With Quote
Old May 11, 2010, 04:08 PM   #3
vicki4
Thread Starter
macrumors newbie
 
Join Date: Jan 2010
Yes, I can create a new project, AND (if I don't try to open the "problem project" first) I can even open and edit other existing projects. Once I try to open the problem project, nothing works from that point fwd.

I have done the DU repair. I have moved the plist to the trash (then put it on the desktop) but I don't know how to restore the event from a back up.

This project is only 8 min, but it has taken me several (probably like 5 or more) hours to make, since it's filled w/ about 100 photos, lots of short video clips, maps I've downloaded, pieces of youtube videos etc. waaaay time consuming. somewhere along the way, I did something (it happened when I was inserting a 4th photo inside a single clip as a picture-in-picture) it went into overload I guess and stopped functioning.

Thing is, in trying to fix it, I've somehow moved all my video out of imovie, so now NO video clips are playing - instead they show "source clip missing". I think this is prob bc I deleted video to make room on the disk thinking that would help. I can see the thumbnails of the clips in the project editing pane, but they won't play.

So, one problem made two. Great. Does this help you understand what the problem might be?
vicki4 is offline   0 Reply With Quote
Old May 12, 2010, 04:23 PM   #4
xStep
macrumors 68000
 
Join Date: Jan 2003
Location: Lost in Minneapolis
It all sounds pretty messed up. What ever the problem is, it sure messes with iMovie once triggered.

It also sounds like you went into an events folder to clear out some video. Check your Trash. If they are there, put them back.

Do you have a backup? If so, is it a TimeMachine backup or some other form? Do you have a backup that includes both the Events folder and project folder?

My thought is that restoring the project and appropriate event(s) to the last backup that was done before the date the issue occurred would bring you back to a stable state.

The geek message might be helpful here. Perhaps it can't find the rejected clips because they are not there. In this case, restoring only the affected events folder might resolve the issue.

Sadly, the other option is to start the project over.
xStep is online now   0 Reply With Quote
Old May 13, 2010, 01:29 AM   #5
vicki4
Thread Starter
macrumors newbie
 
Join Date: Jan 2010
How do I know if I have a back up? I would love it if there was one, but honestly, my computer is 1 yr old (+ 1 week) and if there is a back up, it exists without me intentionally making it. I found my project in the trash, it will not work in iMovie, when I try to add it. iMovie just isn't working right at all. If I start it up right after boot up, I can open other projects & edit them. Once I open the problem project though, the entire program hangs...except, and this is weird...when I "play" the project. It WILL play when I press the spacebar. BUT THE WHOLE TOP WINDOW (edit pane) is BLACK. If I scroll my mouse over the black area, the clips/photos show in the viewing window. My source videos are still missing.

Starting over isn't really an option either, bc iMovie is so finicky now, I wouldn't trust it w/ another minute of my time on a new project. I need to fix it. I may have to take it in to apple. Bummer. Waaay more time than I have...

If you know how I can check for a back up, please let me know! Thanks so much for your time!
vicki4 is offline   0 Reply With Quote
Old May 13, 2010, 12:32 PM   #6
videography101
macrumors newbie
 
Join Date: May 2010
can you "share" the project

since it plays, see if you can share it as a quicktime movie. If so , you can then use that .mov file in a new project and not have to redo everything
videography101 is offline   0 Reply With Quote
Old May 13, 2010, 05:09 PM   #7
xStep
macrumors 68000
 
Join Date: Jan 2003
Location: Lost in Minneapolis
Vicki4, it sounds to me like you don't have a backup. That is something you should know unless someone else set your system up and added an external drive. If you don't have an external drive, then a backup is more than unlikely.

What project did you find in the trash? Does the name end in '.rcproject'? You might be able to drag that into your 'Movies/iMovie Projects/' folder.

iMovie events are not as clear to see. On my system the folder icon looks like just any other folder icon. Inside of one though you'll see two folders named 'iMovie Cache' & 'iMovie Thumbnails' and a file called 'iMovie Data' and one or more .mov files. If you find one of these in your trash, you might be able to drag it back to your '/Movies/iMovie Events/' folder.

Your lack of trust of iMove is based on when you use that bad project. If not opening causes no problems, then avoiding that or deleting it should allow iMovie to operate properly.

The weirdness you described is far out.
xStep is online now   0 Reply With Quote
Old May 14, 2010, 12:27 AM   #8
vicki4
Thread Starter
macrumors newbie
 
Join Date: Jan 2010
I am in the process of exporting now (46 min remaining). I will report back tomorrow. BUT, I did get a warning that my video for this project is not avbl (that's because in my attempts to fix this, I have deleted my video from my iMovie Event Library...so when the part comes to play the video clips, it says, "source missing").

However, if I can just WORK with the project, then I can add those video clips back in. There were only about 10 or so. Much better than starting from scratch.

I had previously saved this "problem project" (it's new name) to a disk. Yet, when I inserted the disk, it will not play. When I insert other disks I've made of other iMovie projects, they do play. So...I am only so hopeful this quicktime .mov will work. Def worth a try.

I really do appreciate the help - so thanks very much. I've been waiting for the time to take it in to apple, so if this doesn't work, i may try this wkend.

p.s. all attempts at adding this prob. project to iMovie from anywhere it's stored on my system have been unsuccessful. If iMovie even THINKS I want to add it back in, it just digs it's feet in the ground and freezes. I think it has post traumatic stress disorder and any memory of the project causes psychotic behavior. I just wish I knew what I did to cause the trauma, so I don't do it again.
vicki4 is offline   0 Reply With Quote
Old May 14, 2010, 10:21 AM   #9
vicki4
Thread Starter
macrumors newbie
 
Join Date: Jan 2010
OK, I am giving up. I exported the problem project to Quicktime as a .mov then was able to play it in iMovie - but PLAY it only. Not edit it. The titles that were only on the photos for my son to read from in a voiceover are now embedded w/ not way to remove them.

I've deleted the project from iMovie and it's working fine now. SOMETHING in that project just shut the entire project down, rendering it useless and uneditable.

Because I have the project in an "event" now, I can see what I did and recreate every clip in the same order. I'm guessing it'll take about 2-4 hours to recreate it...but if I go in the apple store, I'm sure my total time will be at least that, since it's a 20 min drive each way anyway.

I've just recreated the first photo only - ken barnes effect, with a title and 4 pic-in-pics dragged in from iphoto, zooming in on the background photo at different times for 1.5 sec each. Took about 15 min for the one photo. And it's only 10 seconds of the 8 min...that's why I didn't want to start over.

BUT - can someone please tell me how to avoid this problem again? (not necessarily the problem that caused the project to crash - since I don't know if anyone knows that - but the problem of not being able to restore the project to where it was 15 min before it stopped working). I'm interested in this Time Machine thingy. I don't even know what an external drive is though. Is this something I can do on my own or do I need an expert for it...i.e. do I need tech support cuz the process is involved?

Maybe a link to instructions in very simple, detailed terms? Thanks again for all the help!
vicki4 is offline   0 Reply With Quote
Old May 14, 2010, 11:17 AM   #10
WayneH1
macrumors member
 
Join Date: Apr 2010
Quote:
Originally Posted by vicki4 View Post
BUT - can someone please tell me how to avoid this problem again? (not necessarily the problem that caused the project to crash - since I don't know if anyone knows that - but the problem of not being able to restore the project to where it was 15 min before it stopped working). I'm interested in this Time Machine thingy. I don't even know what an external drive is though. Is this something I can do on my own or do I need an expert for it...i.e. do I need tech support cuz the process is involved?

Maybe a link to instructions in very simple, detailed terms? Thanks again for all the help!
I doubt anyone will ever know any better than you just what went wrong here. Hopefully this painful lesson will lead you to consider a cheap external drive and learning how to use Time Machine to backup your Mac. You can get a 2 Tb drive for ~$120 these days. Totally worth it.

I don't know if this would have helped you, but I learned a trick when I had an iMovie project freeze up. (Any attempt to play it in iMovie would give an endless spinning beachball.) I was able to SEE the entire timeline I had edited. SO I was able to Select All, and copy and paste the timeline into a new, undamaged project. I lost the placement of added audio (songs in my case, voiceover in yours), but fixing that was small compared to all my video edits, transition timings, photo Ken Burns settings and on and on. Saving all that saved me hours of rework.
WayneH1 is offline   0 Reply With Quote
Old May 14, 2010, 12:24 PM   #11
vicki4
Thread Starter
macrumors newbie
 
Join Date: Jan 2010
Thanks Wayne, I'm not sure if that copying/pasting would have worked since I couldn't do much at all w/ my project (virtually every function in imovie wouldn't work w/ that project - except the spacebar=play). But, I am glad it worked for you, I feel like you beat the demon and even though it didn't help me, I still feel like it's a point for the human race!

About TM & external drive. My mac's a laptop & don't want to have to carry any other hardware around. Would TM still backup like every 15 min w/out any addt'l hardware to lug around? I'm on airplanes a lot w/ it & work on movies away from home frequently.

I have 25 seconds done!
vicki4 is offline   0 Reply With Quote
Old May 14, 2010, 01:58 PM   #12
WayneH1
macrumors member
 
Join Date: Apr 2010
Quote:
Originally Posted by vicki4 View Post
About TM & external drive. My mac's a laptop & don't want to have to carry any other hardware around. Would TM still backup like every 15 min w/out any addt'l hardware to lug around? I'm on airplanes a lot w/ it & work on movies away from home frequently.
I'm not sure TM will allow backing up to the same drive you're working on, because this is such a questionable procedure. One of the main reasons to back things up is to protect against drive failure, and obviously you wouldn't have that with this strategy. The second problem is that laptop hard drives are nearly always approaching full (mine always was) and backing up makes multiple replicates of every file you protect, eating up precious real estate.

But on the other hand and despite these negatives, backing up to your startup drive might have saved your project and spared you this nightmare. If TM doesn't allow this, there are other utilities that would.

One thing you should consider is just using TM and an external drive whenever you can, even if it's only once a month. Way better than nothing. And, you can offload a LOT of stuff from your laptop onto the external drive, apart from the TM space. This will help cure the chronic space shortage most laptop users get to.
WayneH1 is offline   0 Reply With Quote
Old Aug 14, 2010, 01:54 PM   #13
spytim
macrumors newbie
 
Join Date: Aug 2010
I just wanted to say that the same thing has happened to me.

I deleted a section of footage from the edit window and that was it. capoot!

when I open Imovie now i can open and edit any other project. if i try to open "problem project" everything freezes. annoyingly, if i hit spacebar it will play. the whole entire thing, plays no problem. I just cannot click on anything. the project window is totally frozen as is the event list and the event window.

very very very very very very VERY annoying. Someone must please be able to help



two days of work, gone!
spytim is offline   0 Reply With Quote

Reply
MacRumors Forums > Special Interests > Visual Media > Digital Video

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Apple TV not Responding! jhonhoang Apple TV and Home Theater 5 Dec 28, 2013 06:07 PM
Apple not responding me? kingapple iPhone 11 Dec 26, 2013 07:06 PM
Moved from iMovie HD to iMovie 8 and can't use a diskimage for storage barkmonster Mac Applications and Mac App Store 0 Jul 22, 2013 03:00 PM
Would moving imovie 11 to a computer that has imovie 9 work? jsm209 Mac Applications and Mac App Store 1 Jul 7, 2013 05:08 AM
IMovie isn't responding when opening catlin64 iMac 1 Dec 30, 2012 11:17 PM

Forum Jump

All times are GMT -5. The time now is 11:21 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC