Go Back   MacRumors Forums > Apple Systems and Services > OS X > Mac OS X Server, Xserve, and Networking

Reply
 
Thread Tools Search this Thread Display Modes
Old May 17, 2010, 01:30 AM   #1
PJohnson
macrumors member
 
Join Date: Jan 2008
AirPort - can wifi searching be turned off?

Is there any way to stop AirPort from constantly searching for wifi networks?

I connect to my home wifi and don't want it to keep searching for other networks. I suspect this behavior is what is causing my wifi to keep dropping intermittently. Yes, I am fighting the same problem as many others and have yet to find anyone who has solved it.

Thanks in advance.

Phil
PJohnson is offline   0 Reply With Quote
Old May 20, 2010, 09:10 PM   #2
satcomer
macrumors 601
 
satcomer's Avatar
 
Join Date: Feb 2008
Location: Upstate NYS
One trick to stop from Airport dropping connections is to open System Preferences->Network tab, 'Advanced' button, and uncheck the box to use IPv6 since your wireless router doesn't support IPv6.
__________________
Mac Pro Dual 2.8 Quad(Rev B.), 16 G RAM, OS X 10.9, 23'' LCD
Mac Book Pro Core 2 Duo 2.16Ghz, SuperDrive, 2G RAM, OS X 10.7.5
iPad 3, 32 black
satcomer is offline   0 Reply With Quote
Old May 21, 2010, 03:04 AM   #3
PJohnson
Thread Starter
macrumors member
 
Join Date: Jan 2008
I did turn off IPv6 as well as changing the wifi channel to avoid conflicting with nearby networks. It still drops out a lot, every few minutes most of the time. Once in a while, I get an hour or two of solid connection.

Any other ideas? I'll try most anything at this point.

Phil
PJohnson is offline   0 Reply With Quote
Old May 21, 2010, 04:47 PM   #4
satcomer
macrumors 601
 
satcomer's Avatar
 
Join Date: Feb 2008
Location: Upstate NYS
Well it does require you to reboot and trust in OS X. So follow these steps (in order):

1. Turn off the Airport in your Mac.

2. Navigate to /YourHardDrive/Library/Preferences/ (the Main Library, not your Home Library) and find the folder "SystemConfiguration". Then delete the files com.apple.airport.preferences.plist, com.apple.nat.plist & com.apple.network.identification.plist.

3. Immediately reboot (leaving the Airport card OFF!)

4. Upon the restart go to /Applications/Utilities/Keychain Access and find any saved passwords for you wireless network.

5. Go back to System Preferences->Network pane and at the top of the pane use the "Location" drop-down and create a new Location calling it what ever you like. Then hit the Apply button. This will get rid of that unstable "Automatic".

6. Turn on Airport card and rejoin your wireless network.

7. Pray this reset works.


Plus download the free application iStumbler 99 to make sure no other network is interfering with your network.
Good luck.
__________________
Mac Pro Dual 2.8 Quad(Rev B.), 16 G RAM, OS X 10.9, 23'' LCD
Mac Book Pro Core 2 Duo 2.16Ghz, SuperDrive, 2G RAM, OS X 10.7.5
iPad 3, 32 black
satcomer is offline   0 Reply With Quote
Old May 24, 2010, 01:23 AM   #5
PJohnson
Thread Starter
macrumors member
 
Join Date: Jan 2008
I tried the procedure above without success.

I have narrowed it down to one specific wireless network that is nearby. It's a weak signal, but enough that my Mac drops connection to my home wireless (which is 20 feet away) whenever it looks for other networks and 'sees' this one.

So, I'm back to square one...

How can I tell my Mac to ignore other networks or not search for other networks at all???

Phil
PJohnson is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > OS X > Mac OS X Server, Xserve, and Networking

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Airport Extreme as a WiFi Extender? CaptTCS Mac Peripherals 9 Sep 25, 2014 11:13 PM
Wifi turns off and can't be turned on except restart when press the bottom of macbook windows98wh MacBook Pro 0 Oct 29, 2013 07:13 AM
Airport / Wifi won't turn on btnoel MacBook Air 2 Sep 14, 2013 12:25 PM
Steaming from MacBook to apple tv over wifi, but dhcp has to be turned off. LeeM Apple TV and Home Theater 2 Aug 14, 2012 09:42 AM
Using Enthernet port while wifi is turned on Jigga Beef Mac Pro 6 Aug 3, 2012 04:35 AM

Forum Jump

All times are GMT -5. The time now is 11:36 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC