Go Back   MacRumors Forums > Special Interests > Visual Media > Web Design and Development

Reply
 
Thread Tools Search this Thread Display Modes
Old Jun 5, 2010, 10:16 AM   #1
Chriss316
macrumors newbie
 
Join Date: Aug 2009
#1045 Cannot log in to the MySQL server (Different than most cases)

Hey, im trying to get phpmyadmin set up and I have successfully setup phpmyadmin before (on different server for different site and on windows) and I have went through the same steps as I have before with only a few differences but this time when I try to log in I get #1045 Cannot log in to the MySQL server, and I have looked through tons of different forums for the past 4 days now trying all sorts of different techniques and nothing will work at all. My mysql login works 100% and the account have full privileges to everything, I have also started to use MySQL Workbench to help give me a bit more of a graphical aid to help pinpoint any problems but as far as i can see the is non, is there maybe somthing wrong with my config.inc.php? I also have the apache2 server running and I uploaded phpmyadmin onto the server but I still get the same error message, I then tried to redirect to my website from apache through the config.inc.php but still got the same message,

Im running PHP 5.3.2, phpmyadmin 3.3.3 and MySQL 5.1.47 is there maybe a conflict with these versions going on?

my config file is this

Code:
<?php

/* Servers configuration */
$i = 0;

/* Server: MySiteForums [1] */
$i++;
$cfg['Servers'][$i]['verbose'] = '';
$cfg['Servers'][$i]['host'] = 'localhost';
$cfg['Servers'][$i]['port'] = '3306';
$cfg['Servers'][$i]['socket'] = '';
$cfg['Servers'][$i]['ssl'] = true;
$cfg['Servers'][$i]['connect_type'] = 'tcp';
$cfg['Servers'][$i]['extension'] = 'mysqli';
$cfg['Servers'][$i]['auth_type'] = 'cookie';
$cfg['Servers'][$i]['user'] = '';
$cfg['Servers'][$i]['password'] = '';

/* End of servers configuration */

$cfg['blowfish_secret'] = '4c02d5e1af2b86.89214560';
$cfg['DefaultLang'] = 'en-utf-8';
$cfg['ServerDefault'] = 1;
$cfg['UploadDir'] = '';
$cfg['SaveDir'] = '';
?>
I had my username and password in to start with but was told that u dont need it when using cookies

I have also completely uninstalled and reinstalled MySql a number of times now, I feel like im just missing something very simple lol

Any help would be appreciated.

Last edited by Chriss316; Jun 5, 2010 at 11:00 AM.
Chriss316 is offline   0 Reply With Quote
Old Jun 5, 2010, 02:59 PM   #2
angelwatt
Moderator emeritus
 
angelwatt's Avatar
 
Join Date: Aug 2005
Location: USA
Seems to match my file for the most part. I have an auth type of config with user name and password supplied. For extension I have mysql. None of the settings you supplied look wrong. Have you tried the other auth type ad supplied a user name and password just to see if it works?

The only other thing that comes to mind to check on is to see what the file permissions are for the config file and others to see if they are what they need to be. I found this post about an issue with phpmyAdmin and password encryption type. The solution was to use the old_password function.
angelwatt is offline   0 Reply With Quote
Old Jun 5, 2010, 05:07 PM   #3
Chriss316
Thread Starter
macrumors newbie
 
Join Date: Aug 2009
Ok so I redownloaded the lastest version to get a copy of the sample inc file and used that as the base for inc file I think the problems may of been with the advanced settings

My config now looks like this
Code:
<?php
/* vim: set expandtab sw=4 ts=4 sts=4: */
/**
 * phpMyAdmin sample configuration, you can use it as base for
 * manual configuration. For easier setup you can use setup/
 *
 * All directives are explained in Documentation.html and on phpMyAdmin
 * wiki <http://wiki.phpmyadmin.net>.
 *
 * @version $Id$
 * @package phpMyAdmin
 */

/*
 * This is needed for cookie based authentication to encrypt password in
 * cookie
 */
$cfg['blowfish_secret'] = '4c02d5e1af2b86.89214560'; /* YOU MUST FILL IN THIS FOR COOKIE AUTH! */

/*
 * Servers configuration
 */
$i = 0;

/*
 * First server
 */
$i++;
/* Authentication type */
$cfg['Servers'][$i]['auth_type'] = 'cookie';
/* Server parameters */
$cfg['Servers'][$i]['host'] = 'localhost';
$cfg['Servers'][$i]['connect_type'] = 'tcp';
$cfg['Servers'][$i]['compress'] = false;
/* Select mysqli if your server has it */
$cfg['Servers'][$i]['extension'] = 'mysql';
$cfg['Servers'][$i]['AllowNoPassword'] = false;

/* rajk - for blobstreaming */
$cfg['Servers'][$i]['bs_garbage_threshold'] = 50;
$cfg['Servers'][$i]['bs_repository_threshold'] = '32M';
$cfg['Servers'][$i]['bs_temp_blob_timeout'] = 600;
$cfg['Servers'][$i]['bs_temp_log_threshold'] = '32M';

/* User for advanced features */
$cfg['Servers'][$i]['user'] = 'root';
$cfg['Servers'][$i]['password'] = 'MY_PASSWORD';
/* Advanced phpMyAdmin features */
$cfg['Servers'][$i]['pmadb'] = 'phpmyadmin';
$cfg['Servers'][$i]['bookmarktable'] = 'pma_bookmark';
$cfg['Servers'][$i]['relation'] = 'pma_relation';
$cfg['Servers'][$i]['table_info'] = 'pma_table_info';
$cfg['Servers'][$i]['table_coords'] = 'pma_table_coords';
$cfg['Servers'][$i]['pdf_pages'] = 'pma_pdf_pages';
$cfg['Servers'][$i]['column_info'] = 'pma_column_info';
$cfg['Servers'][$i]['history'] = 'pma_history';
$cfg['Servers'][$i]['tracking'] = 'pma_tracking';
$cfg['Servers'][$i]['designer_coords'] = 'pma_designer_coords';
/* Contrib / Swekey authentication */
$cfg['Servers'][$i]['auth_swekey_config'] = '/etc/swekey-pma.conf';

/*
 * End of servers configuration
 */

/*
 * Directories for saving/loading files from server
 */
$cfg['UploadDir'] = '';
$cfg['SaveDir'] = '';

?>
I now have no problems logging in through the sites folder using localhost on the test server but I still cant get logged in through my hosting server on my domain, must be disabled or lower version on the domain, but I'm for switching providers soon to another host who I know has up to date servers and should be able to get up and running properly with
Chriss316 is offline   0 Reply With Quote

Reply
MacRumors Forums > Special Interests > Visual Media > Web Design and Development

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Trying to set up a testing server & MySQL Problem mripah Web Design and Development 7 Jul 6, 2013 10:31 AM
Log Book Buddy released - log book app for learner drivers MythicFrost iPhone and iPod touch Apps 0 Mar 6, 2013 11:06 PM
App Store crashes when I log in or log out echo.park OS X 10.8 Mountain Lion 1 Aug 3, 2012 01:52 PM
MySQL Server Connection aceiswild Web Design and Development 6 Jun 30, 2012 02:14 PM

Forum Jump

All times are GMT -5. The time now is 03:09 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC