Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > iPhone, iPod and iPad > iPad

Reply
 
Thread Tools Search this Thread Display Modes
Old Jun 7, 2010, 07:37 AM   #1
Ollie Cromwell
macrumors member
 
Join Date: Oct 2006
Location: London
Send a message via MSN to Ollie Cromwell
Problem: iPad and getting a https connection through a proxy server.

I have a proxy server that I need to get through at work, my Mac has no trouble as in the network control panel I can specify a port for each specific type of traffic eg http, https etc. However I cant specify that level of detail in the network connections in my iPad as it only asks for the proxy server address and port once. is there any way to specify the proxy server for the https connection in the ipad OS?

It just means that loads of apps that use that port will not connect at the moment.

Cheers
__________________
MBP C2D 2.33/15""/2gb
Mac Pro Quad 2.66
"Outside of a dog, a book is a man's best friend. Inside of a dog, it is too dark to read." -- Groucho Marx

Last edited by Ollie Cromwell; Jun 7, 2010 at 08:40 AM.
Ollie Cromwell is offline   0 Reply With Quote
Old Jun 9, 2010, 05:40 AM   #2
imagespace
macrumors newbie
 
Join Date: Jun 2010
Similar problem

I am very puzzled by this though. My iPhone connects to the wireless network at work and is set up exactly the same, using the same proxy settings. The iPhone, however, does not show the same issues.

My iPad, whilst it will allow me access to the internet. If I try to login to any sites, I get a proxy (HTTPS) problem and can't log in. This also happens with apps that log into web sites when opened.

So why does the iPhone work OK, yet the iPad doesn't??

Puzzled!
imagespace is offline   0 Reply With Quote
Old Jun 14, 2010, 03:15 AM   #3
peranet
macrumors newbie
 
Join Date: Jun 2010
I have the same problem. If you find a solution please post it.

Thank you very much,
Oscar
peranet is offline   0 Reply With Quote
Old Jun 27, 2010, 09:45 PM   #4
duluxanon
macrumors newbie
 
Join Date: Jun 2010
Thumbs down

i was able to resolve this on my new ipad (just got this morning yay!).

Anyway enter your proxy port, then when finished tap on theyour ip address settings up above... then click the home button...

for some reason if you dont click off the port frame it doesnt save it... if you click on the ip address or dns or router info above it then leave the page it works fine...
duluxanon is offline   0 Reply With Quote
Old Sep 8, 2010, 02:35 PM   #5
jewelrywang
macrumors newbie
 
Join Date: Sep 2010
Unhappy still cannot fulfill HTTPS connection through wireless+proxy.

This doesn't work for me. I tried several valid proxy servers available in my office but all failed. The setting is definitely saved. I can navigate to any websites except those requiring HTTPS. And as mentioned above, some apps like youtube and twitter can't work neither.


Quote:
Originally Posted by duluxanon View Post
i was able to resolve this on my new ipad (just got this morning yay!).

Anyway enter your proxy port, then when finished tap on theyour ip address settings up above... then click the home button...

for some reason if you dont click off the port frame it doesnt save it... if you click on the ip address or dns or router info above it then leave the page it works fine...
jewelrywang is offline   0 Reply With Quote
Old Sep 9, 2010, 07:03 AM   #6
stix
macrumors member
 
Join Date: Aug 2010
Location: Helvetic Confederation
I had a very similar problem not being able to connect to an activesync server (which uses https over port 443 I think) for a mail account. Turned out not to be anything to do with the iPad, but a wrong setting on the router. Try using a different router if you can. In my case (Netgear WNDR3700) the default mac address settings were wrong. Worth a try....
stix is offline   0 Reply With Quote
Old Nov 5, 2010, 02:31 PM   #7
cashxx
macrumors member
 
Join Date: Sep 2010
Workaround found?

Anyone having this problem still?? Having the issue here! Wondering if anyone has found a workaround?
cashxx is offline   0 Reply With Quote
Old Nov 5, 2010, 03:42 PM   #8
tekchic
macrumors 6502a
 
tekchic's Avatar
 
Join Date: Apr 2010
Location: Phoenix, AZ
Send a message via AIM to tekchic
It has to do with the iPad's iOS version. 3.2.2 iPad OS doesn't support HTTPS, which is why if you have an iPhone on 4.0+, you can access it but not on iPad.

The 4.2 OS that is forthcoming is supposed to have HTTPS support. Let's hope so.
__________________
tekchic
2013 15" MBPr i7 512SSD/16gb, iPad Air T-Mobile (64gb), Samsung Galaxy S3, Nexus 7, Surface Pro
tekchic is offline   0 Reply With Quote
Old Nov 24, 2010, 11:15 AM   #9
mikeerhymes
macrumors newbie
 
Join Date: Nov 2010
has anyone got any further with this yet?
i have just put on the IOS4.2 and still no https proxy setting!!!

any fresh ideas????

Last edited by mikeerhymes; Nov 24, 2010 at 11:22 AM. Reason: to email me for replies
mikeerhymes is offline   0 Reply With Quote
Old Nov 7, 2012, 12:21 AM   #10
ASRCH
macrumors newbie
 
Join Date: Nov 2012
problem

i have problem with protocol https in IPad .
ASRCH is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iPad

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
iCloud Documents doesn't use secure (https) connection? The Man iCloud and Apple Services 1 Mar 20, 2013 01:14 AM
Problem with proxy server pm4698 MacBook Pro 0 Feb 18, 2013 12:18 PM
How to configure Mac as a proxy server (not to use a proxy server!) unfrostedpoptar Mac OS X Server, Xserve, and Networking 3 Aug 9, 2012 09:44 AM
Bug? Facebook no longer shows https connection? LightningRod OS X 10.8 Mountain Lion 0 Jun 25, 2012 03:30 PM

Forum Jump

All times are GMT -5. The time now is 04:50 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC