Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Systems and Services > OS X > Mac OS X Server, Xserve, and Networking

Reply
 
Thread Tools Search this Thread Display Modes
Old Jun 12, 2010, 07:53 PM   #1
kase1025
macrumors member
 
Join Date: Aug 2009
IP Configuration in use by...

Our network has been working fine up until now. We have an xserve, a switch off of an xserve that shoots out the internet to all of our ethernet ports in the school. After a couple weeks (school got out and went on vaca) I came back and logged on to a couple of the computers in the computer lab and got this message on each computer. IP Configuration: XXX.XXX.X.XX in use by XX:XX:XX:XX:XX:XX, DHCP Server XXX.XXX.X.X. Of course the IP's were different on each computer I tried. THis message has never popped up before. Our printers are also being very strange, and I am guessing it has to do with this same thing, since our printers are wired via ethernet also.

Can anyone give me some ideas on this? Thanks so much. I greatly need the help and very much appreciate anything.
kase1025 is offline   0 Reply With Quote
Old Jun 13, 2010, 09:22 AM   #2
decksnap
macrumors 68030
 
decksnap's Avatar
 
Join Date: Apr 2003
I'd be interested to hear any ideas on this as well. Our Xserve does similar.
__________________
My cat's breath smells like catfood.
decksnap is offline   0 Reply With Quote
Old Jun 13, 2010, 09:59 AM   #3
jerry333
macrumors member
 
Join Date: Nov 2005
The first thing to do is see what your system thinks is out there. This is done with the arp command (ip and MAC addressess are fudged):


# arp -a
gateway.xxxx.com (131.31.13.1) at 0:90:1a:a1:5b:93 on en0 ifscope [ethernet]
? ((131.31.13.255) at ff:ff:ff:ff:ff:ff on en0 ifscope [ethernet]
? (192.168.1.2) at 90:84:d:d3:e2:cf on en1 ifscope [ethernet]
nekokun.internalnetwork.com (192.168.1.113) at 0:1f:f3:d4:ac:43 on en1 ifscope [ethernet]
? (192.168.1.255) at ff:ff:ff:ff:ff:ff on en1 ifscope [ethernet]

Then check this list for a duplicate of your host (I don't have one but you do. To find out what the addresses your host uses, use the ifconfig command:

# ifconfig -a
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
inet6 ::1 prefixlen 128
inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1
inet 127.0.0.1 netmask 0xff000000
gif0: flags=8010<POINTOPOINT,MULTICAST> mtu 1280
stf0: flags=0<> mtu 1280
en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
ether 00:19:e3:f9:34:c9
inet 131.31.13.66 netmask 0xffffff00 broadcast 131.31.13.255
inet 131.31.13.68 netmask 0xffffff00 broadcast 131.31.13.255
inet 131.31.13.67 netmask 0xffffff00 broadcast 131.31.13.255
inet 131.31.13.72 netmask 0xffffff00 broadcast 131.31.13.255
inet 131.31.13.75 netmask 0xffffff00 broadcast 131.31.13.255
inet 131.31.13.69 netmask 0xffffff00 broadcast 131.31.13.255
media: autoselect (1000baseT <full-duplex,flow-control>)
status: active
en1: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
ether 00:19:e3:ba:ab:bc
inet6 fe80::219:feef:abc1:5ba3%en1 prefixlen 64 scopeid 0x5
inet 192.168.1.1 netmask 0xffffff00 broadcast 192.168.1.255
media: autoselect (1000baseT <full-duplex,flow-control>)
status: active
en2: flags=8823<UP,BROADCAST,SMART,SIMPLEX,MULTICAST> mtu 1500
ether 00:19:e3:ab:cd:ef
media: <unknown subtype> (<unknown type>)
status: inactive
fw0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 4078
lladdr 00:1b:63:ff:cd:dc:ab:12
media: autoselect <full-duplex>
status: inactive

If it's just a bad arp table, you can delete the entry with arp -d. (see the man page for arp for more details).
jerry333 is offline   0 Reply With Quote
Old Jun 13, 2010, 02:28 PM   #4
kase1025
Thread Starter
macrumors member
 
Join Date: Aug 2009
are these commands I run in terminal on the server? I majored in IT but this sounds slightly foreign to me.
kase1025 is offline   0 Reply With Quote
Old Jun 13, 2010, 03:40 PM   #5
jerry333
macrumors member
 
Join Date: Nov 2005
Yes, you run them from the terminal. They are standard Unix commands. I don't know of any flavour of Unix that doesn't have them (though the arguments may be different so you have to check the man page if you are on a Unix system you're not familiar with). The arp command needs to be run as root.
jerry333 is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > OS X > Mac OS X Server, Xserve, and Networking

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Which configuration between the two? theBigD23 Mac Pro 2 Jan 13, 2014 12:10 PM
What configuration you go for and why? wwe2008 MacBook Pro 4 Oct 22, 2013 05:39 PM
IP Configuration Jmanp17 Mac Basics and Help 3 Dec 28, 2012 06:17 PM
Which configuration for MM Jiskefet Mac mini 4 Nov 17, 2012 01:28 PM
Do you know which configuration you are getting? PDFierro iPad 3 Oct 24, 2012 09:06 PM

Forum Jump

All times are GMT -5. The time now is 05:03 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC