Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > iPhone, iPod and iPad > iPhone > iPhone Tips, Help and Troubleshooting

Reply
 
Thread Tools Search this Thread Display Modes
Old Jun 22, 2010, 07:51 AM   #1
ABigGatorsFan
macrumors newbie
 
Join Date: Aug 2009
iPod app not working after update to 4.0 on iPhone 3G s?

Since updating to OS 4.0 on my 3G s last night, my ipod app no longer works. Everytime I go to open the ipod app it stays open for a second and then shuts down. I am not able to get anything to play either through the standard ipod controls or the multitasking control panel. I'm sure there will be an update soon to correct this, i just wanted to see if anyone else was having the same problem.
ABigGatorsFan is offline   0 Reply With Quote
Old Jun 22, 2010, 08:15 AM   #2
iPegboy
macrumors regular
 
Join Date: Jan 2003
Location: Detroit
I'm experiencing the same exact issue.
__________________
"Rules are meant for smart people to break." Dr. Dennis Renner
iPegboy is offline   0 Reply With Quote
Old Jun 22, 2010, 09:02 AM   #3
elb
macrumors newbie
 
Join Date: Jun 2010
ipod app not working after upgrading to OS 4.0

Hi folks,

The same issue here with my IPhone 3GS. Waiting to see any patch soon.

Eduardo Bastos
elb is offline   0 Reply With Quote
Old Jun 22, 2010, 09:54 AM   #4
jzarley
macrumors newbie
 
Join Date: Jun 2010
Same issue as well...the iPod app opens, displays for a few seconds, then closes. I tried rebooting a few times, but I continue to have the issue. (Good thing I have my iPad to use for music at work today )
jzarley is offline   0 Reply With Quote
Old Jun 22, 2010, 10:07 AM   #5
iPegboy
macrumors regular
 
Join Date: Jan 2003
Location: Detroit
I'm considering doing a fresh install of 4.0. Anyone try this yet?
__________________
"Rules are meant for smart people to break." Dr. Dennis Renner
iPegboy is offline   0 Reply With Quote
Old Jun 22, 2010, 10:56 AM   #6
pdpmojo
macrumors newbie
 
Join Date: Jul 2009
I have the same problem. I believe it has something to do with iTunes. I have 2 3Gs' and one of them I downloaded a podcast. The one that I downloaded the podcast, causes the iPod app to crash. The one that was just updated to 4.0 works perfectly fine. Can any of you confirm that you downloaded something off the iTunes app and that caused it to break?
pdpmojo is offline   0 Reply With Quote
Old Jun 22, 2010, 10:57 AM   #7
pdpmojo
macrumors newbie
 
Join Date: Jul 2009
Ironic that we finally get to background the Pandora App and now the iPod app goes.
pdpmojo is offline   0 Reply With Quote
Old Jun 22, 2010, 10:59 AM   #8
Trent0341
macrumors regular
 
Join Date: Jun 2007
I downloaded a song from iTunes and am now having the same issue. Any known fixes out there?
__________________
blah blah blah... lots o' Apple stuff
Trent0341 is offline   0 Reply With Quote
Old Jun 22, 2010, 11:10 AM   #9
jvance
macrumors newbie
 
Join Date: Jan 2008
Experienced the same thing with my 3g. Reinstalling fixed it.
jvance is offline   0 Reply With Quote
Old Jun 22, 2010, 11:13 AM   #10
jzarley
macrumors newbie
 
Join Date: Jun 2010
I downloaded a song from iTunes this morning (via the iPhone) immediately before attempting to use the iPod app. Unfortunately, I don't know if the iPod worked before that and the download broke it, or if it happened immediately as a result of iOS 4 upgrade.

However, I personally know of three other people who've done the iOS upgrade on their 3GS's and are NOT having the iPod issue...so, there must be some sort of combination of factors that is causing it.
jzarley is offline   0 Reply With Quote
Old Jun 22, 2010, 12:01 PM   #11
iPegboy
macrumors regular
 
Join Date: Jan 2003
Location: Detroit
Quote:
Originally Posted by pdpmojo View Post
I have the same problem. I believe it has something to do with iTunes. I have 2 3Gs' and one of them I downloaded a podcast. The one that I downloaded the podcast, causes the iPod app to crash. The one that was just updated to 4.0 works perfectly fine. Can any of you confirm that you downloaded something off the iTunes app and that caused it to break?
I never opened the iPod app before downloading a podcast, so I can't be sure one worked without the other -- but yes, I downloaded a podcast, and now the iPod won't stay open for more than a brief moment.
__________________
"Rules are meant for smart people to break." Dr. Dennis Renner
iPegboy is offline   0 Reply With Quote
Old Jun 22, 2010, 12:57 PM   #12
iPegboy
macrumors regular
 
Join Date: Jan 2003
Location: Detroit
Just read on the Apple support discussion boards that a re-syncing of the phone will do the trick to cure this. I'm away from my home computer to do that, but that's the word. So give that a try, for those experiencing the problem.
__________________
"Rules are meant for smart people to break." Dr. Dennis Renner
iPegboy is offline   0 Reply With Quote
Old Jun 22, 2010, 02:51 PM   #13
Ding.Dong
macrumors regular
 
Join Date: Jun 2008
Location: Los Angeles
I had this exact same problem. After upgrading the OS, my iPod app showed that I had no podcasts even though I had several before upgrading. I downloaded a couple through the iPhone, then the iPod would crash immediately whenever I opened it. I rebooted and resynched a couple of times without any change.

I finally got it to work by downloading a new podcast through iTunes on my desktop and then resynching. I noticed during the synch that it was now transferring podcasts to the iPhone. After the synch, the iPod app worked fine.
Ding.Dong is offline   0 Reply With Quote
Old Jun 22, 2010, 07:28 PM   #14
iPegboy
macrumors regular
 
Join Date: Jan 2003
Location: Detroit
Going through the sync process again fixed the problem for me.
__________________
"Rules are meant for smart people to break." Dr. Dennis Renner
iPegboy is offline   0 Reply With Quote
Old Jul 23, 2010, 09:05 AM   #15
KeithfromJax
macrumors newbie
 
Join Date: Jul 2010
I had the same issue

The iPod worked after the upgrade until I downloaded a couple of songs yesterday directly. I hope re-syncing works!
KeithfromJax is offline   0 Reply With Quote
Old Aug 1, 2010, 08:43 PM   #16
samandjordan
macrumors newbie
 
Join Date: Aug 2010
Quote:
Originally Posted by KeithfromJax View Post
The iPod worked after the upgrade until I downloaded a couple of songs yesterday directly. I hope re-syncing works!
Sync-ing worked for me
samandjordan is offline   0 Reply With Quote
Old Oct 15, 2011, 09:08 PM   #17
SD.37
macrumors newbie
 
Join Date: Oct 2011
My music shows up, but doesn't always play. Or it shows a different song title / album artwork than what is playing.

I have shut the phone down, and tried syncing it again. Neither of these things worked
SD.37 is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iPhone > iPhone Tips, Help and Troubleshooting

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Vevo Working on Apple TV App for 24/7 Music Video Channel [Update: Coming This Month] MacRumors MacRumors.com News Discussion 39 Aug 12, 2013 06:47 AM
App Store update not working kmoreau48 iOS 6 2 Nov 20, 2012 12:24 AM
iPhone: App not Working after update ryguy2303 Jailbreaks and iOS Hacks 3 Jul 24, 2012 04:02 PM
Apple Working on Fix for Corrupted App Store Downloads [Update: Fixed] MacRumors MacRumors.com News Discussion 66 Jul 14, 2012 03:23 PM
iphone app update warning sign keeps coming back after update petri71 iPhone Tips, Help and Troubleshooting 0 Jul 10, 2012 07:50 PM

Forum Jump

All times are GMT -5. The time now is 09:25 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC