Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Systems and Services > Programming > iPhone/iPad Programming

Reply
 
Thread Tools Search this Thread Display Modes
Old Jul 5, 2010, 02:44 PM   #1
LastLine
macrumors 65816
 
Join Date: Aug 2005
Network Code runs as expected in Simulator but not on Device...any help?

http://cocoa-nut.de/?p=27

Hey everyone, I've been exploring this code with a view to helping me understand the basics of Networking between iPhone and Mac and I've had some fun playing around with it doing silly little things, there is a minor problem though.

If I run it on the simulator it works perfectly allowing syncronisation of the data between simulator and the Mac client.

If I run it on my device (iOS 4.0 if that makes any difference) it won't sync the text to the textfield on the phone, no errors, nothing.

Anyone able to suggest to me what it is I might be missing here as I can't help but feel it's something fairly obvious and that it belongs in the networking code. The Mac client identifies the iPhone and shows up the appropriate name but just doesn't seem to be 'syncing' (I say 'syncing' as it isn't exactly a syncing app per se so much as transferring data.


So anyone able to help me out with this? there don't seem to be many real simple tutorials so I'm trying to learn through reverse engineering

Last edited by LastLine; Jul 6, 2010 at 10:45 AM.
LastLine is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > Programming > iPhone/iPad Programming

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
thread Thread Starter Forum Replies Last Post
Calander and contacts in cloud but not on device Bigfootworld iCloud and Apple Services 0 Nov 15, 2011 04:35 PM
Animation works on Simulator, but not on Ipod JGoose iPhone/iPad Programming 11 Apr 13, 2010 07:18 PM
Works on simulator but not on device dipaliP iPhone/iPad Programming 1 Nov 25, 2008 12:58 AM
Api compiled in simulator but not in iphone device sgauravv iPhone/iPad Programming 3 Aug 20, 2008 06:27 PM
Can't tap upper 20 pixel in simulator, but can on device ghollins iPhone/iPad Programming 2 Aug 5, 2008 03:23 PM


All times are GMT -5. The time now is 11:41 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC