Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Systems and Services > Programming > iPhone/iPad Programming

Reply
 
Thread Tools Search this Thread Display Modes
Old Aug 12, 2010, 01:19 PM   #1
Danneman101
macrumors 6502
 
Join Date: Aug 2008
webbrowser in split-view (ipad) not scrolling properly

Ive got a uiwebview in the detailview of a split-view ipad app, which loads a local html-file.

Problem is, the darn thing wont scroll the html-file properly. It's like there was a rubberband attached to the top, actively pulling the page up again when reaching the bottom.

This is the header of my html-files:

Code:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
<html>
<head>
    <title>GALLERY</title>
    <meta http-equiv="content-type" content="text/html; charset=utf-8">
	<meta name="viewport" content="width=device-width, minimum-scale=0.1, maximum-scale=1.6">
    <meta name="apple-mobile-web-app-capable" content="YES">
    <link rel="stylesheet" href="main.css">
</head>
<body>

.. do stuff

</body>
</html>
Pretty standard, and works fine on iphone with the exception that "minimum-scale=0.1" is then set to "1.0".

My current solution is to add a lot of "<br/>" to the end of each html-file, but that's just ugly.

Any ideas?
Danneman101 is offline   0 Reply With Quote
Old Aug 13, 2010, 05:44 AM   #2
Danneman101
Thread Starter
macrumors 6502
 
Join Date: Aug 2008
Weird, Ive been googling my ass off for a solution, but I havent even found one single report of the same issue by a developer.

Perhaps I should submit a bug-report?
Danneman101 is offline   0 Reply With Quote
Old Aug 13, 2010, 01:34 PM   #3
seepel
macrumors 6502
 
Join Date: Dec 2009
I've been putting web views in my detail views just fine. Are you sure that your setting the web view itself correctly? Maybe it is getting a strange frame, or its scroll view is wonky?
__________________
Free iOS App that turns your music library into an info graphic.
Phonographic
seepel is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > Programming > iPhone/iPad Programming

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
thread Thread Starter Forum Replies Last Post
iCloud Mail not Syncing Properly renewed iCloud and Apple Services 2 Oct 13, 2011 10:54 AM
Images will not open in Mail (iPad) MajorTCS iPad 0 Apr 20, 2010 11:22 AM
UITableView not scrolling properly with keyboard, but inconsistent behaviour radebe iPhone/iPad Programming 0 Jan 13, 2010 04:51 AM
unstable webbrowsers in leopard aneftp MacBook 9 Mar 9, 2008 08:21 PM
Parental Control in German does not work properly NEED HELP! drafb OS X 3 Dec 22, 2007 10:04 AM


All times are GMT -5. The time now is 10:06 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC