10.3.9 - Massively long Finder load times

Discussion in 'macOS' started by Xenesis, Sep 23, 2006.

  1. Xenesis macrumors regular

    Xenesis

    Joined:
    Sep 3, 2006
    Location:
    Australia
    #1
    Hey, sometimes on my iMac G3 running 10.3.9, the finder takes an absolutely abhorrent amount of time to load. Every now and again when I go to log in, it can take up to half an hour before the finder actually loads. Now, this wouldn't be too bad, apart from the fact that no network services seem to work properly until it loads. :S

    On the other hand, a lot of the time it just loads fine, within about a minute.

    Any ideas?
     
  2. GimmeSlack12 macrumors 603

    GimmeSlack12

    Joined:
    Apr 29, 2005
    Location:
    San Francisco
    #2
    Repair the hard drive maybe? Or at least verify that it is ok.
     
  3. Blue Velvet Moderator emeritus

    Joined:
    Jul 4, 2004
    #3
    Sounds just like the problems my friend had before her hard-drive stopped working... if I were you, I'd back up your data now or asap and run disk utility's verify routines over the disk before going much further.
     
  4. Xenesis thread starter macrumors regular

    Xenesis

    Joined:
    Sep 3, 2006
    Location:
    Australia
    #4
    Hmm...well, I'm not that sure. The iMac has been doing this for a good year or so. I might as well run disk verification though...need to find some OSX discs again to boot off.
     
  5. HughJ macrumors regular

    Joined:
    Feb 21, 2006
    Location:
    Norwich UK
    #5
    if you have hundreds (or thousands) of fonts on your system that can increase the boot up time massively
     
  6. beatsme macrumors 65816

    beatsme

    Joined:
    Oct 6, 2005
    #6
    yea I'd have to give this suggestion a vigorous second. Back up your data ASAP.
     

Share This Page