10.4.2 weird performance with iBook G4

Discussion in 'macOS' started by leekohler, Jul 19, 2005.

  1. leekohler macrumors G5

    leekohler

    Joined:
    Dec 22, 2004
    Location:
    Chicago, Illinois
    #1
    OK- I have now done a clean install of Tiger on my 1GHz iBook G4 with 640 Mb RAM. It's great except when I'm on battery power. I had it on better performance while it was plugged in today at work and it flew. As soon as I started using it on the bus, I noticed the performance was not so good. I checked energy saver and it had gone back to the automatic setting. So I switched it to better performance and it was still slow. I plugged it in when I got home and it was fine again. What gives? Anybody else have this problem?
     
  2. leekohler thread starter macrumors G5

    leekohler

    Joined:
    Dec 22, 2004
    Location:
    Chicago, Illinois
  3. dmw007 macrumors G4

    dmw007

    Joined:
    May 26, 2005
    Location:
    Working for MI-6
    #3
    Well, maybe...Do you (in Energy Saver) have the hard drive selected to "sleep" whenever possible? This might be a possible performance slower (although this should be the same regardless if your 'Book is plugged in or not - don't have a 'Book so not 100% sure).
     
  4. leekohler thread starter macrumors G5

    leekohler

    Joined:
    Dec 22, 2004
    Location:
    Chicago, Illinois
    #4
    I'll try that. I think it's set that way by default.
     
  5. leekohler thread starter macrumors G5

    leekohler

    Joined:
    Dec 22, 2004
    Location:
    Chicago, Illinois
    #5
    Nope. Thanks, but it's still doing the same thing. Anybody else?
     
  6. dmw007 macrumors G4

    dmw007

    Joined:
    May 26, 2005
    Location:
    Working for MI-6
    #6
    Sorry leekohler (guess it was worth a shot :rolleyes: ). I might have to think about this one overnight.

    Someone far smarter than little ol' me please save leekohler from his woes.
     
  7. leekohler thread starter macrumors G5

    leekohler

    Joined:
    Dec 22, 2004
    Location:
    Chicago, Illinois
    #7
    Thanks man! :) I have to go to bed, but if anybody can help, I'd appreciate it. I use my iBook mainly on the go, so this is important to me.
     
  8. dmw007 macrumors G4

    dmw007

    Joined:
    May 26, 2005
    Location:
    Working for MI-6
    #8
    Same here leekohler (I have work tomorrow). Sleep easy, tomorrow will no doubt offer you a solution to your "performance crisis."
     
  9. Jedi128 macrumors 6502

    Joined:
    Jul 7, 2005
    Location:
    New York, NY
    #9
    I have a G4 iBook and almost always use it on the go(without it being plugged in). I have never had this happen to me.... Thats extremely weird that its changes when its plugged in. Maybe look at the energy saver settings with it unplugged and then plug it in to see if anything changes. Thats all I can think of right now.....
     
  10. leekohler thread starter macrumors G5

    leekohler

    Joined:
    Dec 22, 2004
    Location:
    Chicago, Illinois
    #10
    As I stated in my original post, it did change to automatic and when I switched it back to better performance things stayed the same.
     
  11. leekohler thread starter macrumors G5

    leekohler

    Joined:
    Dec 22, 2004
    Location:
    Chicago, Illinois
    #11
    OK guys- I tried this: I opened energy saver and made sure it was on better performance. Then, with energy saver still open, I unplugged the computer. Guess what? Looks like Tiger has different definitions of what better performance is between battery power and the adapter power. The settings switched right in front of me and it looks like you can't change that. It even dims the screen a bit. Help! How do I make this stop?
     
  12. killmoms macrumors 68040

    killmoms

    Joined:
    Jun 23, 2003
    Location:
    Washington, DC
    #12
    Just change the settings for each. Go in and set processor performance to "highest" on the battery power preset if you want. Don't see why this is so confusing. :confused:
     
  13. leekohler thread starter macrumors G5

    leekohler

    Joined:
    Dec 22, 2004
    Location:
    Chicago, Illinois
    #13
    Because that's EXACTLY what I did and have been doing! That's why this is so confusing. It's on better performace for BOTH and it's still performing differently. Have I not explained this already? Let's be more clear- under power adapter it's set for better performance, under battery power it's set for better performance. Now, when I unplug the computer, the screen gets dimmer and the performance gets poorer, BUT it's still set on better performance. Sorry, but I'm really frustrated.
     
  14. psycho bob macrumors 6502a

    psycho bob

    Joined:
    Oct 25, 2003
    Location:
    Leeds, England
    #14
    Well if the behaviour is different since you installed 10.4.2 and the machine is working fine in general then it is a software issue. Try reinstalling the .2 update using the combo updater, run permissions and if necessary startup from the original iBook recovery disk or your Tiger DVD and run permissions and also check the HD while your at it.

    When on battery open up Activity Monitor and see if anything is hogging the CPU. When on battery even if the CPU is set to highest performace it is my understading components like the graphics card still run in a reduced state. I say this because the Core Image and Quartz performance differs greatly on battery regardless of the CPU energy saver setting. I assume things like the system controller and HD also have battery operation modes to save power.

    You can try trashing the energy saver plist HD>library>preferences>

    The screen goes dim because there is a setting under battery power to automatically dim the screen, you can uncheck this.
     
  15. After G macrumors 68000

    After G

    Joined:
    Aug 27, 2003
    Location:
    California
    #15
    The dimming thing is a result of Apple trying to save your battery. This is a minor inconvenience and can be resolved by just changing the brightness on your display back to how you want it with the controls on the keyboard. Or as the above poster said, check the system preferences.

    The performance issues though ... this is an interesting one, something I haven't experienced, but maybe I am just used to it? I will try it myself and see what happens. Maybe with Xbench or something.
     
  16. leekohler thread starter macrumors G5

    leekohler

    Joined:
    Dec 22, 2004
    Location:
    Chicago, Illinois
    #16
    I'll try all these. This was an alarming difference after upgrading from Panther. And these are the answers I was looking for. I'll try them out and let you know.
     
  17. hob macrumors 68020

    hob

    Joined:
    Oct 4, 2003
    Location:
    London, UK
    #17
    Hold on - you said you had it set for one processor setting when you were plugged in. Then it was somehow different when you were on the bus.

    The reason would surely be, that there is one setting for when you're plugged in, and one for when you're running off battery power.

    For example, if you're using your iBook plugged in, and you set it to one energy profile, that will be what is set for your "plugged in" settings. Your battery settings are different.

    You can change either setting in either mode, thusly:
     

    Attached Files:

  18. psycho bob macrumors 6502a

    psycho bob

    Joined:
    Oct 25, 2003
    Location:
    Leeds, England
    #18
    I think he means that the performance differs even when the settings are the same under both power mode options. As he seems to have only experienced this under 10.4.2 it would seem to be an issue related to the update whether it be .2 itself or the installer.
     
  19. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #19
    The screen dimness option is under the options pane for battery only, and is called "Reduce the brightness of the built-in...."

    Eeeeep, as far as the speed issue goes, I think I might know what your issue is. You set both to "Better performance," right? Yes, you're right -- that *IS* different for battery and wall power usage.

    If you want the processor performance to stay up on both wall power and battery power, you need to change the processor performance on the battery profile to be Highest (this will change the battery profile from Better to Custom). The processor performance is at the bottom of the options screen. I think this is due to a difference in the way the profiles are defined -- if you look at the Better Performance profile, it uses the Automatic, not the Highest, CPU setting, which changes depending on the ability of power (Highest does not).

    I'm getting confused by this thread for some reason....maybe I'm in caffeine overdose. So I hope I'm not saying something très stupide.... :(
     
  20. leekohler thread starter macrumors G5

    leekohler

    Joined:
    Dec 22, 2004
    Location:
    Chicago, Illinois
    #20
    You just nailed it! It was different in Panther, I just finally found that setting in Tiger. What a pain! Why did Apple think it was necessary to make this even more complicated? Anyway, I did reinstall 10.4.2 and it helped a lot in addition to correcting these settings. I think I'm OK now. Thanks everybody! :)
     

Share This Page