10.4.4 Won't Mount Disk Images

Discussion in 'macOS' started by gingi0, Jan 11, 2006.

  1. gingi0 macrumors newbie

    Oct 3, 2004
    I installed 10.4.4 on my PowerBook last night and now I cannot mount disk images. I tried double-clicking .dmg files, opening them from within Disk Utility, and running the hdiutil command. Some error output I'm getting from various attempts:

    load_hdi: timed out waiting for driver to load

    diskimages-helper[349] ERROR: unable to load disk image driver - 0xE00002C0/-536870208 - Device not configured.

    I've run Repair Permissions and Repair Disk (from OS X install CD). But nothing. Searching for these kinds of errors only returns problems related to 10.3.1 which are resolved in 10.3.2.

    Oh, yeah, and the PowerBook does not recognize my internal speakers.

    Any help?

  2. gingi0 thread starter macrumors newbie

    Oct 3, 2004

    It seems I have been having a far more extensive problem, and it's not unique to 10.4.4. Apparently, many of the kernel extensions have failed to update. I rebooted in verbose mode and got a plethora of error messages about inconsistencies between kernel extension versions and failures to load or link even basic extensions. I was able, in single-user mode, to attach the Update disk image and extract the package. Then I reinstalled 10.4.4 and everything is back to normal.

    Perhaps Apple needs to do include some post-installation QC to verify that things have been installed correctly.

Share This Page