10.4 Audio Balance Bug

Discussion in 'macOS' started by PlaceofDis, Jan 28, 2006.

  1. PlaceofDis macrumors Core

    Jan 6, 2004
    okay since i upgraded to Tiger, and i have applied all the point upgrades, the audio balance will shift from its normal setting. none of the point upgrades have had any effect on this. its getting annoying having to go into System prefs every now and then to adjust it.

    anyone know what causes this? is it shifting the volume (as i suspect?) and does anyone eles experience this? and has anyone found a solution as of yet?
  2. dolphin842 macrumors 65816


    Jul 14, 2004
    I've had this happen in Tiger at least once, and know of at least one other person who has had it happen to them. For the longest time I just thought the right side of my headphones were broken :rolleyes:

    Which way did it shift for you? It went to the left channel for me (not all the way, though). How often does it happen? Now that I see more folks with the problem, I'm wondering what's causing it (my guess is either a really assertive app or some prefs or settings getting corrupted one way or the other).
  3. stridey macrumors 65816


    Jan 21, 2005
    Massachusetts, Connecticut
    Yeah, lots and lots of people get this. The nearest I can make out, it's somewhat linked to changing the volume rapidly (maybe switching directions too quickly?)

    As a side note, it's not just a 10.4 bug, it's been around since Panther. :)
  4. dolphin842 macrumors 65816


    Jul 14, 2004
    Through a similar thread on another site, I found someone post a link to an app that takes care of the problem (I haven't tested it myself). Apparently it is related to rapidly switching volume using the keyboard instead of the mouse.

    Hmm... if it's been around since Panther you'd think it'd be resolved by now. I guess it's just one of those random bugs...
  5. mduser63 macrumors 68040


    Nov 9, 2004
    Salt Lake City, UT
    Definitely related to changing the volume. I've had this problem occasionally. Based on reading this thread, I just opened up Sound Preferences so I could see the balance control. It was in the middle. I started changing the volume up and down, with rapid changes from going up to going down using the volume keys on the keyboard. Once the balance slider went all the way to the right but then snapped back to the middle. A little later it went to the right and stayed there. Definitely a bug, minor but annoying.
  6. dolphin842 macrumors 65816


    Jul 14, 2004
    Hmm... it might not be restricted to the volume keys either, since I'm using a 3rd party keyboard that doesn't have volume keys. Ah well, so long as it's infrequent I don't mind.
  7. Laser47 macrumors 6502a


    Jan 8, 2004
    Wow, I can definately vouch for it being keys. I just tried this on my ibook changing the volume all the way up then down multiple times. Then opened up control panel and tada the balance is all the way left. I cant believe apple hasint fixed this yet.

    Attached Files:

  8. Sirus The Virus macrumors 6502a

    Sirus The Virus

    May 12, 2005
    I hope they fix this soon. This is super annoying.
  9. devman macrumors 65816


    Apr 19, 2004
    yikes. my balance was off to the left also. PB15.
  10. VanNess macrumors 6502a


    Mar 31, 2005
    I remember that happened to me a few times as well (but not to the point where it moved to the extreme left or right, usually it shifted about a quarter or so off-center).

    It rarely happened anyway and it hasn't occured at all for me since the 10.4.3 update.
  11. dolphin842 macrumors 65816


    Jul 14, 2004
    It's weird... it's only happened once to me, yet for others it happens more often. When it happens it shifts in varying degrees to the left or right. I've tried to provoke it by switching the volume up and down a lot, but to no avail. It makes you wonder how deep and obfuscated the bug might be, and why Apple hasn't tackled it yet.
  12. ifjake macrumors 6502a

    Jan 19, 2004
    oh good i posted at Apple about this and never got a response. i'm glad that it's not just me then. and i also have a PB15.

    it's only a minor annoyance to me. it's a bug that you can fix yourself. well... maybe not fix, but make right again. besides i use an Airport Express for music, so i usually miss it until i put on headphones and wonder why one of my ears are going deaf.
  13. StokeLee macrumors 6502


    May 30, 2005
    Stoke-on-Trent. Midlands, UK
    I have this problem on my iMac, but only with my internal speakers, the sound will just go to the left speaker, while iTunes is on, or eyetv, or quicktime, but then say when i get a system noise, like say a contact on msn, it "pops" to both speakers. Dead annoying, called apple care, no luck, done all the usual things, pram and stuff.

    But the strange this is that its only my internal speakers, my iMac is connected up to my AV receiver, and works perfectly that way :confused:
  14. telecomm macrumors 65816


    Nov 30, 2003
    Yeah, this has been an ongoing problem since... umm... the dawn of time... Well, that's how it feels, anyway.

    People seem to complain about this every time there's an OS update, with comments like "I can't believe Apple hasn't fixed the audio bug yet."
  15. jthomson macrumors newbie

    Feb 6, 2006
    Another fix

    This bug has been bothering me forever.

    Balanced is another script which might fix the problem (it appears to work, but I haven't tested it extensively). The app linked above works within iTunes only.
  16. PlaceofDis thread starter macrumors Core

    Jan 6, 2004
    thanks for the link and info. i'll give it a shot too. won't hurt at least.
  17. iMeowbot macrumors G3


    Aug 30, 2003
    I've been running balanced since May or so and it's taken care of the problem well.
  18. Soulstorm macrumors 68000


    Feb 1, 2005
    Same thing happens for me. It happens since I had Jaguar installed.
  19. Dalriada macrumors 6502

    Aug 26, 2004
    Moorlough Shore
    Believe this has been discussed at length over here and I think it was Vanilla who made a lot of noise over at Apple Support at that time. It is amazing no fix still available.

    - Dal
  20. telecomm macrumors 65816


    Nov 30, 2003
    That's a different issue—with the PB 15s, the balance is thrown off by the placement of the "mid-range enhancing" third speaker.

    This issue (as far as I know) affects all laptops, and is software related. (The balance slider actually gets repositioned for no apparent reason.)
  21. le sacre macrumors regular

    Apr 20, 2004
    sf, ca, usa

    i had this on my old pb g4, and am rather shocked to see it persist on my brand new macbook pro c2d. what's up? we have to wait until leopard to get audio balance that stays in one place?
  22. Nermal Moderator


    Staff Member

    Dec 7, 2002
    New Zealand
    I used to have this problem a lot (back around the time that the thread was originally posted) but I haven't seen it in months. I could've sworn that it was in the patch notes for one of the updates, so check that you have all of them.

Share This Page