10.5.2 makes Boot Camp volume appear on desktop with "Hard disks" display off

Discussion in 'OS X' started by timelord726, Feb 11, 2008.

  1. macrumors member

    Joined:
    Nov 4, 2007
    Location:
    Maryland, USA
    #1
    In 10.5.1, I had my Desktop set so that internal hard drives would not show up, but CDs, DVDs, external drives, etc. would. When it was set up like this, my Mac HD and my Boot Camp volume both remained hidden from my desktop, keeping it completely clear as long as no external devices were connected.

    Since upgrading to 10.5.2, however, even with the same settings, only my Mac HD is hidden from the desktop -- my Boot Camp volume still appears there, even though display of "Hard disks" in the Finder preferences is turned off.

    Bizarrely, the checkbox that does hide my Boot Camp volume from the desktop is "CDs, DVDs, and iPods." My Boot Camp partition is none of those (it still appears as a normal hard disk with appropriate icon on the desktop), and I don't want to have to turn their display off to keep it hidden. Is there any way I can have my Boot Camp volume once again recognized as a hard disk instead of a CD/DVD/iPod?

    [​IMG]
     
  2. macrumors 6502

    Joined:
    Aug 9, 2007
    Location:
    Allentown, PA
    #2
    Ditto on this. I'm looking for a fix as well.
     
  3. macrumors 6502

    Joined:
    Mar 25, 2004
    #3
    Bootcamp partition disappears when you uncheck "CDs, DVDs & iPod"
     
  4. macrumors 6502

    Joined:
    Aug 9, 2007
    Location:
    Allentown, PA
    #4
    I'm aware of that, but I would also like CDs, DVDs, and iPods to show on my desktop. The Boot Camp partition should go away with the Hard Drive.
     
  5. thread starter macrumors member

    Joined:
    Nov 4, 2007
    Location:
    Maryland, USA
    #5
    I pointed this out in my original post. To me, this is not an acceptable solution. It is neither a CD, DVD, nor iPod.
     
  6. macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #6
    this is happening for me to. im wondering if you guys have Paragon's NTFS for Mac OS X installed? 10.5.2 hosed this too.
     
  7. thread starter macrumors member

    Joined:
    Nov 4, 2007
    Location:
    Maryland, USA
    #7
    Excellent point! I do in fact have Paragon's NTFS driver installed. This is probably what's causing the problem, which means we'll likely have to wait for Paragon to issue a fix for it. Is there any way to report this to them?
     
  8. macrumors 6502

    Joined:
    Aug 9, 2007
    Location:
    Allentown, PA
    #8
    Nope, I don't have that software, but my drive is formated NTFS.
     
  9. thread starter macrumors member

    Joined:
    Nov 4, 2007
    Location:
    Maryland, USA
    #9
    Interesting. There goes my theory...

    So then this goes back to Apple's realm.
     
  10. macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #10
    i remember this happened in 10.5.0 and then it sorted itself out and the Boot Camp partition disappeared when leaving the CDs & iPods option ticked.

    theres always a workaround though :) boot into windows and rename Local Disk C to ".anything". this will make the boot camp partition disappear from the desktop but also from the Finder too.
     
  11. macrumors member

    Joined:
    Jun 27, 2006
    #11
    I feel that you should have the option of hiding each icon individually, as I'd like to keep my "Macintosh HD" icon, as well as CDs DVDs and iPods, and hide my Boot Camp partition icon.
     
  12. macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #12
    you can do this by doing what i said in the post above yours.
     
  13. macrumors 604

    thejadedmonkey

    Joined:
    May 28, 2005
    Location:
    Pa
    #13
    Anyone ever find a fix for this, besides putting a . in-front of the name?

    I tried the . fix, but it keeps it in the finder sidebar, causing it to just look weird.
     

Share This Page