10.5.6 USB Issues on Air?

Discussion in 'MacBook Air' started by xerikx, Dec 15, 2008.

  1. macrumors regular

    Joined:
    Sep 19, 2007
    #1
    Anyone else having issues? I've tried three different thumb drives and none appear in the disk utility. They're all blinking when plugged in
     
  2. macrumors 604

    SFStateStudent

    Joined:
    Aug 28, 2007
    Location:
    San Francisco California, USA
    #2
    I just tried all four of my SanDisk 2GB, 4GB, 8GB x 2 and they popped-up no problem. Transferred files to each one w/o incident...
     
  3. thread starter macrumors regular

    Joined:
    Sep 19, 2007
    #3
    Hmm, weird, I tried a SanDisk, Toshiba, Patriot, and Iron Key all formatted FAT and previously worked

    My iPhone can sync though
     
  4. macrumors 604

    SFStateStudent

    Joined:
    Aug 28, 2007
    Location:
    San Francisco California, USA
    #4
    I just upgraded to 10.5.6 on my MBA, Mac Pro, MBP and they all are working just fine. I transferred about 750MB of data with each of my thumb drives as a test and they are working just fine. I just plug into the USB port and the thumb drive flashes four times; I open the thumb drive; then close it; then eject it by click, drag, and release to the trash can/eject icon and it flashes four times and then I remove the thumb drive..:(
     
  5. macrumors 6502a

    Ironic

    Joined:
    Oct 6, 2008
    Location:
    In my MBA!
  6. thread starter macrumors regular

    Joined:
    Sep 19, 2007
    #6
    Figures it's just me, guess I'll restore a time machine backup tomorrow!
     
  7. macrumors 604

    SFStateStudent

    Joined:
    Aug 28, 2007
    Location:
    San Francisco California, USA
    #7
    Keep us updated...
     
  8. macrumors 603

    HLdan

    Joined:
    Aug 22, 2007
    #8
    Yep, I'm afraid it's just you. My Sandisk 8GB USB stick works great after the OS X update.
     
  9. thread starter macrumors regular

    Joined:
    Sep 19, 2007
    #9
    It was, I ran a permissions repair and I guess the update left the permissions incorrect on the USB daemon and it's all working now.

    Thanks guys!
     
  10. macrumors regular

    Joined:
    Sep 17, 2008
    #10
    I think I'm having the same problem as you. Earlier today, I did a clean reinstall and maybe was trying to do too many things at the same time (Boot Camping TinyXP and running System Update) -- and now my USB port isn't working. There's power running on it (i.e. my iPhone is getting recharged), but nothing actually works when plugged in.

    I just repaired permissions, and it detected the same USB daemon problem as you probably had. However, after restarting the computer, nothing has changed except that Disk Utility doesn't detect any errors with permissions. Did you have to do anything else to make USB work again?
     
  11. macrumors regular

    Joined:
    Sep 17, 2008
    #11
    Another strange thing is that I can't access the Apple Hardware Test via either of the usual ways (power on while holding D or F2). I also can't access my OS X DVD either because my USB port isn't working (i.e. I can't access the CD/DVD drive).

    Anyone got any tips on how to proceed? Unfortunately, I suspect a call to Apple may be in order... :(


    EDIT: I've tried resetting the NVRAM (option+cmd+r+p), as well as doing another clean reinstall of OS X using remote disk. Neither have done anything. Safe mode doesn't make it better either.

    Any other suggestions would be more than welcome...


    EDIT #2: Just in case anyone is following this in the future, it turned out to be that the USB/hatch cables needed to be reseated. Completely un-software-related, despite the fact that it appeared to stem from my system update and attempted Boot Camp installation.
     

Share This Page