10.8.2 broke text replacement in safari

Discussion in 'OS X Mountain Lion (10.8)' started by Pagemakers, Sep 24, 2012.

  1. macrumors 65816

    Joined:
    Mar 28, 2008
    Location:
    Manchester UK
    #1
    Ever since upgrading to 10.8.2 text replacement is broken in Safari.

    To confirm this go to a website where you can enter text (like this forum).

    Make sure edit/substitutions/text replacement is checked in Safari.

    Make sure you have some auto-replace text in system preferences/language and text. In the box on the left add "i" and tell it to substitute it for "I".

    Now in Safari start typing away. In your sentence enter the letter i and it should replace to the letter I, but as you continue to type the curser jumps back a few words.

    It never used to happen before 10.8.2
     
  2. macrumors member

    Joined:
    Jul 27, 2012
    #2
    Strange, it works fine for me. Do you want to capture it in a video so we can see how you had the problem?
     
  3. thread starter macrumors 65816

    Joined:
    Mar 28, 2008
    Location:
    Manchester UK
    #3
    OK. Here is a video of the bug. Look what happens to the cursor when I type the letter "i". You can see it jumps back into the text after it has used text replacement.

    If I turn text replacement off, all is good.

    I have 6 Macs here. Some Mac Pros, some iMacs and some Macbook Airs and they all do it since 10.8.2 was installed a couple of days ago.

    1st video is the settings.
    2nd is the bug.
     

    Attached Files:

    • Bug.zip
      File size:
      2.2 MB
      Views:
      20
  4. macrumors member

    Joined:
    Jul 27, 2012
    #4
    Confirmed! It's the same on mine. Haha funny how the cursor jumps backward. I presume if you don't replace "i" with "I" then the bug doesn't happen? Probably have to wait till there's a fix by Apple
     
  5. thread starter macrumors 65816

    Joined:
    Mar 28, 2008
    Location:
    Manchester UK
    #5
    It happens when any words replaces. I have hundreds... EG: eth to the,cant to can't, mm to my@myemailaddress.com etc etc
     
  6. macrumors member

    Joined:
    Jul 27, 2012
    #6
    Also sometime substitution works for me and sometime it doesn't. So strange.
     
  7. thread starter macrumors 65816

    Joined:
    Mar 28, 2008
    Location:
    Manchester UK
    #7
    Sadly the latest incremental update has not fixed the problem.
     
  8. macrumors member

    jtrwallace

    Joined:
    Jul 4, 2007
    Location:
    Maui, Hawaii
    #8
    I have the same issue!

    This is maddening. I thought for sure I had some extension causing this but you guys think it is just with 10.8.2? Every time I have a substitution, after the next word I type the cursor jumps to the beginning of that next word. I then have to do command + right arrow to get to the correct cursor position. It drives me crazy.
     
  9. thread starter macrumors 65816

    Joined:
    Mar 28, 2008
    Location:
    Manchester UK
    #9
    On our 5 macs here it has worked perfectly for years. Then when the 10.8.2 upgrade came out it broke on every machine.
     
  10. macrumors newbie

    Joined:
    Oct 13, 2012
    #10
    Same here !

    And you don't know how it's annoying especially when you're French … :)
    I had the habit not to type any accent (café, voilà, …), to type quotation marks " (they're replaced by French ones «» or English ones “” depending) and to make some mistakes obviously.
    I've got also many shortcuts like : rdv = rendez-vous/min = minutes/fb = Facebook/cmd+ = ⌘/…, set in OS X System Preferences.
    Now I've disabled everything since the curser goes back few letters before or even disappear. The replacement system is also slowed/laggy.
    I don't remember if it has started since 10.8.2 or 10.8, perhaps 10.8.2.

    Hoping it'll be soon fixed (like the transparent Dock issue, they're my only complaint about Mountain Lion).
     
  11. macrumors newbie

    Joined:
    Sep 6, 2009
    #11
    I am just glad you figured out that text replacement is the issue so I can turn it off and not loose my mind. I was opening Text Edit and typing in there and copy paste into Safari.
     
  12. thread starter macrumors 65816

    Joined:
    Mar 28, 2008
    Location:
    Manchester UK
    #12
    Sadly it's not been fixed in the latest Safari update.
     
  13. macrumors 68020

    ouimetnick

    Joined:
    Aug 28, 2008
    Location:
    Beverly, Massachusetts
    #13
    same issue here. Pretty lousy on Apple's part.

    I this?goof they did why ..this broke apple think
     

Share This Page