10.8.2: Randomly Unable to Save to Hard Drive

Discussion in 'OS X Mountain Lion (10.8)' started by ObeseSquirrel, Feb 10, 2013.

  1. macrumors regular

    Joined:
    Nov 22, 2011
    #1
    I have had this bug intermittently since October, or roughly around the release of the current version of 10.8.2. Sometimes, especially when I have moved my laptop from one location to another, my Mac will lose the ability to save to the hard drive, and I may also lose access to the keychain and the ability to open new apps.

    I posted more about this error here, but I have not been able to find an answer, or even other complaints about this:
    https://discussions.apple.com/message/20446905#20446905

    I've attached a photograph from my Console as well. I had to take a picture because I lose the ability to save to my hard drive, and when I restart my computer, the Console messages are gone. I restarted my computer so that I would know which messages had appeared after I had lost connection to the hard drive.

    When I rebooted my computer, everything in the Console starting at 7:04 had disappeared. (So the error began between 7:01 and 7:04.)

    Any ideas?
     

    Attached Files:

  2. macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #2
    That looks like a failing hard drive. But it could also be a very odd permissions problem. I suggest backing up your data and reinstalling Mac OS X making sure to wipe the drive before installation.
     
  3. thread starter macrumors regular

    Joined:
    Nov 22, 2011
    #3
    I have a Corsair Performance Pro SSD. Disk Utility finds nothing, and I have even tried Terminal "resetpassword" command that can supposedly fix permissions for all files, not just the system files. Earlier, I had reinstalled OSX as well, though it was not a clean install.

    Yesterday, I had been watching videos in my apartment unplugged, and the laptop became disconnected when I plugged the laptop back in, and reconnected my Time Machine Drive. (I knew because I had lost my keychain password access to my Time Machine drive.)

    It also seems to happen when I bring my laptop to class and there is a wifi problem. (sometimes, because I have lost keychain access, but other times the wifi is just down, and the other Macs in the room are disconnected as well.) Other times, it just happens randomly, but the majority of the time, it seems correlated with connecting to a new wifi network or else to a new external drive.)

    The Console seems like one of the few apps that I actually can open after this happens. Sometimes, a particular app will crash, but not always.
     
  4. macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #4
    SSD's can still fail in similar ways to a hard drive with bad sectors. The resetpassword command does not reset permissions, it only changes the permissions for the user's folder whose password you're resetting.
     
  5. thread starter macrumors regular

    Joined:
    Nov 22, 2011
    #5
    Is there a good way to test my SSD for bad sectors without resorting to a clean install?
     
  6. Guest

    Joined:
    Apr 17, 2005
    Location:
    Currently in Switzerland
    #6
    Try Safe Booting your Mac (with shift pressed) and then rebooting normally again - let us know if this helps.
     
  7. thread starter macrumors regular

    Joined:
    Nov 22, 2011
    #7
    I've done that multiple times already. No change, though it may stop it for a little while. :(

    EDIT: If it happens again, I'll try to post another Console message, though from what I can see, the Console isn't saying much, besides that logs and mail items are failing to save to disk (I think).
     
  8. Guest

    Joined:
    Apr 17, 2005
    Location:
    Currently in Switzerland
    #8
    Then I would also recommend you back up everything and perhaps try reformatting the whole enchilada.

    I/O errors are normally the sign of something more serious.

    Have you tried checking their SMART status?
     
  9. ObeseSquirrel, Feb 10, 2013
    Last edited: Feb 10, 2013

    thread starter macrumors regular

    Joined:
    Nov 22, 2011
    #9
    It says "Verified" in Disk Utility. I do have Trim Enabler working, though I'm not sure if that would cause a problem.

    By "something more serious" do you mean hardware-related? Would erasing the disk and then reinstalling from my Time Machine be a good idea, or do you mean a completely fresh install? (Reformat the disk, and move files back individually)

    EDIT: I see the Disk I/O error seems to always refer to a temporary items folder for mail. Is it safe to delete that?
     
  10. Guest

    Joined:
    Apr 17, 2005
    Location:
    Currently in Switzerland
    #10
    Disable TRIM Enabler - it's been reported to cause instability to many people, AND OWC specifically recommends AGAINST using it in any of SandForce drives. If your SSD already has garbage collection, you don't need it.

    In any case and at the very least, try disabling it for now and see if the problem disappears.
     
  11. thread starter macrumors regular

    Joined:
    Nov 22, 2011
    #11
    My understanding is that TRIM and garbage collection are different though. Garbage collection moves data around so it is more efficiently clustered in your SSD, while TRIM cleans out the deleted parts.

    It happened again today, and I may have an idea of what's causing it. (Just an idea, though. I could be wrong.) When I eject my Time Machine Drive, the icons are supposed to disappear from my Desktop and my Finder to show that it has been ejected. Before 10.8.2, this happened normally, but since that update, the disks have taken longer to actually eject than it would appear. So my computer would show that my disks had ejected, but if I unplugged them, I would get an alert that my disks were ejected improperly. To eject properly, I would have to wait much longer than normal for it to happen.

    The other day, I was running on battery power at my apartment, and I had unplugged my Time Machine drive too soon (but after it should have been ejected). When I plugged my Time Machine and my power back in, the problem occurred. This morning, on my way to school, I had unplugged my Time Machine relatively quickly, but not so fast enough to give me an improper eject message. When I opened my laptop at school, the computer had forgotten my wifi password, and sure enough, I could not save to disk. Restart, and I was fine. I believe that I had recently had some improper eject messages soon before the I/O had gone out, even though I had not unplugged my drive.

    Also, my Time Machine Drive is password encrypted, and signs in automatically with my Keychain, so that could explain the Keychain connection. (I guess?)

    This can't explain all of the times this has happened, but it may explain most of them. I'm just not sure. I'm thinking I will be extra careful with my external drives until hopefully 10.8.3 fixes this. Otherwise, I'll keep updates on my situation right here. :cool:
     
  12. macrumors 6502

    Joined:
    Jan 24, 2012
    #12
    I/O errors don't necessarily mean that the drive is bad, it means that the I/O operation failed. Most of the time on an HD, it's caused by a bad sector, but a bad or poorly connected cable can cause the exact same problem - it looks like a drive problem when it isn't one.

    Find the web site for Scannerz, go to their downloads section, and get the document that describes path isolation and troubleshooting with Scannerz. That could tell you how this problem could occur and how to isolate it, but I have no idea if their product works on SSDs. I would have thought that the controller on an SSD would be mapping out bad blocks anyway.
     
  13. Moderator

    SandboxGeneral

    Staff Member

    Joined:
    Sep 8, 2010
    Location:
    Detroit, Michigan
    #13
    You can get a mild check of it's status with SMART. Get the SMART Utility here. It works on SSD's just like HDD's.

    Next, or first, you should double check all the physical connections to the SSD. Be sure they're properly connected and not damaged.

    If you're still having the problem after the physical check, and you have access to an IBM PC, you can run Spinrite on it. "SpinRite's Level 1 is a read-only scan, and doing that on an SSD makes a lot of sense. Do a read-only scan of an SSD, it'll show the SSD's controller that it's got a problem reading a sector, and then it'll map that out or rewrite it in order to strengthen that sector, if possible. So that ends up being a value for SpinRite on solid-state drives." - Steve Gibson, Spinrite creator and from the Security Now podcast.

    If you can get the SSD into that IBM PC, run it only on level 1 or 2. You don't want levels 3 or 4 because those read and write which are great for HDD's, but not SSD's.

    I use Spinrite as a maintenance and data recovery utility on all my HDD's. Below is my old MBP HDD in a Dell PC with Spinrite working on it.

    Independent review of Spinrite (not me)

    [​IMG]

    [​IMG]

     
  14. thread starter macrumors regular

    Joined:
    Nov 22, 2011
    #14
    It seems like Scannerz does not support SSD's yet.

    Smart Utility shows my disk as "verified" but the short and long tests seem to hang my computer. (Like stuck on "2 minutes" for a couple of hours.) Connection seemed fine. I have an old HP laptop from c. 2005, but sadly, it's pre-SATA, so that is not an option (I think).

    And… it happened again. This time there was a storm and my school has having wifi problems. After closing my laptop and opening it again somewhere else, I got the error. This time, I recognized it because the "connect to wifi" window kept popping up, as I had no access to the KeyChain.

    This seems to usually happen with the same type of promptings, either after connecting or disconnecting an external drive, after waking from sleep, or after problems in the wifi problems. This makes me think it is something other than a normal hard drive dying, but beyond that, I am at a loss.

    Here are some pictures from today. Upon restart, everything starting at 12:56:08 was gone (meaning that the SSD had stopped writing to disk).
     
  15. Guest

    Joined:
    Apr 17, 2005
    Location:
    Currently in Switzerland
    #15
    Have you tried disabling TRIM Enabler at all?
     
  16. Moderator

    SandboxGeneral

    Staff Member

    Joined:
    Sep 8, 2010
    Location:
    Detroit, Michigan
    #16
    You can get an IDE to SATA adapter for cheap if you're serious about trying Spinrite. Here is one from Amazon.com for about $7.

    Do you have those pictures to post still?
     
  17. thread starter macrumors regular

    Joined:
    Nov 22, 2011
    #17
    Not yet. I'll do that if 10.8.3 doesn't fix this.

    If 10.8.3 doesn't end this, I might just try that. Looks easy enough.

    Got the pictures. Had trouble uploading them. Again, the I/O problem happened between 12:56:06 and 12:56:08.
     

    Attached Files:

  18. SandboxGeneral, Feb 12, 2013
    Last edited: Feb 12, 2013

    Moderator

    SandboxGeneral

    Staff Member

    Joined:
    Sep 8, 2010
    Location:
    Detroit, Michigan
    #18
    Why wait for 10.8.3? Disable TRIM now and see what happens. Are you using Groths? It's just a matter of flipping the switch to on or off.

    Have you done anything with your screensaver and/or do you have Aperture? I came across this thread based on one of the Console messages.
     
  19. Guest

    Joined:
    Apr 17, 2005
    Location:
    Currently in Switzerland
    #19
    I have already suggested that he disable TRIM Enabler and can't understand why he wouldn't do that just as an initial test - it's a matter of flicking the switch from ON to OFF...
     
  20. thread starter macrumors regular

    Joined:
    Nov 22, 2011
    #20
    Yes, it's Groths. The problem is that when 10.8.3 is released (I was assuming today or tomorrow) I would have TRIM disabled -and- 10.8.3, so I would not know that whether I fixed the problem. Not a big deal though. I'll disable it now, and if it happens again before 10.8.3, I'll know it isn't TRIM.

    Don't have Aperture. Computer is set never to sleep, and "put disk to sleep whenever possible" is deactivated because I've read this is bad for SSD's. I *do* have "wake for network access" activated though. I do not use a screen saver. My display just goes black.
     
  21. TheBSDGuy, Feb 14, 2013
    Last edited by a moderator: Feb 14, 2013

    macrumors 6502

    Joined:
    Jan 24, 2012
    #21
    1. Scannerz supports SSDs, otherwise it couldn't support Core Storage technology. To the best of my knowledge it treats even mounted disk images as valid drives. I don't know if it would be of any value to you, as the rest of this post will indicate.

    2. I've read some of your other posts on Apple as well as responders to it, and all the posts in this thread, and one thing begs the question: Is this an OS problem, and will an update fix it?

    IMHO you need to approach the problem in a logical manner, one step at a time. I would take the advice of BRLawyer and others BEFORE updating the OS, and disable TRIM enabler before proceeding.

    The problems you're having appear to be similar to those of faulty connections somewhere in the system. Unfortunately, the more I use Mountain Lion, the more I'm inclined to move back to Snow Leopard.

    Here are some of the problems I ran into when using an older version of iWeb and iPhoto that I imported to ML to try and update a simple and quite honestly pathetic little site I have for business purposes:

    1. iPhoto seems to have a mind of its own as to whether or not a camera is attached. Sometimes it sees it sometimes it doesn't. If it does see it and there are images to download, whether or not their recognized is a crap shoot. Sometimes iPhoto simply crashes or locks up.

    2. iWeb never exits cleanly. It exits with a crash, EVERY time. I can't really publish anything with it.

    3. There are reports of external hard drive driver problems existing with ML and Lion that simply didn't exist before, and they're serious too.

    The more I use ML the more buggy it appears. I remember that someone referred to Lion as Apple's "Vista Moment," but I'm beginning to believe it might be better to call it Apple's "Windows 95" moment.

    If the problems you were having were on a STABLE operating system, I'd be inclined to tell you the problems were likely related to a bad cable or connection in the system, but if my digital camera is exhibiting the exact same types of problems, it implies to me this is a kernel problem and this isn't really a stable operating system. This has gotten ridiculous.

    ... I also understand that the development team at Apple was given a whopping 2 weeks to test and debug an OS. Note that comment - an OS, not an application.

    In any case, good luck, and please let us know how things turn out.
     
  22. thread starter macrumors regular

    Joined:
    Nov 22, 2011
    #22
    http://www.scsc-online.com/Downloads_files/FAQ-2.pdf
    "24. Can Scannerz be used with SSDs or flash drives? Scannerz will treat these as if they're regular hard drives, but the results might be erratic. SSDs are a “moving target.” The technology and how the OS deals with SSDs is still emerging. Future releases of Scannerz will have better SSD support. Scannerz can still be used with either of these if the user suspects the problem is related to the hardware connectivity circuitry or certain sections of the devices are unreadable.

    I agree completely about the bugginess of Mountain Lion, but am glad that this may likely be an OS issue and not a hardware issue. It also seems like it is a problem with external connections somehow.

    Another problem I have been having (randomly started about 3 weeks ago) is that my Safari will go out of control with RAM usage after a few hours. This will happen all at once, and my RAM will fill up with Active Memory, before paging out. My swap file will reach 14-18GB before my computer becomes almost completely unusable and I have to restart Safari. I had had this problem in 10.8.1 (I think) and determined that the only way to stop it was to disable JavaScript (unworkable) but the problem eventually ended. Now it's back and I use the Webkit Nightlies without a problem. The only difference in functionality between Safari and Webkit: Webkit has no access to the iCloud tabs…. Weird.

    I have disabled TRIM Enabler, so if it happens again, I will know that this was not problem.
     
  23. macrumors 68040

    xgman

    Joined:
    Aug 6, 2007
    #23
    Trim enabler is trouble.
     
  24. Moderator

    SandboxGeneral

    Staff Member

    Joined:
    Sep 8, 2010
    Location:
    Detroit, Michigan
    #24
    Would you elaborate please on your statement and back it up with examples and sources?
     
  25. Guest

    Joined:
    Apr 17, 2005
    Location:
    Currently in Switzerland
    #25
    The Internet is full of them - reports of crashes, slowdowns and overall instability when using TRIM Enabler. Not to mention OWC's own explicit recommendation to AVOID it whenever using SandForce-enabled SSDs.
     

Share This Page