15" Aluminum PB battery problem- please help!

Discussion in 'MacBook Pro' started by phreakout13, Nov 8, 2006.

  1. phreakout13 macrumors 6502

    phreakout13

    Joined:
    Jan 4, 2004
    Location:
    South Eastern MA
    #1
    Hello! I'm having an issue with my 15" 1.5ghz Aluminum Powerbook battery, and I haven't been able to find a solution on the forums or Google. My battery is almost two years old, and I've never had a problem with it until recently. All of a sudden for no apparent reason, it went from lasting for two or more hours to only about 30 seconds. When I use coconut battery, it says the battery is not charging, but my charger says otherwise. I've checked the connection on the battery, and it seems fine. I've already reset the PMU and the PRAM as well. I'm ready to get a new battery, but I'm not sure if I should until I figure out the problem. Could someone please help?

    Here's the coconut battery window
    [​IMG]
     
  2. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #2
    Yeah, that's quite typical dead battery behaviour. Sorry, but I think it's time for a new one. :(
     
  3. phreakout13 thread starter macrumors 6502

    phreakout13

    Joined:
    Jan 4, 2004
    Location:
    South Eastern MA
    #3
    Thanks maeng. Luckily I finally got a job, so that'll give me something to blow my money on:)
     
  4. Counterfit macrumors G3

    Counterfit

    Joined:
    Aug 20, 2003
    Location:
    sitting on your shoulder
    #4
    I'm quite happy with my battery from BTI. You got some pretty good life out of your battery though.
     

Share This Page