15" Powerbook G4 Screen is.. dim. Really dim.

Discussion in 'PowerPC Macs' started by silversyren, Oct 6, 2006.

  1. macrumors member

    Joined:
    Apr 9, 2006
    #1
    I think my backlight went out?

    I restarted and nothing. Still dim. I can barely, barely see things like if I hit expose, I can see shifting rectangles.

    Also, I've been having this issue where the keyboard mostly stopped working -- if I hit kjjh, it'll come up as 3443 or something. It's usually fixed with a restart.

    I have it covered by a year of applecare until feb 24, 2007 -- but I haven't registered it yet. Should I register and then call apple or what?

    This comes at a REALLY bad time. :( I have design projects coming up everywhere and of course, despite my $250 external hard drive, i haven't been backing things up because I'm an idiot.

    Can I hook it up to a external monitor just to make a backup of my hard drive?
     
  2. macrumors 68020

    Joined:
    Feb 12, 2005
    Location:
    VA
    #2
    Yes...if you can get the computer to actually work. It sounds like it's got a hardware problem.

    Did you purchase Applecare or is it still within the one year warranty? If you purchased Applecare at the time you purchased the PowerBook (new, that is), then you should be enrolled already. If not, you should call Apple ASAP.
     
  3. macrumors 603

    2nyRiggz

    Joined:
    Aug 20, 2005
    Location:
    Thank you Jah...I'm so Blessed
    #3
    Yes you can hook it up to an external monitor. Yes you should register and backup.


    Bless
     
  4. thread starter macrumors member

    Joined:
    Apr 9, 2006
    #4
    thanks guys.

    I just finished backing up my hard drive onto my external and I registered -- it's still covered under the one year applecare. Now I'm heading to the local shop that specializes in Apple Computers.. I called and they said they can fix it under the warrenty for me, so I'm hopeful.
     
  5. macrumors regular

    Pancake

    Joined:
    Apr 7, 2003
    Location:
    Anchorage, Alaska
    #5
    I think I gad the same problem you did shortly after I bought my 15" at the end of 2003. I sent it to Apple, and they replaced something or other and it has been working fine ever since.
     

Share This Page