17" PB Screen broke?

Discussion in 'Mac Pro' started by Jimme, Mar 8, 2006.

  1. Jimme macrumors newbie

    Joined:
    Mar 18, 2003
    #1
    Hi

    I have had my 17" PB Rev A. since apple released it..... been the perfect laptop for me, never had a single problem. It is now running 10.4.5.

    My main mac is my Dual 2.5 G5, however I still use the 17" occasionally when I go to other offices etc, today was such a day. I have a hard case for my PB (Zero Halliburton) which I use to transport it in, as such my PB has hardly a mark on it and is basically 'as new'.

    However.... today I took my PB with me incase I needed to do some work on the move, turns out I didn't even use it. So when I got home and found the screen was looking very very dodgy, I was 'suprised' to say the least. :cool:

    I have attached a pic to this post showing what it looks like... it does it from the very first grey boot screen (you can see it on the apple logo), I have plugged the PB into my Dell 24" Display and it outputs as normal, which makes me think the LCD in the PB is physically damaged, or the connectors etc.

    Can anyone shed any light on if its likely just a connector or the LCD itself.

    Thanks :)

    James
     

    Attached Files:

  2. calebjohnston macrumors 68000

    calebjohnston

    Joined:
    Jan 24, 2006
    #2
    As long as the screen didn't take any physical damage, I'm almost positive that's simply a problem with a connector - it's either loose or dead. Take it to an apple store and see what they tell you. Shouldn't be expensive to fix.
     

Share This Page