2.3Ghz DP G5 will not turn on. Updated: it turns on! But it's still teasing me...

Discussion in 'PowerPC Macs' started by quantum003, Mar 1, 2010.

  1. macrumors 6502a

    quantum003

    Joined:
    Apr 27, 2009
    Location:
    Superposition
    #1
    Hi guys,

    I have a question for all the G5 techs out there. I have a 2.3Ghz DP G5 (8 dimm slots) that I am eager to get running. It's not booting now, and it does NOTHING when I press the power button. (w/ both processors removed). In my other G5, when I plug in the external power cord it makes a very small "thunk" noise that I have heard before in these G5's; I think I have heard that the noise is a sign that the power supply is healthy. However, this G5 does not produce any noise at all when this machine is plugged in.

    I would be ready to pronounce the power supply dead, BUT, the main 24 pin connector to the mobo produces exactly a 5V power trickle. So now I'm scratching my head...

    I have no processors installed, but I should at least see the light on the front flash, or the inside red lights flash. I know the 2GB of RAM I have in the machine are good. Is it possible the motherboard is "grounded" or "not grounded" or something? I have heard of that type of thing before but not sure exactly what it means or how to trouble-shoot it. Any other thoughts or suggestions? (I have of course reset the PMU :D). Thanks!!
     
  2. macrumors 68040

    666sheep

    Joined:
    Dec 7, 2009
    Location:
    Poland
    #2
  3. macrumors 601

    OrangeSVTguy

    Joined:
    Sep 16, 2007
    Location:
    Northeastern Ohio
    #3
    You should at least hear the little click noise when you plug in the power to the PSU. But it won't do anything otherwise with no processors installed so it won't boot, no lights or anything.
     
  4. thread starter macrumors 6502a

    quantum003

    Joined:
    Apr 27, 2009
    Location:
    Superposition
    #4
    Thank you for the great link, I had to join that site. It's my kind of place. :)

    Great! Thanks for your post. So I shouldn't expect any sort of reaction w/o a working processor in the top CPU slot. Does the absence of a clicking sound alone condemn a PSU? What about the good trickle through the 24-pin connector?
     
  5. thread starter macrumors 6502a

    quantum003

    Joined:
    Apr 27, 2009
    Location:
    Superposition
    #5
    Well, I got somewhere with it last night! :D

    I've worked on 1.8Ghz G5's before, single and duals, and I know those machines will run with just one processor in place, and you don't even need to tighten the screws to test them out. So it never occurred to me that this 2.3Ghz G5 might not work the same way, but when I plugged in both processors and tightened the mounting screws, it did start up and chimed. That guy has been sitting in one garage or another for over the last year, so it was pretty cool to see it finally roar to life. :D

    BUT, the SOB still won't boot for me.

    Immediately after it started it up, I ran the A.S.D., and it passed all 66 tests. After it was finished, I chose "Restart", and the machine did restart... but no chime, no light on the front, nothing.... it just kind of sits there and idles, the fans run, but that's about it.

    So, it passes ASD, and it turns on, but the following failures are still happening:

    :apple: No startup chime
    :apple: No light on front, no red lights inside
    :apple: Will not respond to keyboard commands (PRAM etc)
    :apple: Will not produce any form of video

    But it certainly provided all of those things before A.S.D., until after the testing and a restart.

    :confused: What the heck... anyone have any suggestions for what I might try next? Thanks. :confused:
     
  6. macrumors 68040

    666sheep

    Joined:
    Dec 7, 2009
    Location:
    Poland
    #6
    It is certainly power problem :)
    Suspect are PSU and lobo (second one seems to me more possible after that what you wrote in last post).
    Best way to eliminate first is exchange PSU with working one (as you probably know ;)) It could be pulled out from any model except DC and watercooled ones. 450 or 600W, no matter.
    Or check voltages on PSU according to pinouts that i posted.

    I do not mention about PRAM battery replacing and PMU reset, cause you certainly done it before, correct?
     
  7. thread starter macrumors 6502a

    quantum003

    Joined:
    Apr 27, 2009
    Location:
    Superposition
    #7
    Thank you again for stopping in to help me out. :D

    I definitely have reset the PMU several times, but the fact is that I have not replaced the PRAM battery... it tested dead so I removed it from the machine entirely. Would that silly battery really keep the computer from booting though? I thought it's purpose was to continue tracking date and time when the computer was not plugged in to AC. :confused:

    I'll get a new one right away.... holy cow.

    When you say that you suspect the lobo is bad.... do you mean the Logic Board? Oh no... I was assuming the A.S.D. would have caught that, but it only tests the processors huh? That's so odd that it would boot the ASD CD, with video, chime, and everything else, but not boot again after the testing. So strange. I need to get one of those PRAM batteries ASAP now.
     
  8. macrumors 68040

    666sheep

    Joined:
    Dec 7, 2009
    Location:
    Poland
    #8
    In fact, G5 should work fine without battery but dead and almost dead could (but not must) produce minor issues.
    It's not only holds up RTC but also is related with onboard PMU, which controlls many functions of hardware: http://en.wikipedia.org/wiki/Power_Management_Unit

    By "lobo" i mean logic board/mainboard/mobo. Some series of PM G5 (1.8 single, 2.0 DP) had problems with logic boards.
    If you got any spare working PSU (or could borrow from somebody for tests), you should pretty quick isolate the reason of issue.

    ASD tests many things (RAM, CPUs, fans, thermal sensors and many more), but no power related components (like PMU) AFAIR.
     
  9. macrumors 601

    OrangeSVTguy

    Joined:
    Sep 16, 2007
    Location:
    Northeastern Ohio
    #9
    I have a working 600w PSU that you could borrow for testing purposes. PM me if interested.
     
  10. thread starter macrumors 6502a

    quantum003

    Joined:
    Apr 27, 2009
    Location:
    Superposition
    #10
    You are awesome. Thank you. It didn't occur to me that the onboard PMU might be powered by that tiny little battery... I remember that the older Macs will boot if you remove a bad battery, but not with a bad one in place, so I pulled it. I am feverishly looking for a battery...

    So you think it is a power related problem... it's just so odd that it booted up just great, ran the entire diagnostic test, and then after a restart the things that were just working no longer worked. No chime, video, etc. I figure it's got to be something small and weird, like that dippy little battery. Each time I reached inside the case, I removed the power cord. And then with no battery in to preserve the PMU settings... it's possible they could have been dropped each time?

    I will also test the other pins on that pesky power supply tonight. It has not been making that "clink" noise at all.

    :eek: That is an... incredibly... generous offer... :eek: I would like to take you up on that one actually. Would you want to make an eBay auction or something, so that I could paypal you the money for shipping, and a rental fee as well?
     
  11. macrumors 68040

    666sheep

    Joined:
    Dec 7, 2009
    Location:
    Poland
    #11
    I'm not sure about that.
    There is simple and clever trick, which sometimes works. You can try procedure described in links that i posted in this thread:
    http://forums.macrumors.com/showpost.php?p=9299019&postcount=65, then reset PMU and install new battery.
     
  12. thread starter macrumors 6502a

    quantum003

    Joined:
    Apr 27, 2009
    Location:
    Superposition
    #12
    Thanks for your suggestion, I will try it as soon as I get home tonight.

    The G5 is frustrating me greatly now. It occasionally will boot up as it should, but if I shut down or restart, it will not boot. There is no chime and no video, but it sounds perfectly normal otherwise- the light on the front comes on, the other G5 whooshing sounds I'm familiar with all occur- but the hard drive will not spin, or the CD drive will not start the machine booting, and no video is ever produced.

    I have started to think it must be bad logic or a bad power supply; perhaps the machine just isn't getting enough power. But corrupted firmware on the board would be a much more pleasant problem to have... wish I had the original install DVD's for this model... but I do not.
     
  13. thread starter macrumors 6502a

    quantum003

    Joined:
    Apr 27, 2009
    Location:
    Superposition
    #13
    Thanks for a great suggestion... tried but no improvement- and now the front light doesn't even come on. I'm going try swapping PSU's with a known good 600W that I have in a dual 1.8Ghz G5...
     
  14. macrumors newbie

    Joined:
    Jul 20, 2010
  15. macrumors newbie

    Joined:
    Jul 20, 2010
    #15
    tips

     

Share This Page