2 Build Errors

Discussion in 'Mac Programming' started by solutions, Oct 3, 2006.

  1. solutions macrumors newbie

    Oct 3, 2006

    I am new to Cocoa. I am trying to build an existing Xcode project. This file says to download and build the framework.

    http://henwen.cvs.sourceforge.net/henwen/HenWen2/How to build.rtf?revision=

    However, building the framework gives the following errors:

    _fegetround referenced from libSystem expected to be defined in /usr/lib/system/libmathCommon.A.dylib

    /usr/bin/libtool: internal link edit command failed

    Since the framework did not compile and I could not add it to the framework library, I got the source files from CVS and compiled those to see what happened. The terminal make commands worked. However, the project gives the following 2 errors:

    When compiling AMToolTipTableView.h:

    gcc-3.3: installation problem, cannot exec `cc1obj': No such file or directory

    and the same error for AMToolTipTableView.m.

    I have tried to search for the errors online and think that I need to change the gcc ppc and 1386 settings in the target settings. However, there is no GCC_Version Setting and when I create one and put the following in, it does not seem to work.

    GCC_VERSION_i386 = 4.0
    GCC_VERSION_ppc = 3.3

    I don't now if the latter errors are because I do not have the framework compiled and in the framework library, but if you can help with the first or second set of errors, I would appreciate it.

    Thank you!
  2. kainjow Moderator emeritus


    Jun 15, 2000
    What version of Xcode do you have? What's your OS version?
  3. solutions thread starter macrumors newbie

    Oct 3, 2006
    My X Code is version 2.3. The OS is 10.4.8.


Share This Page