20" iMac G5 (1.8ghz PPC single core) - not booting from DVD?

Discussion in 'PowerPC Macs' started by Great Satchmo, Jan 18, 2010.

  1. macrumors newbie

    I just picked up a PPC 1.8ghz 20" G5.

    Where I stand:

    I have put a brand new hard drive in the machine.

    I took off the plastic bezel to the power cord, to make sure it's plugging in all the way.

    I turned the computer on while watching the LED's on the logic board. All 3 stayed on, and the 4th never came on.

    I have unplugged it, left it unplugged for a few minutes, plugged the cord back in while holding the power, then turned it on (forgot what that was supposed to accomplish). No change.

    I have reset the PVRAM (or whatever) 3 times in a row by holding command-option-p-r until I heard 3 chimes after the initial boot. No change.

    I can get into open firmware, but have no idea what I could even try in there (other than ejecting the DVD).

    I hold down "C" while booting, it chimes, it goes to a blank grey background, then proceeds on to the white screen with the apple. It sits there for a few seconds, then starts spinning the circle for a while, then shuts down. I hear the optical drive spin up, but it does nothing.

    If I hold down the command key, it chimes, goes to a gray screen with a circular arrow on the left, an arrow pointing to the right on the right, then eventually a DVD icon with "OSX Install DVD" in the middle. I can't get it to move past there. It either proceeds to the white screen with the apple, and does the same sit then turn-off thing, or it just turns off.

    The DVD in there is an original Leopard (10.5) version of OSX. The computer had an earlier version on it before, but I don't know what that is, and the HDD in there now is blank from the manufacturer.

    At the end of a normal turn-on (not touching anything), what I get is:

    Chime, gray screen with face/flashing question mark (as I understand, looking for system files to boot to an OS), then to a white screen with an apple where it sits for a few seconds, then a circle starts spinning and it will do that for maybe 30 seconds to 90 seconds (very rough estimate), and then it will shut off.

  2. macrumors newbie

    open up the back panel and check to see if you have any popped capacitors. I just had a problem with my 17" imac 2.0ghz G5. One day I woke up and it wouldn't wake from sleep. after unsuccessfully trying to restart, I opened the back up. I found one capacitor had popped and had crusty stuff on top of it. Still hoping that it was just a dead hd, I went a bought a new one. Installed it. it worked, I was able to start installing the OS, when it got stuck on a blue screen. I opened up that back and found another cap had blown. I replaced both caps reinstalled the original hd and its worked great ever since.
  3. macrumors newbie

    I surveyed the board when I had it open to replace the HDD, and all of the caps looked clean and flat (no burnt or bulging caps). When I get a chance, I'll check them again, but I'm 99% sure they all look flat and clean.
  4. macrumors newbie

    Also, I am considering if it could be a power supply issue? The LED's seem to show that it's fine, but it shuts down at the end of the "cycle", or sometimes faster than that.

    However, I had a G5 iSight (intel) a bit back with a bad power supply, and that acted differently. That would work fine for a while when it was freshly turned on, but after it shut itself off it wouldn't turn on for more than a few seconds unless I unplugged it and let it sit for a while. This one just pops right back on, and will run the "long" cycle (chime, gray screen with flashing question mark, then white apple screen for a while, then shut down).
  5. macrumors 68040


    LED #4 should be off. It's correct. If comes "on" - it means overheating: http://support.apple.com/kb/HT2831.
    Do yo have retail version of Leopard (black disc with "X") or hardware dedicated (gray disc)? If it's retail, try to install system software putting iMacs HDD into other PPC Mac (if you have one) ad put HDD back to iMac. Or use external Firewire optical drive.
    If it will work, then replace internal burner. If you got gray disc(s), no luck will be, you must have retail version to install Leo on PPC.
  6. macrumors newbie

    mine lit up the three LED's too. even with the two caps blown.
  7. macrumors 68040


    you stated you just picked it up , which means i suppose that you bought it from someone, have you asked if he has fitted maybe a new superdive/combodrive
    because it wont boot if the jumper setting is on slave/cable select , it has to be jumpered as master , in order to be able to boot of it
    so has to be your hardrive jumpered as master , not cable select or slave
    so i know its a pain to open it up again , but you have to check it before you rip out other vital parts

    btw if the one changed the optical drive later after there was a os on the harddrive and forgot to check ,it will work on slave ,means it would play a dvd or cd, but wont boot of it , and some people just carboncopyclone the systems on the harddrives to save time ;) so they would not notice the difference ,

    had this problem on a emac it was working fine in every aspect apart form i could not bring a osx to boot from dvd,i opened it up and did want to change the opticaldrive as i thought i was broken and found the jumper setting slave , changed to master and everything was fine it booted straight away after hitting the c key
  8. macrumors 68040


    MacHamster: optical in iMac G5 got no jumpers and is working on his own ATA channel. There is no possibilty of conflict with anything cause HDD is SATA and optical drive is the only ATA device in this computer.
  9. macrumors 68040


    if it was changed it might not be a original drive and most drives have
    jumpers at the back
    never came across a drive without them
    and in the emac its also the only optical drive on that channel the hardrive is on a different channel, thats why both are master
    so i say its worth to check instead of buying a new psu or any other part , which might not be the cause of the problem
  10. macrumors newbie

    It's a black disk.

    I do not have another PPC (or even Mac) available.

    Do I need the external drive enclosure for the optical drive to be firewire (1394) to boot from? Or will a USB drive suffice?
  11. macrumors newbie

    What are symptoms of blown caps?

    I will try to get a chance to open it up tonight and look back over caps. If there is anything suspicious then I'll take a picture and post it, but nothing looked messed up when glanced before.
  12. macrumors newbie

    That was just about to be my question.

    Are all G5's this way? Or is it even worth checking for a jumper on the optical drive?
  13. macrumors newbie


    Alright, it does seem like something to give a shot. The guy I bought it from seemed to know his way around Macs, so I wouldn't put it past him to have replaced a part.

    I'll pull the optical and make sure it's jumpered for master.

    I'll also check for bulging/blown caps.

    I shall report back, but definitely toss more ideas my way! Greatly appreciated!
  14. macrumors 68040


    Yes, in all G5 optical is only PATA device.
    BTW, checking is always worth, at least to know how your computer is built ;), but in this case you will find no jumper.
  15. macrumors newbie

    Didn't find anything bulging/burnt/busted.

    Any other ideas?
  16. macrumors 68040


    Yes, firewire enclosure will be optimal. From USB usually it will not boot... but you can try this: http://www.macosxhints.com/article.php?story=20060301112336384 - your model is 1st gen of G5 iMac and it's not listed there, but it might work.

    Before trying this way, try SMU reset: http://support.apple.com/kb/HT1767 - but using button on logic board (last paragraph).

    I assume that you don't have original installation discs? Apple Hardware Test is usually on 1st. Unfortunately there is no possibility to download it from Apple support, but if you are in U.S. you can order it for S&H fee only: http://discussions.info.apple.com/thread.jspa?messageID=10861552
  17. macrumors newbie

    Hello I have this same problem, my imac 2005 17inch 1.6G has a blank hard drive and I need to reinstall the operating system back on it. But when insert the Mac OSX leopard cd replacement from apple the cd drive takes it in then puts it out what is with this I have also tryed to boot from a usb drive with the instructions from the above post and it did not work, Came to the apple logo and the spinning thing than after like 1 min it stopped and froze. Does anyone have any thoughts on what to do I have looked on a lot of forums and tryed several things but nothing. Any help would be much appreciated Thank you

Share This Page