2005-03 security update messed up Safari

Discussion in 'Mac Apps and Mac App Store' started by superbovine, Mar 21, 2005.

  1. superbovine macrumors 68030

    superbovine

    Joined:
    Nov 7, 2003
    #1
    After I updated with the security update, now I can't click on link in Safari. All i can do is view pages, and open them in new tabs/windows. I just tried reinstalling Safari. It didn't improve the situation.

    any thoughts on any files icon delete. i.e. ~/library/ or ~/home/library etc?
     
  2. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #2
    Umm... Sorry, I'm not fully with it today but I don't quite understand your problem. You can see pages but you can't click on them?
     
  3. superbovine thread starter macrumors 68030

    superbovine

    Joined:
    Nov 7, 2003
    #3
    I can type web page into the address bars but i can't follow any links unless I right click and open new window.

    more technically, anything with
    Code:
    <a href="".....></a>
    I can't left click or click and follow because nothing happens.
     
  4. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #4
  5. superbovine thread starter macrumors 68030

    superbovine

    Joined:
    Nov 7, 2003
    #5

    every place that you can on macrumors.com to take you another page does not work. that includes, quotes, ads, threads, images, etc.

    i.e.

    Code:
    <a href="*"></a>
    where * = every valid and invalid url.
     
  6. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #6
    That's a bit weird. It hasn't done that for me. Are you running any third-party pop-up blockers?
     
  7. superbovine thread starter macrumors 68030

    superbovine

    Joined:
    Nov 7, 2003
    #7
    you were almost right, it was a third party download assistant, namely igetter.
     
  8. rccola70 macrumors regular

    Joined:
    Oct 28, 2004
    Location:
    California
    #8
    ya i have the same problem..i can go to a site in a new window or tab but can't click on any links on them. (I can click and it will change colors but nothing happens).I doubt its PithHelmet which was working fine before..
     
  9. MXDT macrumors member

    Joined:
    Oct 19, 2004
    #9
    I have had only bad experiences with little modification add on Apps like that.
    I make it a point to stay away from little Apps as they only cause problems down the road.
     
  10. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #10
    Yeah, gotta agree with you on this one. They're great until Apple upgrades something that they haven't accounted for in their code. It's not their fault or anything, it's not like we can expect them to keep up with every little change in the OS instantaneously. On that note, most of them are fine after a while, once the developers have had a chance to make some changes. Still, most of them don't really offer anything that makes them all that worthwhile. I've been checking out all the 'free little apps' forums and trying the programs but so many of them just seem so unpolished.
     
  11. KingSleaze macrumors 6502

    Joined:
    Feb 24, 2004
    Location:
    So. Cal
    #11
    Well, since the Security Update did affect some elements in Safari, if you were using a third party 'upgrade' app on top of Safari.....then the Security Update probably did have something to do with Safari's failure to perform as it did before the Update. I just use Safari as issued and updated by Apple, and haven't had any problems since doing the update (OS 10.3.8).
     
  12. biohazard6969 macrumors 6502a

    biohazard6969

    Joined:
    Feb 23, 2005
    Location:
    toronto canada
    #12
    i havn't had the exact same problems but since i update, safari has been acting up and being an all around biatch, i get the beach ball ALL the time, and it freezesa up a lot when i do tabbed browsing, which i've grown accustomed to doing now
     
  13. rccola70 macrumors regular

    Joined:
    Oct 28, 2004
    Location:
    California
    #13
    kinda off topic but adium X seems to be crashing a lot too..every time i get an IM etc..
     

Share This Page